aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2002-01-22 21:15:31 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2002-01-22 21:15:31 +0000
commitddccf9d3eac8a1953810ea429a7a1703ce37ff75 (patch)
treeb73b130191ae30bed123105f0c4d7c73fdb8af7a
parent2213b0b336da16039448ab14b818854dd47f22fa (diff)
downloadports-ddccf9d3eac8a1953810ea429a7a1703ce37ff75.tar.gz
ports-ddccf9d3eac8a1953810ea429a7a1703ce37ff75.zip
o add PTHREAD_CFLAGS/LIBS to make libGL work.
o avoid autoheader running. PR: 34179 Submitted by: Kyle Martin (patch not used)
Notes
Notes: svn path=/head/; revision=53603
-rw-r--r--games/xracer/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/games/xracer/Makefile b/games/xracer/Makefile
index 2e8d43023789..dc989095b31d 100644
--- a/games/xracer/Makefile
+++ b/games/xracer/Makefile
@@ -19,10 +19,13 @@ USE_XLIB= yes
USE_MESA= yes
USE_GMAKE= yes
USE_AUTOMAKE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --disable-esd
+post-patch:
+ @${TOUCH} ${WRKSRC}/stamp-h.in
+
post-install:
@${ECHO} "===> Installing Tracks and Sound"
@${MKDIR} ${PREFIX}/share/xracer