aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-01-15 14:21:31 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-01-15 14:21:31 +0000
commit6ab4eea68a6299174c83bbae3eb60e8621180bdb (patch)
treeda9cadb27f478c5c98cb57ce5d41ba756e9f1be7
parent412523c3db6e9a0c7ea4a7356f8f21a2c8ec1164 (diff)
downloadports-6ab4eea68a6299174c83bbae3eb60e8621180bdb.tar.gz
ports-6ab4eea68a6299174c83bbae3eb60e8621180bdb.zip
Update to 1.60
PR: 24283 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=37219
-rw-r--r--graphics/epstool/Makefile11
-rw-r--r--graphics/epstool/distinfo2
-rw-r--r--graphics/epstool/files/patch-aa12
3 files changed, 16 insertions, 9 deletions
diff --git a/graphics/epstool/Makefile b/graphics/epstool/Makefile
index 400519f47767..770da15a9d44 100644
--- a/graphics/epstool/Makefile
+++ b/graphics/epstool/Makefile
@@ -6,19 +6,26 @@
#
PORTNAME= epstool
-PORTVERSION= 1.40
+PORTVERSION= 1.60
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.cs.wisc.edu/ghost/ghostgum/ \
ftp://ftp.fh-koblenz.de/pub/Ghostscript/ghostgum/
-DISTNAME= ${PORTNAME}-140
+DISTNAME= gsv36src
MAINTAINER= ports@FreeBSD.org
RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript55
WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_ZIP= yes
MAKEFILE= makefile.unx
+post-extract:
+.for file in epstool.zip src.zip
+ @cd ${WRKDIR} && unzip -q -aa ${file}
+.endfor
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/epstool
diff --git a/graphics/epstool/distinfo b/graphics/epstool/distinfo
index 355a3477ea3d..e19b30397593 100644
--- a/graphics/epstool/distinfo
+++ b/graphics/epstool/distinfo
@@ -1 +1 @@
-MD5 (epstool-140.tar.gz) = 42859819caa516364ff93337f56d7bdf
+MD5 (gsv36src.zip) = a410b200cd3f99590804eec071fb121a
diff --git a/graphics/epstool/files/patch-aa b/graphics/epstool/files/patch-aa
index e99640db8d18..30a22daf3976 100644
--- a/graphics/epstool/files/patch-aa
+++ b/graphics/epstool/files/patch-aa
@@ -1,13 +1,13 @@
---- makefile.unx.orig Sat Dec 5 04:05:34 1998
-+++ makefile.unx Fri Feb 25 04:42:20 2000
+--- makefile.unx.orig Mon Nov 6 09:58:48 2000
++++ makefile.unx Thu Jan 11 22:48:17 2001
@@ -20,13 +20,13 @@
RM=/bin/rm -f
SHELL=/bin/sh
-BINDIR=/usr/local/bin
--INCLUDES=-I/usr/openwin/include
+-INCLUDES=-I/usr/openwin/include -I../src -I.
+BINDIR=${PREFIX}/bin
-+INCLUDES=
++INCLUDES=-I../src -I.
LIBS=
# if you have a strict ANSI compiler, add -D__STDC__
DEFINES=-DUNIX -DEPSTOOL -DHAVE_UNISTD_H
@@ -15,9 +15,9 @@
-CC=gcc
+#CC=gcc
- OBJS=epstool.$(OBJ) gvceps.$(OBJ) ps.$(OBJ)
+ OBJS=epstool.$(OBJ) gvceps.$(OBJ) dscparse.$(OBJ) dscutil.$(OBJ)
-@@ -54,5 +54,5 @@
+@@ -61,5 +61,5 @@
-$(RM) epstool
install: epstool