aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-01-14 20:41:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-01-14 20:41:02 +0000
commite06a80eebec042c43e3d9e5e7ce92817109d4f36 (patch)
tree6c36a33fcd1e58d8700668ba087b6f8295634d23
parent6a83c602cb5a4249479963e0f643f50676ff94a4 (diff)
downloadports-e06a80eebec042c43e3d9e5e7ce92817109d4f36.tar.gz
ports-e06a80eebec042c43e3d9e5e7ce92817109d4f36.zip
- BUILD_DEPENDS -> LIB_DEPENDS
- Sort pkg-plist - Add WWW: line PR: ports/24287 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=37200
-rw-r--r--net-im/icb/Makefile22
-rw-r--r--net-im/icb/pkg-descr2
-rw-r--r--net-im/icb/pkg-plist4
-rw-r--r--net/icb/Makefile22
-rw-r--r--net/icb/pkg-descr2
-rw-r--r--net/icb/pkg-plist4
6 files changed, 30 insertions, 26 deletions
diff --git a/net-im/icb/Makefile b/net-im/icb/Makefile
index 9fef78942758..bfd936a21994 100644
--- a/net-im/icb/Makefile
+++ b/net-im/icb/Makefile
@@ -8,26 +8,26 @@
PORTNAME= icb
PORTVERSION= 5.1.0
-CATEGORIES= net
-MASTER_SITES= http://ftp.obfuscation.org/ftp/pub/icb/ \
+PORTREVISION= 1
+CATEGORIES= net tcl82
+MASTER_SITES= http://www.obfuscation.org/ftp/pub/icb/ \
ftp://ftp.obfuscation.org/pub/icb/
-DISTNAME= cicb-${PORTVERSION}
+DISTNAME= c${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tclinclude=${LOCALBASE}/include/tcl8.2 \
+ --with-tcllib=${LOCALBASE}/lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icb/icb ${PREFIX}/bin
- ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
- ${PREFIX}/share/icb
+ @${MKDIR} ${PREFIX}/share/icb
${INSTALL_DATA} ${WRKSRC}/icbserverdb ${PREFIX}/share/icb
- ${INSTALL_DATA} ${WRKSRC}/contrib/sample.icbrc \
- ${WRKSRC}/contrib/bartender \
- ${WRKSRC}/contrib/confuse \
- ${WRKSRC}/contrib/echofunctions \
- ${PREFIX}/share/icb
+.for file in bartender confuse echofunctions sample.icbrc
+ ${INSTALL_DATA} ${WRKSRC}/contrib/${file} ${PREFIX}/share/icb
+.endfor
.include <bsd.port.mk>
diff --git a/net-im/icb/pkg-descr b/net-im/icb/pkg-descr
index 517ea5464ea6..d652698d4d4b 100644
--- a/net-im/icb/pkg-descr
+++ b/net-im/icb/pkg-descr
@@ -4,5 +4,7 @@ features, and bots.
All-in-all, what it would be nice for IRC to be.
+WWW: http://www.obfuscation.org/icb/
+
-- David
(obrien@NUXI.com)
diff --git a/net-im/icb/pkg-plist b/net-im/icb/pkg-plist
index c561276a4f11..e4d2d5ff1616 100644
--- a/net-im/icb/pkg-plist
+++ b/net-im/icb/pkg-plist
@@ -1,8 +1,8 @@
@comment $FreeBSD$
bin/icb
-share/icb/icbserverdb
-share/icb/sample.icbrc
share/icb/bartender
share/icb/confuse
share/icb/echofunctions
+share/icb/icbserverdb
+share/icb/sample.icbrc
@dirrm share/icb
diff --git a/net/icb/Makefile b/net/icb/Makefile
index 9fef78942758..bfd936a21994 100644
--- a/net/icb/Makefile
+++ b/net/icb/Makefile
@@ -8,26 +8,26 @@
PORTNAME= icb
PORTVERSION= 5.1.0
-CATEGORIES= net
-MASTER_SITES= http://ftp.obfuscation.org/ftp/pub/icb/ \
+PORTREVISION= 1
+CATEGORIES= net tcl82
+MASTER_SITES= http://www.obfuscation.org/ftp/pub/icb/ \
ftp://ftp.obfuscation.org/pub/icb/
-DISTNAME= cicb-${PORTVERSION}
+DISTNAME= c${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tclinclude=${LOCALBASE}/include/tcl8.2 \
+ --with-tcllib=${LOCALBASE}/lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icb/icb ${PREFIX}/bin
- ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
- ${PREFIX}/share/icb
+ @${MKDIR} ${PREFIX}/share/icb
${INSTALL_DATA} ${WRKSRC}/icbserverdb ${PREFIX}/share/icb
- ${INSTALL_DATA} ${WRKSRC}/contrib/sample.icbrc \
- ${WRKSRC}/contrib/bartender \
- ${WRKSRC}/contrib/confuse \
- ${WRKSRC}/contrib/echofunctions \
- ${PREFIX}/share/icb
+.for file in bartender confuse echofunctions sample.icbrc
+ ${INSTALL_DATA} ${WRKSRC}/contrib/${file} ${PREFIX}/share/icb
+.endfor
.include <bsd.port.mk>
diff --git a/net/icb/pkg-descr b/net/icb/pkg-descr
index 517ea5464ea6..d652698d4d4b 100644
--- a/net/icb/pkg-descr
+++ b/net/icb/pkg-descr
@@ -4,5 +4,7 @@ features, and bots.
All-in-all, what it would be nice for IRC to be.
+WWW: http://www.obfuscation.org/icb/
+
-- David
(obrien@NUXI.com)
diff --git a/net/icb/pkg-plist b/net/icb/pkg-plist
index c561276a4f11..e4d2d5ff1616 100644
--- a/net/icb/pkg-plist
+++ b/net/icb/pkg-plist
@@ -1,8 +1,8 @@
@comment $FreeBSD$
bin/icb
-share/icb/icbserverdb
-share/icb/sample.icbrc
share/icb/bartender
share/icb/confuse
share/icb/echofunctions
+share/icb/icbserverdb
+share/icb/sample.icbrc
@dirrm share/icb