aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Dorfman <dd@FreeBSD.org>2001-08-11 18:33:24 +0000
committerDima Dorfman <dd@FreeBSD.org>2001-08-11 18:33:24 +0000
commit03a8e95530181902e0c1701d689e7d10484c8259 (patch)
treef02509adca744ebbb807b578bda554557fb8a806
parent0539131aa04f57040065064b449f2353bd637b7e (diff)
downloadports-03a8e95530181902e0c1701d689e7d10484c8259.tar.gz
ports-03a8e95530181902e0c1701d689e7d10484c8259.zip
Add xslint 005, an xSL(T) stylesheet checker maintained by Norman Walsh.
PR: 29470 Submitted by: Alex Kapranoff <kapr@crosswinds.net>
Notes
Notes: svn path=/head/; revision=46086
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/xslint/Makefile36
-rw-r--r--textproc/xslint/distinfo1
-rw-r--r--textproc/xslint/pkg-comment1
-rw-r--r--textproc/xslint/pkg-descr18
-rw-r--r--textproc/xslint/pkg-plist5
6 files changed, 62 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index e4e97e604ce8..05e010f3e0b4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -206,6 +206,7 @@
SUBDIR += xmlppm
SUBDIR += xp
SUBDIR += xsl-docbook-modular
+ SUBDIR += xslint
SUBDIR += xt
SUBDIR += y2l
SUBDIR += yodl
diff --git a/textproc/xslint/Makefile b/textproc/xslint/Makefile
new file mode 100644
index 000000000000..544d5aa414dd
--- /dev/null
+++ b/textproc/xslint/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xslint
+# Date created: 11 August 2001
+# Whom: Alex Kapranoff <kapr@crosswinds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xslint
+PORTVERSION= 005
+CATEGORIES= textproc perl5
+MASTER_SITES= http://nwalsh.com/xsl/xslint/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= kapr@crosswinds.net
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM
+
+USE_PERL5= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+post-patch:
+ ${PERL5} -pi -e 's,/usr/local/bin/perl5,${PERL},' ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xslint.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xslint.xml ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/xslint/distinfo b/textproc/xslint/distinfo
new file mode 100644
index 000000000000..9cbd1644c2dc
--- /dev/null
+++ b/textproc/xslint/distinfo
@@ -0,0 +1 @@
+MD5 (xslint005.zip) = 61c3483fc2ee7901e5cb2fdb3481c572
diff --git a/textproc/xslint/pkg-comment b/textproc/xslint/pkg-comment
new file mode 100644
index 000000000000..26f9ad0e458f
--- /dev/null
+++ b/textproc/xslint/pkg-comment
@@ -0,0 +1 @@
+XSL(T) stylesheet checker
diff --git a/textproc/xslint/pkg-descr b/textproc/xslint/pkg-descr
new file mode 100644
index 000000000000..97d48219a57f
--- /dev/null
+++ b/textproc/xslint/pkg-descr
@@ -0,0 +1,18 @@
+XSLint is an XSL lint checker. It reads an XSL stylesheet and looks
+for semantic errors.
+
+XSLint looks for:
+* an incorrect XSLT URI;
+* failure to provide a version;
+* duplicate match patterns;
+* modes that are used but never defined;
+* modes that are defined but never used;
+* named templates that are used but never defined;
+* named templates that are defined but never used;
+* templates that use name= where match= was probably intended;
+* xsl:call-template elements that contain anything other than xsl:with-param;
+* variable/parameter references that are not defined at the point of use;
+* fo: elements that aren't part of the XSL 1.0 PR;
+* fo: element properties that aren't part of the XSL 1.0 PR.
+
+WWW: http://nwalsh.com/xsl/xslint/
diff --git a/textproc/xslint/pkg-plist b/textproc/xslint/pkg-plist
new file mode 100644
index 000000000000..b41760b97224
--- /dev/null
+++ b/textproc/xslint/pkg-plist
@@ -0,0 +1,5 @@
+bin/xslint
+%%PORTDOCS%%share/doc/xslint/README
+%%PORTDOCS%%share/doc/xslint/xslint.html
+%%PORTDOCS%%share/doc/xslint/xslint.xml
+%%PORTDOCS%%@dirrm share/doc/xslint