aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-02 05:11:48 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-02 05:11:48 +0000
commit5878e8e7435b7980610d3b17a83ff21e51e8813a (patch)
treeaf76f61965ea0cc55405cbdeafecec8f966980f3
parent53f369dcd517195c267465b769824d76a69acd05 (diff)
downloadports-5878e8e7435b7980610d3b17a83ff21e51e8813a.tar.gz
ports-5878e8e7435b7980610d3b17a83ff21e51e8813a.zip
Fix the breakage with gcc 2.95.3 on -CURRENT by adding "-fpic" to
CFLAGS. Rqported by: Andrew Kenneth Milton <akm@mail.theinternet.com.au>
Notes
Notes: svn path=/head/; revision=37902
-rw-r--r--devel/SWIG-devel/Makefile3
-rw-r--r--devel/SWIG/Makefile3
-rw-r--r--devel/swig11/Makefile3
-rw-r--r--devel/swig13/Makefile3
-rw-r--r--devel/swig20/Makefile3
5 files changed, 10 insertions, 5 deletions
diff --git a/devel/SWIG-devel/Makefile b/devel/SWIG-devel/Makefile
index 25acdd95a647..8e0a56241c2c 100644
--- a/devel/SWIG-devel/Makefile
+++ b/devel/SWIG-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= ${VER}a5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel perl5 python ruby tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/ \
@@ -30,6 +30,7 @@ PYTHON_NO_DEPENDS= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
USE_LIBTOOL= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
CONFIGURE_ARGS= --with-tclincl=${PREFIX}/include/tcl8.2/ \
--with-tcllib=${PREFIX}/lib/tcl8.2/
ALL_TARGET= swig runtime
diff --git a/devel/SWIG/Makefile b/devel/SWIG/Makefile
index a6ab3e5328d1..67a5b8857609 100644
--- a/devel/SWIG/Makefile
+++ b/devel/SWIG/Makefile
@@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= ${VER}p5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel perl5 python tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/${VER}/ \
@@ -29,6 +29,7 @@ INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
CONFIGURE_ARGS= --with-tclincl=${PREFIX}/include/tcl8.2/ \
--with-tcllib=${PREFIX}/lib/tcl8.2/
ALL_TARGET= all runtime
diff --git a/devel/swig11/Makefile b/devel/swig11/Makefile
index a6ab3e5328d1..67a5b8857609 100644
--- a/devel/swig11/Makefile
+++ b/devel/swig11/Makefile
@@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= ${VER}p5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel perl5 python tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/${VER}/ \
@@ -29,6 +29,7 @@ INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
CONFIGURE_ARGS= --with-tclincl=${PREFIX}/include/tcl8.2/ \
--with-tcllib=${PREFIX}/lib/tcl8.2/
ALL_TARGET= all runtime
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index 25acdd95a647..8e0a56241c2c 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= ${VER}a5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel perl5 python ruby tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/ \
@@ -30,6 +30,7 @@ PYTHON_NO_DEPENDS= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
USE_LIBTOOL= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
CONFIGURE_ARGS= --with-tclincl=${PREFIX}/include/tcl8.2/ \
--with-tcllib=${PREFIX}/lib/tcl8.2/
ALL_TARGET= swig runtime
diff --git a/devel/swig20/Makefile b/devel/swig20/Makefile
index 25acdd95a647..8e0a56241c2c 100644
--- a/devel/swig20/Makefile
+++ b/devel/swig20/Makefile
@@ -7,7 +7,7 @@
PORTNAME= swig
PORTVERSION= ${VER}a5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel perl5 python ruby tcl82
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.rge.com/pub/languages/swig/ \
@@ -30,6 +30,7 @@ PYTHON_NO_DEPENDS= yes
INSTALLS_SHLIB= yes
WRKSRC= ${WRKDIR}/SWIG${PORTVERSION}
USE_LIBTOOL= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC"
CONFIGURE_ARGS= --with-tclincl=${PREFIX}/include/tcl8.2/ \
--with-tcllib=${PREFIX}/lib/tcl8.2/
ALL_TARGET= swig runtime