aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2000-04-15 17:20:47 +0000
committerSADA Kenji <sada@FreeBSD.org>2000-04-15 17:20:47 +0000
commit83cbb5e080b94e813cbd466b6c20035114c5c901 (patch)
treec3ed1fcfeed01058367dc98a397e9063fc89415e
parentf2fc8303fc46e6c0359264acc9b331045c7cad4d (diff)
downloadports-83cbb5e080b94e813cbd466b6c20035114c5c901.tar.gz
ports-83cbb5e080b94e813cbd466b6c20035114c5c901.zip
Linux gtk lib. Install gtk lib from rpm.
Notes
Notes: svn path=/head/; revision=27617
-rw-r--r--x11-toolkits/linux-f10-gtk/Makefile46
-rw-r--r--x11-toolkits/linux-f10-gtk/distinfo.i3861
-rw-r--r--x11-toolkits/linux-f10-gtk/pkg-comment1
-rw-r--r--x11-toolkits/linux-f10-gtk/pkg-descr1
-rw-r--r--x11-toolkits/linux-f10-gtk/pkg-plist.i38637
-rw-r--r--x11-toolkits/linux-f8-gtk/Makefile46
-rw-r--r--x11-toolkits/linux-f8-gtk/distinfo.i3861
-rw-r--r--x11-toolkits/linux-f8-gtk/pkg-comment1
-rw-r--r--x11-toolkits/linux-f8-gtk/pkg-descr1
-rw-r--r--x11-toolkits/linux-f8-gtk/pkg-plist.i38637
-rw-r--r--x11-toolkits/linux-gtk/Makefile46
-rw-r--r--x11-toolkits/linux-gtk/distinfo.i3861
-rw-r--r--x11-toolkits/linux-gtk/pkg-comment1
-rw-r--r--x11-toolkits/linux-gtk/pkg-descr1
-rw-r--r--x11-toolkits/linux-gtk/pkg-plist.i38637
15 files changed, 258 insertions, 0 deletions
diff --git a/x11-toolkits/linux-f10-gtk/Makefile b/x11-toolkits/linux-f10-gtk/Makefile
new file mode 100644
index 000000000000..5563c0413ac3
--- /dev/null
+++ b/x11-toolkits/linux-f10-gtk/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: linux-gtk
+# Version required: 1.2.x
+# Date created: 8 April 2000
+# Whom: sada@FreeBSD.org
+# Based on: emulators/linux_base by marcel@FreeBSD.org
+# & graphics/xmovie by sanpei@sanpei.org
+#
+# $FreeBSD$
+#
+
+PORTNAME?= gtk
+PORTVERSION?= 1.2
+CATEGORIES?= x11-toolkits linux
+MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+PKGNAMEPREFIX= linux-
+DISTFILES= ${RPM_SET}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= rpm:${PORTSDIR}/misc/rpm
+RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+
+DIST_SUBDIR= rpm
+EXTRACT_ONLY=
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+NO_MTREE= yes
+ONLY_FOR_ARCHS= i386
+PREFIX= /compat/linux
+
+RPM_MIRRORS= ftp://ftp.freesoftware.com/pub/linux/redhat/__DIR__/
+STDDIR= redhat-6.1/${MACHINE_ARCH}/RedHat/RPMS
+UPDDIR= updates/6.1/${MACHINE_ARCH}
+RPM_SET?= gtk+-1.2.5-2.${MACHINE_ARCH}.rpm
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+do-install:
+ @for R in ${RPM_SET}; do \
+ ${ECHO} $$R; \
+ rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
+ done
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/linux-f10-gtk/distinfo.i386 b/x11-toolkits/linux-f10-gtk/distinfo.i386
new file mode 100644
index 000000000000..68db97f99742
--- /dev/null
+++ b/x11-toolkits/linux-f10-gtk/distinfo.i386
@@ -0,0 +1 @@
+MD5 (rpm/gtk+-1.2.5-2.i386.rpm) = de064ec539a1bd6f2482e3c2fecde392
diff --git a/x11-toolkits/linux-f10-gtk/pkg-comment b/x11-toolkits/linux-f10-gtk/pkg-comment
new file mode 100644
index 000000000000..fa154b9e7fa0
--- /dev/null
+++ b/x11-toolkits/linux-f10-gtk/pkg-comment
@@ -0,0 +1 @@
+Rpm of Gtk lib.
diff --git a/x11-toolkits/linux-f10-gtk/pkg-descr b/x11-toolkits/linux-f10-gtk/pkg-descr
new file mode 100644
index 000000000000..dfc332ea769f
--- /dev/null
+++ b/x11-toolkits/linux-f10-gtk/pkg-descr
@@ -0,0 +1 @@
+A port of gtk-1.2 lib rpm.
diff --git a/x11-toolkits/linux-f10-gtk/pkg-plist.i386 b/x11-toolkits/linux-f10-gtk/pkg-plist.i386
new file mode 100644
index 000000000000..2ed872785be5
--- /dev/null
+++ b/x11-toolkits/linux-f10-gtk/pkg-plist.i386
@@ -0,0 +1,37 @@
+usr/doc/gtk+-1.2.5/AUTHORS
+usr/doc/gtk+-1.2.5/COPYING
+usr/doc/gtk+-1.2.5/ChangeLog
+usr/doc/gtk+-1.2.5/NEWS
+usr/doc/gtk+-1.2.5/README
+usr/doc/gtk+-1.2.5/TODO
+usr/lib/libgdk-1.2.so.0.5.0
+usr/share/locale/ca/LC_MESSAGES/gtk+.mo
+usr/share/locale/cs/LC_MESSAGES/gtk+.mo
+usr/share/locale/da/LC_MESSAGES/gtk+.mo
+usr/share/locale/de/LC_MESSAGES/gtk+.mo
+usr/share/locale/el/LC_MESSAGES/gtk+.mo
+usr/share/locale/es/LC_MESSAGES/gtk+.mo
+usr/share/locale/et/LC_MESSAGES/gtk+.mo
+usr/share/locale/eu/LC_MESSAGES/gtk+.mo
+usr/share/locale/fi/LC_MESSAGES/gtk+.mo
+usr/share/locale/fr/LC_MESSAGES/gtk+.mo
+usr/share/locale/ga/LC_MESSAGES/gtk+.mo
+usr/share/locale/hr/LC_MESSAGES/gtk+.mo
+usr/share/locale/hu/LC_MESSAGES/gtk+.mo
+usr/share/locale/it/LC_MESSAGES/gtk+.mo
+usr/share/locale/ja/LC_MESSAGES/gtk+.mo
+usr/share/locale/ko/LC_MESSAGES/gtk+.mo
+usr/share/locale/nl/LC_MESSAGES/gtk+.mo
+usr/share/locale/no/LC_MESSAGES/gtk+.mo
+usr/share/locale/pl/LC_MESSAGES/gtk+.mo
+usr/share/locale/pt/LC_MESSAGES/gtk+.mo
+usr/share/locale/pt_BR/LC_MESSAGES/gtk+.mo
+usr/share/locale/ru/LC_MESSAGES/gtk+.mo
+usr/share/locale/sk/LC_MESSAGES/gtk+.mo
+usr/share/locale/sl/LC_MESSAGES/gtk+.mo
+usr/share/locale/sv/LC_MESSAGES/gtk+.mo
+usr/share/locale/wa/LC_MESSAGES/gtk+.mo
+usr/share/locale/zh_TW.Big5/LC_MESSAGES/gtk+.mo
+usr/share/themes/Default/gtk/gtkrc
+@dirrm usr/share/themes/Default/gtk
+@dirrm usr/doc/gtk+-1.2.5
diff --git a/x11-toolkits/linux-f8-gtk/Makefile b/x11-toolkits/linux-f8-gtk/Makefile
new file mode 100644
index 000000000000..5563c0413ac3
--- /dev/null
+++ b/x11-toolkits/linux-f8-gtk/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: linux-gtk
+# Version required: 1.2.x
+# Date created: 8 April 2000
+# Whom: sada@FreeBSD.org
+# Based on: emulators/linux_base by marcel@FreeBSD.org
+# & graphics/xmovie by sanpei@sanpei.org
+#
+# $FreeBSD$
+#
+
+PORTNAME?= gtk
+PORTVERSION?= 1.2
+CATEGORIES?= x11-toolkits linux
+MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+PKGNAMEPREFIX= linux-
+DISTFILES= ${RPM_SET}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= rpm:${PORTSDIR}/misc/rpm
+RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+
+DIST_SUBDIR= rpm
+EXTRACT_ONLY=
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+NO_MTREE= yes
+ONLY_FOR_ARCHS= i386
+PREFIX= /compat/linux
+
+RPM_MIRRORS= ftp://ftp.freesoftware.com/pub/linux/redhat/__DIR__/
+STDDIR= redhat-6.1/${MACHINE_ARCH}/RedHat/RPMS
+UPDDIR= updates/6.1/${MACHINE_ARCH}
+RPM_SET?= gtk+-1.2.5-2.${MACHINE_ARCH}.rpm
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+do-install:
+ @for R in ${RPM_SET}; do \
+ ${ECHO} $$R; \
+ rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
+ done
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/linux-f8-gtk/distinfo.i386 b/x11-toolkits/linux-f8-gtk/distinfo.i386
new file mode 100644
index 000000000000..68db97f99742
--- /dev/null
+++ b/x11-toolkits/linux-f8-gtk/distinfo.i386
@@ -0,0 +1 @@
+MD5 (rpm/gtk+-1.2.5-2.i386.rpm) = de064ec539a1bd6f2482e3c2fecde392
diff --git a/x11-toolkits/linux-f8-gtk/pkg-comment b/x11-toolkits/linux-f8-gtk/pkg-comment
new file mode 100644
index 000000000000..fa154b9e7fa0
--- /dev/null
+++ b/x11-toolkits/linux-f8-gtk/pkg-comment
@@ -0,0 +1 @@
+Rpm of Gtk lib.
diff --git a/x11-toolkits/linux-f8-gtk/pkg-descr b/x11-toolkits/linux-f8-gtk/pkg-descr
new file mode 100644
index 000000000000..dfc332ea769f
--- /dev/null
+++ b/x11-toolkits/linux-f8-gtk/pkg-descr
@@ -0,0 +1 @@
+A port of gtk-1.2 lib rpm.
diff --git a/x11-toolkits/linux-f8-gtk/pkg-plist.i386 b/x11-toolkits/linux-f8-gtk/pkg-plist.i386
new file mode 100644
index 000000000000..2ed872785be5
--- /dev/null
+++ b/x11-toolkits/linux-f8-gtk/pkg-plist.i386
@@ -0,0 +1,37 @@
+usr/doc/gtk+-1.2.5/AUTHORS
+usr/doc/gtk+-1.2.5/COPYING
+usr/doc/gtk+-1.2.5/ChangeLog
+usr/doc/gtk+-1.2.5/NEWS
+usr/doc/gtk+-1.2.5/README
+usr/doc/gtk+-1.2.5/TODO
+usr/lib/libgdk-1.2.so.0.5.0
+usr/share/locale/ca/LC_MESSAGES/gtk+.mo
+usr/share/locale/cs/LC_MESSAGES/gtk+.mo
+usr/share/locale/da/LC_MESSAGES/gtk+.mo
+usr/share/locale/de/LC_MESSAGES/gtk+.mo
+usr/share/locale/el/LC_MESSAGES/gtk+.mo
+usr/share/locale/es/LC_MESSAGES/gtk+.mo
+usr/share/locale/et/LC_MESSAGES/gtk+.mo
+usr/share/locale/eu/LC_MESSAGES/gtk+.mo
+usr/share/locale/fi/LC_MESSAGES/gtk+.mo
+usr/share/locale/fr/LC_MESSAGES/gtk+.mo
+usr/share/locale/ga/LC_MESSAGES/gtk+.mo
+usr/share/locale/hr/LC_MESSAGES/gtk+.mo
+usr/share/locale/hu/LC_MESSAGES/gtk+.mo
+usr/share/locale/it/LC_MESSAGES/gtk+.mo
+usr/share/locale/ja/LC_MESSAGES/gtk+.mo
+usr/share/locale/ko/LC_MESSAGES/gtk+.mo
+usr/share/locale/nl/LC_MESSAGES/gtk+.mo
+usr/share/locale/no/LC_MESSAGES/gtk+.mo
+usr/share/locale/pl/LC_MESSAGES/gtk+.mo
+usr/share/locale/pt/LC_MESSAGES/gtk+.mo
+usr/share/locale/pt_BR/LC_MESSAGES/gtk+.mo
+usr/share/locale/ru/LC_MESSAGES/gtk+.mo
+usr/share/locale/sk/LC_MESSAGES/gtk+.mo
+usr/share/locale/sl/LC_MESSAGES/gtk+.mo
+usr/share/locale/sv/LC_MESSAGES/gtk+.mo
+usr/share/locale/wa/LC_MESSAGES/gtk+.mo
+usr/share/locale/zh_TW.Big5/LC_MESSAGES/gtk+.mo
+usr/share/themes/Default/gtk/gtkrc
+@dirrm usr/share/themes/Default/gtk
+@dirrm usr/doc/gtk+-1.2.5
diff --git a/x11-toolkits/linux-gtk/Makefile b/x11-toolkits/linux-gtk/Makefile
new file mode 100644
index 000000000000..5563c0413ac3
--- /dev/null
+++ b/x11-toolkits/linux-gtk/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: linux-gtk
+# Version required: 1.2.x
+# Date created: 8 April 2000
+# Whom: sada@FreeBSD.org
+# Based on: emulators/linux_base by marcel@FreeBSD.org
+# & graphics/xmovie by sanpei@sanpei.org
+#
+# $FreeBSD$
+#
+
+PORTNAME?= gtk
+PORTVERSION?= 1.2
+CATEGORIES?= x11-toolkits linux
+MASTER_SITES= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
+PKGNAMEPREFIX= linux-
+DISTFILES= ${RPM_SET}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= rpm:${PORTSDIR}/misc/rpm
+RUN_DEPENDS= /compat/linux/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+
+DIST_SUBDIR= rpm
+EXTRACT_ONLY=
+NO_BUILD= yes
+NO_FILTER_SHLIBS= yes
+NO_MTREE= yes
+ONLY_FOR_ARCHS= i386
+PREFIX= /compat/linux
+
+RPM_MIRRORS= ftp://ftp.freesoftware.com/pub/linux/redhat/__DIR__/
+STDDIR= redhat-6.1/${MACHINE_ARCH}/RedHat/RPMS
+UPDDIR= updates/6.1/${MACHINE_ARCH}
+RPM_SET?= gtk+-1.2.5-2.${MACHINE_ARCH}.rpm
+DBPATH= /var/lib/rpm
+RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
+ --nodeps --replacepkgs
+RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
+
+do-install:
+ @for R in ${RPM_SET}; do \
+ ${ECHO} $$R; \
+ rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
+ done
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/linux-gtk/distinfo.i386 b/x11-toolkits/linux-gtk/distinfo.i386
new file mode 100644
index 000000000000..68db97f99742
--- /dev/null
+++ b/x11-toolkits/linux-gtk/distinfo.i386
@@ -0,0 +1 @@
+MD5 (rpm/gtk+-1.2.5-2.i386.rpm) = de064ec539a1bd6f2482e3c2fecde392
diff --git a/x11-toolkits/linux-gtk/pkg-comment b/x11-toolkits/linux-gtk/pkg-comment
new file mode 100644
index 000000000000..fa154b9e7fa0
--- /dev/null
+++ b/x11-toolkits/linux-gtk/pkg-comment
@@ -0,0 +1 @@
+Rpm of Gtk lib.
diff --git a/x11-toolkits/linux-gtk/pkg-descr b/x11-toolkits/linux-gtk/pkg-descr
new file mode 100644
index 000000000000..dfc332ea769f
--- /dev/null
+++ b/x11-toolkits/linux-gtk/pkg-descr
@@ -0,0 +1 @@
+A port of gtk-1.2 lib rpm.
diff --git a/x11-toolkits/linux-gtk/pkg-plist.i386 b/x11-toolkits/linux-gtk/pkg-plist.i386
new file mode 100644
index 000000000000..2ed872785be5
--- /dev/null
+++ b/x11-toolkits/linux-gtk/pkg-plist.i386
@@ -0,0 +1,37 @@
+usr/doc/gtk+-1.2.5/AUTHORS
+usr/doc/gtk+-1.2.5/COPYING
+usr/doc/gtk+-1.2.5/ChangeLog
+usr/doc/gtk+-1.2.5/NEWS
+usr/doc/gtk+-1.2.5/README
+usr/doc/gtk+-1.2.5/TODO
+usr/lib/libgdk-1.2.so.0.5.0
+usr/share/locale/ca/LC_MESSAGES/gtk+.mo
+usr/share/locale/cs/LC_MESSAGES/gtk+.mo
+usr/share/locale/da/LC_MESSAGES/gtk+.mo
+usr/share/locale/de/LC_MESSAGES/gtk+.mo
+usr/share/locale/el/LC_MESSAGES/gtk+.mo
+usr/share/locale/es/LC_MESSAGES/gtk+.mo
+usr/share/locale/et/LC_MESSAGES/gtk+.mo
+usr/share/locale/eu/LC_MESSAGES/gtk+.mo
+usr/share/locale/fi/LC_MESSAGES/gtk+.mo
+usr/share/locale/fr/LC_MESSAGES/gtk+.mo
+usr/share/locale/ga/LC_MESSAGES/gtk+.mo
+usr/share/locale/hr/LC_MESSAGES/gtk+.mo
+usr/share/locale/hu/LC_MESSAGES/gtk+.mo
+usr/share/locale/it/LC_MESSAGES/gtk+.mo
+usr/share/locale/ja/LC_MESSAGES/gtk+.mo
+usr/share/locale/ko/LC_MESSAGES/gtk+.mo
+usr/share/locale/nl/LC_MESSAGES/gtk+.mo
+usr/share/locale/no/LC_MESSAGES/gtk+.mo
+usr/share/locale/pl/LC_MESSAGES/gtk+.mo
+usr/share/locale/pt/LC_MESSAGES/gtk+.mo
+usr/share/locale/pt_BR/LC_MESSAGES/gtk+.mo
+usr/share/locale/ru/LC_MESSAGES/gtk+.mo
+usr/share/locale/sk/LC_MESSAGES/gtk+.mo
+usr/share/locale/sl/LC_MESSAGES/gtk+.mo
+usr/share/locale/sv/LC_MESSAGES/gtk+.mo
+usr/share/locale/wa/LC_MESSAGES/gtk+.mo
+usr/share/locale/zh_TW.Big5/LC_MESSAGES/gtk+.mo
+usr/share/themes/Default/gtk/gtkrc
+@dirrm usr/share/themes/Default/gtk
+@dirrm usr/doc/gtk+-1.2.5