aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-16 04:30:28 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-16 04:30:28 +0000
commit8a5f39c62162866e0c0bebb3c268b0d34e41abe1 (patch)
tree4135516246792feff600da429749a5fd4f463e97
parentd0a8dad01e38336d74197b279983c8c248656ab6 (diff)
downloadports-8a5f39c62162866e0c0bebb3c268b0d34e41abe1.tar.gz
ports-8a5f39c62162866e0c0bebb3c268b0d34e41abe1.zip
Add mudix to net category, moved from games. Also upgrade to version 3.2.
And fix building on 4.0+, which have ncurses in the base, but unfortunately base ncurses is useless. Noted by; "Oleg V. Volkov" <rover@lglobus.ru> Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp> (fix for -current) Approved by: asami (in regards to no repo-copy)
Notes
Notes: svn path=/head/; revision=27636
-rw-r--r--net/Makefile1
-rw-r--r--net/mudix/Makefile23
-rw-r--r--net/mudix/distinfo1
-rw-r--r--net/mudix/files/patch-aa18
-rw-r--r--net/mudix/pkg-comment1
-rw-r--r--net/mudix/pkg-descr9
-rw-r--r--net/mudix/pkg-plist1
7 files changed, 54 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ed1827b6c60d..ffdf15a9e400 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -117,6 +117,7 @@
SUBDIR += mrt
SUBDIR += mrtg
SUBDIR += mtr
+ SUBDIR += mudix
SUBDIR += naim
SUBDIR += nam
SUBDIR += ncplib
diff --git a/net/mudix/Makefile b/net/mudix/Makefile
new file mode 100644
index 000000000000..c29a37dd2e56
--- /dev/null
+++ b/net/mudix/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: mudix
+# Date created: 26 Mar 2000
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= mudix
+PORTVERSION= 3.2
+CATEGORIES= net
+MASTER_SITES= http://dwizardry.dhs.org/mudix/
+
+MAINTAINER= will@FreeBSD.org
+
+LIB_DEPENDS+= ncurses.4:${PORTSDIR}/devel/ncurses
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+ALL_TARGET= mudix
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mudix ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/mudix/distinfo b/net/mudix/distinfo
new file mode 100644
index 000000000000..32d5ad9e1f19
--- /dev/null
+++ b/net/mudix/distinfo
@@ -0,0 +1 @@
+MD5 (mudix-3.2.tar.gz) = 8e3b5a094316c8e727c7295e43e6109f
diff --git a/net/mudix/files/patch-aa b/net/mudix/files/patch-aa
new file mode 100644
index 000000000000..b74c0643b789
--- /dev/null
+++ b/net/mudix/files/patch-aa
@@ -0,0 +1,18 @@
+--- Makefile Sun Mar 26 13:02:11 2000
++++ Makefile.new Sun Mar 26 13:41:34 2000
+@@ -1,10 +1,11 @@
+-CC = gcc
++LOCALBASE ?= /usr/local
++CC ?= gcc
+ PROF =
+ DEBUG =
+ NOCRYPT =
+-O_FLAGS = -O -g
+-C_FLAGS = $(O_FLAGS) -DPOLLING -Wall $(DEBUG) $(PROF) $(NOCRYPT)
+-L_FLAGS = $(O_FLAGS) -lpanel -lncurses $(DEBUG) $(PROF)
++O_FLAGS = ${CFLAGS}
++C_FLAGS = $(O_FLAGS) -DPOLLING -Wall $(DEBUG) $(PROF) $(NOCRYPT) -I$(LOCALBASE)/include/ncurses -I$(LOCALBASE)/include
++L_FLAGS = $(O_FLAGS) -lpanel -lncurses $(DEBUG) $(PROF) -L$(LOCALBASE)/lib
+
+ O_FILES = alias.o commands.o file.o input.o log.o mudix.o output.o parse.o \
+ path.o settings.o tabs.o telnet.o trigger.o
diff --git a/net/mudix/pkg-comment b/net/mudix/pkg-comment
new file mode 100644
index 000000000000..aa1218d3d371
--- /dev/null
+++ b/net/mudix/pkg-comment
@@ -0,0 +1 @@
+Ncurses-based MUD client with triggers, aliases, colors
diff --git a/net/mudix/pkg-descr b/net/mudix/pkg-descr
new file mode 100644
index 000000000000..e158ee254fc4
--- /dev/null
+++ b/net/mudix/pkg-descr
@@ -0,0 +1,9 @@
+Very cool ncurses-based MUD client that offers
+triggers, aliases, colors, etc. This is for people
+who dislike tintin++, tinyfugue, and can't use an
+X11 MUD client.
+
+WWW: http://dwizardry.dhs.org/
+Author: Enigma <enigma@dwizardry.dhs.org>
+
+- Will <andrews@technologist.com>
diff --git a/net/mudix/pkg-plist b/net/mudix/pkg-plist
new file mode 100644
index 000000000000..4c537bd5f290
--- /dev/null
+++ b/net/mudix/pkg-plist
@@ -0,0 +1 @@
+bin/mudix