aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-08-12 03:48:46 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-08-12 03:48:46 +0000
commitc0a956d41aaa8db2f02b5d03ff52d352ac60f376 (patch)
tree00ea40c7242b5efdf143f5849b4daff2452d844e
parent642bbd8ec49b528f04079f6cbe08bed1aa49498c (diff)
downloadports-c0a956d41aaa8db2f02b5d03ff52d352ac60f376.tar.gz
ports-c0a956d41aaa8db2f02b5d03ff52d352ac60f376.zip
Fix escapeurl() not expanded and png linking
Notes
Notes: svn path=/head/; revision=46100
-rw-r--r--www/WebMagick/Makefile1
-rw-r--r--www/WebMagick/files/patch-aa27
2 files changed, 28 insertions, 0 deletions
diff --git a/www/WebMagick/Makefile b/www/WebMagick/Makefile
index aace9fd1489c..4daede50244a 100644
--- a/www/WebMagick/Makefile
+++ b/www/WebMagick/Makefile
@@ -7,6 +7,7 @@
PORTNAME= WebMagick
PORTVERSION= 2.01
+PORTREVISION= 1
CATEGORIES= www graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= webmagick
diff --git a/www/WebMagick/files/patch-aa b/www/WebMagick/files/patch-aa
new file mode 100644
index 000000000000..36627144dbe8
--- /dev/null
+++ b/www/WebMagick/files/patch-aa
@@ -0,0 +1,27 @@
+--- webmagick.in.bak Thu Aug 9 09:59:52 2001
++++ webmagick.in Sun Aug 12 07:31:59 2001
+@@ -1828,9 +1828,9 @@
+ #
+ my $helphtml = '';
+ if( $haveReadme ) {
+- $helphtml = "<A HREF=\"escapeurl(${opt_readme})\" TARGET=\"$frameTargets{'readmeview'}\">
++ $helphtml = "<A HREF=\"" . escapeurl(${opt_readme}) . "\" TARGET=\"$frameTargets{'readmeview'}\">
+ <IMG SRC=\"$iconImageUrls{'help'}\" $iconImageSizes{'help'} ALT=\"?\" BORDER=0></A>
+- <A HREF=\"escapeurl(${opt_readme})\" TARGET=\"$frameTargets{'readmeview'}\">ReadMe</A><BR>";
++ <A HREF=\"" . escapeurl(${opt_readme}) . "\" TARGET=\"$frameTargets{'readmeview'}\">ReadMe</A><BR>";
+ }
+
+ #
+@@ -2265,10 +2265,10 @@
+ }
+ print( PICHTML ">\n\n" );
+ print( PICHTML "$opt_pichtmltop") if $opt_pichtmltop;
+- if ( $pic =~ /\.(jpg|jpeg?|gif|xbm)$/i ) {
++ if ( $pic =~ /\.(jpg|jpeg?|gif|xbm|png)$/i ) {
+ print( PICHTML "<IMG SRC=\"$pic\">" );
+ } else {
+- print( PICHTML "<A HREF=\"escapeurl($pic)\"><BIG><B>$pic</B></A> ", fsize($pic), "</BIG>" );
++ print( PICHTML "<A HREF=\"", escapeurl($pic), "\"><BIG><B>$pic</B></A> ", fsize($pic), "</BIG>" );
+ }
+ print( PICHTML "$opt_pichtmlbottom\n") if $opt_pichtmlbottom;
+ print( PICHTML "</BODY>\n" );