aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-10 18:55:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-10 18:55:17 +0000
commit38c7ca20d1ea6f48d44b0d3e6a022b9f88efc732 (patch)
tree570e26d10036f9968aefda5e4d69e0251d9a9a7a
parent1b3031c7fa40b754e4f85f184e535cf7c8e4c5eb (diff)
downloadports-38c7ca20d1ea6f48d44b0d3e6a022b9f88efc732.tar.gz
ports-38c7ca20d1ea6f48d44b0d3e6a022b9f88efc732.zip
MHGUI is the GUI widget library used in the C++ version of MakeHuman.
The main idea is to have a small and easy toolkit with a set of special widgets. Some of this widgets are very special and not available in other toolkits. WWW: http://www.dedalo-3d.com/index.php PR: ports/111078 Submitted by: Dmitry Marakasov <amdmi3 at amdmi3.ru>
Notes
Notes: svn path=/head/; revision=189706
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/mhgui/Makefile37
-rw-r--r--graphics/mhgui/distinfo3
-rw-r--r--graphics/mhgui/pkg-descr6
-rw-r--r--graphics/mhgui/pkg-plist35
5 files changed, 82 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 157e3c4d760d..0f122beecb41 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -415,6 +415,7 @@
SUBDIR += meshviewer
SUBDIR += metacam
SUBDIR += metapixel
+ SUBDIR += mhgui
SUBDIR += ming
SUBDIR += mingplot
SUBDIR += mirage
diff --git a/graphics/mhgui/Makefile b/graphics/mhgui/Makefile
new file mode 100644
index 000000000000..3b148891218c
--- /dev/null
+++ b/graphics/mhgui/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mhgui
+# Date created: 31 Mar 2007
+# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mhgui
+PORTVERSION= 0.1
+CATEGORIES= graphics
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= makehuman
+
+MAINTAINER= amdmi3@amdmi3.ru
+COMMENT= GUI widget library for MakeHuman
+
+LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut \
+ animorph.0:${PORTSDIR}/graphics/animorph \
+ png.5:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GNOME= pkgconfig
+USE_LDCONFIG= yes
+USE_GL= yes
+
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^libmhguidocdir =/ s|doc/|share/doc/|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e '/^pkgconfigdir =/ s|\$$(libdir)|\$$(exec_prefix)/libdata|' ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libmhguidocDATA||' ${WRKSRC}/Makefile.in
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/mhgui/distinfo b/graphics/mhgui/distinfo
new file mode 100644
index 000000000000..026859752215
--- /dev/null
+++ b/graphics/mhgui/distinfo
@@ -0,0 +1,3 @@
+MD5 (mhgui-0.1.tar.gz) = d9c335c032bb41feb99bba7f20db0c00
+SHA256 (mhgui-0.1.tar.gz) = 79918922cf3706a8a8310b61cdb8a86d4101d960c4cd096e63b2d9aadbf9385f
+SIZE (mhgui-0.1.tar.gz) = 330543
diff --git a/graphics/mhgui/pkg-descr b/graphics/mhgui/pkg-descr
new file mode 100644
index 000000000000..1c0e88534325
--- /dev/null
+++ b/graphics/mhgui/pkg-descr
@@ -0,0 +1,6 @@
+MHGUI is the GUI widget library used in the C++ version of MakeHuman.
+The main idea is to have a small and easy toolkit with a set of special
+widgets. Some of this widgets are very special and not available in
+other toolkits.
+
+WWW: http://www.dedalo-3d.com/index.php
diff --git a/graphics/mhgui/pkg-plist b/graphics/mhgui/pkg-plist
new file mode 100644
index 000000000000..e1b1591553f8
--- /dev/null
+++ b/graphics/mhgui/pkg-plist
@@ -0,0 +1,35 @@
+include/mhgui/AbstractListener.h
+include/mhgui/CGUtilities.h
+include/mhgui/Camera.h
+include/mhgui/Component.h
+include/mhgui/Console.h
+include/mhgui/Image.h
+include/mhgui/ImageData.h
+include/mhgui/ImageSlider.h
+include/mhgui/ImageSliderSysListener.h
+include/mhgui/ImageSysListener.h
+include/mhgui/Label.h
+include/mhgui/Panel.h
+include/mhgui/Point.h
+include/mhgui/Rect.h
+include/mhgui/Size.h
+include/mhgui/TextEntry.h
+include/mhgui/TextEntrySysListener.h
+include/mhgui/Texture.h
+include/mhgui/Tooltip.h
+include/mhgui/Widget.h
+include/mhgui/Window.h
+lib/libmhgui.a
+lib/libmhgui.la
+lib/libmhgui.so
+lib/libmhgui.so.0
+libdata/pkgconfig/mhgui.pc
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/mhgui