aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-02-13 13:56:34 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-02-13 13:56:34 +0000
commit7dee418d6575f1523638f28d0c9624457050bf3c (patch)
tree801b44ae669aaa43270cfc49972dc063a6b72a07
parenta26fd8dc6373e93defaf942e038ae89860deeb85 (diff)
downloadports-7dee418d6575f1523638f28d0c9624457050bf3c.tar.gz
ports-7dee418d6575f1523638f28d0c9624457050bf3c.zip
Add cd9660_unicode 1.0, a kernel driver for reading CD disks with non-English
filenames. Requires -current as of several hours ago.
Notes
Notes: svn path=/head/; revision=38309
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/cd9660_unicode/Makefile49
-rw-r--r--sysutils/cd9660_unicode/distinfo1
-rw-r--r--sysutils/cd9660_unicode/pkg-comment1
-rw-r--r--sysutils/cd9660_unicode/pkg-descr1
-rw-r--r--sysutils/cd9660_unicode/pkg-message16
-rw-r--r--sysutils/cd9660_unicode/pkg-plist15
7 files changed, 84 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 9a62a0a2efb7..aeb5b561a4eb 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -13,6 +13,7 @@
SUBDIR += bchunk
SUBDIR += bkpupsd
SUBDIR += cd-write
+ SUBDIR += cd9660_unicode
SUBDIR += cdrecord
SUBDIR += cfengine
SUBDIR += checkservice
diff --git a/sysutils/cd9660_unicode/Makefile b/sysutils/cd9660_unicode/Makefile
new file mode 100644
index 000000000000..44a56cbfe3cd
--- /dev/null
+++ b/sysutils/cd9660_unicode/Makefile
@@ -0,0 +1,49 @@
+# Ports collection makefile for: cd9660_unicode
+# Date created: 13 February 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cd9660_unicode
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= sobomax
+
+MAINTAINER= sobomax@FreeBSD.org
+
+NO_PACKAGE= Should be in sync with the kernel to work correctly
+
+SRCPREFIX?= /usr/src
+PKGMESSAGE= ${WRKDIR}/.MESSAGE
+ENCODINGS= cd ${WRKSRC}/templates && ${ECHO} [^C]* | \
+ ${SED} 's|\.txt|,|g'
+FMT= /usr/bin/fmt
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "FreeBSD 3.*, 4.* are not supported"
+.endif
+
+pre-fetch:
+ @if [ ! -d /sys -o ! -d ${SRCPREFIX}/sys ]; then \
+ ${ECHO} "****************************************" ; \
+ ${ECHO} " You need to extract kernel source tree" ; \
+ ${ECHO} " before you build this package..." ; \
+ ${ECHO} "****************************************" ; \
+ ${FALSE} ; \
+ fi
+
+pre-install:
+ @ENCODINGS=`${ENCODINGS}` && \
+ ENCODINGS=`${ECHO} $${ENCODINGS} | ${SED} 's|,$$||'` && \
+ ${SED} "s|%%PREFIX%%|${PREFIX}|g; s|%%ENCODINGS%%|$${ENCODINGS}|" \
+ ${PKGDIR}/pkg-message | ${FMT} > ${PKGMESSAGE}
+ ${MKDIR} ${PREFIX}/lib/cd9660_unicode
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/cd9660_unicode/distinfo b/sysutils/cd9660_unicode/distinfo
new file mode 100644
index 000000000000..b393c903e71d
--- /dev/null
+++ b/sysutils/cd9660_unicode/distinfo
@@ -0,0 +1 @@
+MD5 (cd9660_unicode-1.0.tar.gz) = ec20a029149149581bc7510cbd0cc91f
diff --git a/sysutils/cd9660_unicode/pkg-comment b/sysutils/cd9660_unicode/pkg-comment
new file mode 100644
index 000000000000..9633b3e9a39e
--- /dev/null
+++ b/sysutils/cd9660_unicode/pkg-comment
@@ -0,0 +1 @@
+A kernel driver for reading CD disks with non-English filenames
diff --git a/sysutils/cd9660_unicode/pkg-descr b/sysutils/cd9660_unicode/pkg-descr
new file mode 100644
index 000000000000..766b820fd1b0
--- /dev/null
+++ b/sysutils/cd9660_unicode/pkg-descr
@@ -0,0 +1 @@
+Kernel driver for reading CD disks with non-English filenames.
diff --git a/sysutils/cd9660_unicode/pkg-message b/sysutils/cd9660_unicode/pkg-message
new file mode 100644
index 000000000000..11bed69bf4d1
--- /dev/null
+++ b/sysutils/cd9660_unicode/pkg-message
@@ -0,0 +1,16 @@
+---------------------------------------------------------------------
+ You can load the module by typing (as root of course):
+
+ # kldload %%PREFIX%%/lib/cd9660_unicode/cd9660_<encoding>.ko
+
+ where <encoding> is any name from the following list:
+
+ %%ENCODINGS%%.
+
+ If you have a CD with filenames in a single byte language/encoding
+ that doesn't listed here, feel free to send me conversion table
+ between that encoding and Unicode and I'll include it into the
+ distribution.
+
+ -- Maxim Sobolev <sobomax@FreeBSD.org>
+---------------------------------------------------------------------
diff --git a/sysutils/cd9660_unicode/pkg-plist b/sysutils/cd9660_unicode/pkg-plist
new file mode 100644
index 000000000000..d5aad99053a9
--- /dev/null
+++ b/sysutils/cd9660_unicode/pkg-plist
@@ -0,0 +1,15 @@
+lib/cd9660_unicode/cd9660_cp775.ko
+lib/cd9660_unicode/cd9660_cp850.ko
+lib/cd9660_unicode/cd9660_cp852.ko
+lib/cd9660_unicode/cd9660_cp855.ko
+lib/cd9660_unicode/cd9660_cp866.ko
+lib/cd9660_unicode/cd9660_iso-8859-1.ko
+lib/cd9660_unicode/cd9660_iso-8859-15.ko
+lib/cd9660_unicode/cd9660_iso-8859-2.ko
+lib/cd9660_unicode/cd9660_iso-8859-4.ko
+lib/cd9660_unicode/cd9660_iso-8859-5.ko
+lib/cd9660_unicode/cd9660_jis_x0201.ko
+lib/cd9660_unicode/cd9660_koi8-r.ko
+lib/cd9660_unicode/cd9660_koi8-u.ko
+lib/cd9660_unicode/cd9660_shift_jis.ko
+@dirrm lib/cd9660_unicode