aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2003-10-15 21:43:46 +0000
committerKris Kennaway <kris@FreeBSD.org>2003-10-15 21:43:46 +0000
commitee6faee56e86a3a331b8714ae95d777d09e75a6d (patch)
tree4754cadf9e0f7051d7ca300b978db460eb681ca2
parent0859a9c9f4a505ff4a4598ca9cc9a76b4b416f1d (diff)
downloadports-ee6faee56e86a3a331b8714ae95d777d09e75a6d.tar.gz
ports-ee6faee56e86a3a331b8714ae95d777d09e75a6d.zip
BROKEN on 5.x: does not compile
Notes
Notes: svn path=/head/; revision=91364
-rw-r--r--audio/xmms-crystality/Makefile8
-rw-r--r--devel/vb2c/Makefile8
-rw-r--r--games/tetrinet-x/Makefile8
-rw-r--r--graphics/fujiplay/Makefile8
-rw-r--r--irc/party/Makefile8
-rw-r--r--japanese/e2ps/Makefile9
-rw-r--r--lang/pdss/Makefile8
-rw-r--r--net-mgmt/rancid-devel/Makefile8
-rw-r--r--net-mgmt/rancid/Makefile8
-rw-r--r--net/rancid/Makefile8
-rw-r--r--net/ttt/Makefile8
-rw-r--r--sysutils/cd-write/Makefile4
12 files changed, 82 insertions, 11 deletions
diff --git a/audio/xmms-crystality/Makefile b/audio/xmms-crystality/Makefile
index 8158ee8d3229..4b21c245f14b 100644
--- a/audio/xmms-crystality/Makefile
+++ b/audio/xmms-crystality/Makefile
@@ -23,9 +23,15 @@ INSTALLS_SHLIB= yes
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/crystality-stdio ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/libcrystality.so \
${PREFIX}/lib/xmms/Effect
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/vb2c/Makefile b/devel/vb2c/Makefile
index a83f10b365f7..a72de490490e 100644
--- a/devel/vb2c/Makefile
+++ b/devel/vb2c/Makefile
@@ -19,7 +19,13 @@ MAKEFILE= ${FILESDIR}/Makefile
NO_MAN=
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/*.o
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/tetrinet-x/Makefile b/games/tetrinet-x/Makefile
index fb5be5821ee1..7e310d570317 100644
--- a/games/tetrinet-x/Makefile
+++ b/games/tetrinet-x/Makefile
@@ -19,6 +19,12 @@ WRKSRC= ${WRKDIR}/tetrinetx-${PORTVERSION}
INSTALLDIR= ${PREFIX}/tetrinet-x
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-build:
(cd ${WRKDIR}/tetrinetx-1.13.16/src && \
gcc -O2 -fno-strength-reduce -Wall main.c -o ../bin/tetrix.freebsd)
@@ -44,4 +50,4 @@ post-install:
@${ECHO} ""
@${ECHO} ""
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/fujiplay/Makefile b/graphics/fujiplay/Makefile
index 34517f5a8b0b..322b41dc57a7 100644
--- a/graphics/fujiplay/Makefile
+++ b/graphics/fujiplay/Makefile
@@ -19,6 +19,12 @@ NO_WRKSUBDIR= yes
PORTSDOC= README fujiplay.lsm mx700-commands.html
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-install:
(cd ${WRKDIR}; ${INSTALL_PROGRAM} fujiplay yycc2ppm ${PREFIX}/bin)
.if !defined(NOPORTDOCS)
@@ -28,4 +34,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/irc/party/Makefile b/irc/party/Makefile
index 9e10f2ce7e4f..f8ff45e2d00c 100644
--- a/irc/party/Makefile
+++ b/irc/party/Makefile
@@ -16,6 +16,12 @@ COMMENT= Simple multi-user chat system
MAN1= party.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-install:
${INSTALL_SCRIPT} -g nobody -o nobody -m 4711 ${WRKSRC}/party ${PREFIX}/bin
${MKDIR} ${PREFIX}/lib/party
@@ -29,4 +35,4 @@ do-install:
post-extract:
@(cd ${WRKSRC}; ${RM} -f .depend)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/japanese/e2ps/Makefile b/japanese/e2ps/Makefile
index 4fe98b1217ad..735efe2e24a6 100644
--- a/japanese/e2ps/Makefile
+++ b/japanese/e2ps/Makefile
@@ -15,8 +15,15 @@ COMMENT= Text file to postscript converter (with Japanese support)
WRKSRC= ${WRKDIR}/e2ps
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/e2ps ${PREFIX}/bin
${LN} -sf ${PREFIX}/bin/e2ps ${PREFIX}/bin/e2lpr
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/pdss/Makefile b/lang/pdss/Makefile
index c919e9b74628..953796be8c94 100644
--- a/lang/pdss/Makefile
+++ b/lang/pdss/Makefile
@@ -27,6 +27,12 @@ WRKSRC= ${WRKDIR}
MAKE_ENV+= BSD_INSTALL_DIR="${INSTALL_DIR}"
SCRIPTS_ENV+= BSD_INSTALL_DIR="${INSTALL_DIR}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
do-configure:
@${CP} ${FILESDIR}/Makefile.bsd ${WRKSRC}/Makefile
.for f in pdsscmp emulator/config.h emacs/pdss-init.el
@@ -45,4 +51,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/emacs/${f} ${DATADIR}/emacs
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/rancid-devel/Makefile b/net-mgmt/rancid-devel/Makefile
index 3ed851297999..cc5c23bf8f8c 100644
--- a/net-mgmt/rancid-devel/Makefile
+++ b/net-mgmt/rancid-devel/Makefile
@@ -38,6 +38,12 @@ MAN5= env.5 lg.conf.5 cloginrc.5 router.db.5
CONFIG_FILES= bin/env util/lg/lg.conf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-install:
@ ${SED} -e "s:%%INSTDIR%%:${PREFIX}/rancid:g" pkg-message >${PKGMESSAGE}
.if !defined(BATCH)
@@ -52,4 +58,4 @@ post-install:
fi
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/rancid/Makefile b/net-mgmt/rancid/Makefile
index 3ed851297999..cc5c23bf8f8c 100644
--- a/net-mgmt/rancid/Makefile
+++ b/net-mgmt/rancid/Makefile
@@ -38,6 +38,12 @@ MAN5= env.5 lg.conf.5 cloginrc.5 router.db.5
CONFIG_FILES= bin/env util/lg/lg.conf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-install:
@ ${SED} -e "s:%%INSTDIR%%:${PREFIX}/rancid:g" pkg-message >${PKGMESSAGE}
.if !defined(BATCH)
@@ -52,4 +58,4 @@ post-install:
fi
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/rancid/Makefile b/net/rancid/Makefile
index 3ed851297999..cc5c23bf8f8c 100644
--- a/net/rancid/Makefile
+++ b/net/rancid/Makefile
@@ -38,6 +38,12 @@ MAN5= env.5 lg.conf.5 cloginrc.5 router.db.5
CONFIG_FILES= bin/env util/lg/lg.conf
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
post-install:
@ ${SED} -e "s:%%INSTDIR%%:${PREFIX}/rancid:g" pkg-message >${PKGMESSAGE}
.if !defined(BATCH)
@@ -52,4 +58,4 @@ post-install:
fi
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/ttt/Makefile b/net/ttt/Makefile
index 506ceb2c75a9..d58e17eebd77 100644
--- a/net/ttt/Makefile
+++ b/net/ttt/Makefile
@@ -13,6 +13,12 @@ MASTER_SITES= ftp://ftp.csl.sony.co.jp/pub/kjc/
MAINTAINER= kjc@csl.sony.co.jp
COMMENT= Tele Traffic Tapper, a network traffic monitoring tool
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
# the tcl/tk LIB_DEPENDS has to match that of ports/x11-toolkits/blt.
LIB_DEPENDS= BLT24.2:${PORTSDIR}/x11-toolkits/blt \
tcl83.1:${PORTSDIR}/lang/tcl83 \
@@ -22,4 +28,4 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install install-man
MAN1= ttt.1 tttprobe.1 tttview.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/cd-write/Makefile b/sysutils/cd-write/Makefile
index 61b1c2551606..4dd2ffd926df 100644
--- a/sysutils/cd-write/Makefile
+++ b/sysutils/cd-write/Makefile
@@ -25,6 +25,10 @@ WRKSRC= ${WRKDIR}/cd-write
BROKEN= CAM
.endif
+.if ${OSVERSION} >= 501000
+BROKEN= "Does not compile"
+.endif
+
pre-build:
@cd ${WRKSRC}; ${MV} Makefile Makefile~; \
${SED} -e s:/usr/local:${PREFIX}:g -e s/CFL/CXXFL/ <Makefile~ >Makefile;\