aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-04-16 03:34:03 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-04-16 03:34:03 +0000
commit5bff8e7bfda161127a5de38fd9210004f591218e (patch)
tree22ce65ff235253d7a661b087620b2525628b455c
parent9606e35d58cb77ce81ab3588d7386aefa82f4309 (diff)
downloadports-5bff8e7bfda161127a5de38fd9210004f591218e.tar.gz
ports-5bff8e7bfda161127a5de38fd9210004f591218e.zip
[patch] audio/alac - cleanup non-supported FreeBSD versions
[patch] audio/grip - cleanup non-supported FreeBSD versions [patch] audio/jack - cleanup non-supported FreeBSD versions [patch] audio/libcddb - cleanup non-supported FreeBSD versions PR: ports/111646, ports/111660, ports/111662, ports/111668 Submitted by: Edwin Groothuis <edwin@mavetju.org> Appproved by: Michael Johnson <ahze@>
Notes
Notes: svn path=/head/; revision=190062
-rw-r--r--audio/alac/Makefile8
-rw-r--r--audio/grip/Makefile4
-rw-r--r--audio/jack/Makefile9
-rw-r--r--audio/libcddb/Makefile9
-rw-r--r--audio/libcddb/files/cddb.h-systypes-patch10
-rw-r--r--audio/libcddb/files/cddb_ni.h-systypes-patch10
6 files changed, 4 insertions, 46 deletions
diff --git a/audio/alac/Makefile b/audio/alac/Makefile
index 22bbbdeb420e..c0b330c37170 100644
--- a/audio/alac/Makefile
+++ b/audio/alac/Makefile
@@ -20,17 +20,11 @@ ALL_TARGET= alac
PLIST_FILES= bin/alac
PORTDOCS= README
-.include <bsd.port.pre.mk>
-
post-patch:
.if !defined(WITH_DEBUG)
@${REINPLACE_CMD} -e 's|-ggdb||' \
${WRKSRC}/${MAKEFILE}
.endif
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|stdint.h|inttypes.h|' \
- ${WRKSRC}/*.*
-.endif
@${REINPLACE_CMD} -e 's|gcc|${CC}|; s|-O3|${CFLAGS}|' \
${WRKSRC}/${MAKEFILE}
@@ -41,4 +35,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/grip/Makefile b/audio/grip/Makefile
index d1dda068fd49..418925d17362 100644
--- a/audio/grip/Makefile
+++ b/audio/grip/Makefile
@@ -48,12 +48,8 @@ ISO_LOCALES= de es fr pt_BR
.if defined(WITH_CDROM_DEVICE)
DEFAULT_CDROM_DEVICE=${WITH_CDROM_DEVICE}
.else
-.if ${OSVERSION} < 500000
-DEFAULT_CDROM_DEVICE=/dev/acd0c
-.else
DEFAULT_CDROM_DEVICE=/dev/acd0
.endif
-.endif
.if !defined(WITHOUT_CDPARANOIA)
LIB_DEPENDS+= cdda_paranoia.0:${PORTSDIR}/audio/cdparanoia
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index fe0dc882f755..2549cee8bd4d 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -49,16 +49,11 @@ CONFIGURE_ENV+= ac_cv_prog_HAVE_DOXYGEN="false"
PLIST_SUB+= DOCS="@comment "
.endif
-.if ${OSVERSION} < 500000
-CONFIGURE_ENV+= ac_cv_func_clock_gettime=no
-CFLAGS+= -Duintmax_t=uintptr_t
-.endif
-
-.if (${OSVERSION} > 500000 ) && (${OSVERSION} < 502102 )
+.if (${OSVERSION} < 502102 )
BROKEN= Does not compile
.endif
-.if ${OSVERSION} < 500018 || exists(${LOCALBASE}/lib/libreadline.so.5)
+.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
diff --git a/audio/libcddb/Makefile b/audio/libcddb/Makefile
index 88f360fd9b58..fb83715b94df 100644
--- a/audio/libcddb/Makefile
+++ b/audio/libcddb/Makefile
@@ -22,11 +22,4 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --without-cdio
CONFIGURE_ENV= CPPFLAGS="-DICONV_CONST=\"const\""
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${PATCHDIR}/cddb.h-systypes-patch \
- ${PATCHDIR}/cddb_ni.h-systypes-patch
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/libcddb/files/cddb.h-systypes-patch b/audio/libcddb/files/cddb.h-systypes-patch
deleted file mode 100644
index 5331ae87c4da..000000000000
--- a/audio/libcddb/files/cddb.h-systypes-patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- include/cddb/cddb.h.orig Wed Jul 21 15:34:48 2004
-+++ include/cddb/cddb.h Wed Jul 21 15:35:03 2004
-@@ -27,6 +27,7 @@
- #endif
-
-
-+#include <sys/types.h>
- #include <cddb/cddb_config.h>
- #include <cddb/cddb_error.h>
- #include <cddb/cddb_track.h>
diff --git a/audio/libcddb/files/cddb_ni.h-systypes-patch b/audio/libcddb/files/cddb_ni.h-systypes-patch
deleted file mode 100644
index 15df8d01168f..000000000000
--- a/audio/libcddb/files/cddb_ni.h-systypes-patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- include/cddb/cddb_ni.h.orig Wed Jul 21 15:35:13 2004
-+++ include/cddb/cddb_ni.h Wed Jul 21 15:35:32 2004
-@@ -31,6 +31,7 @@
- # include <config.h>
- #endif
-
-+#include <sys/types.h>
- #include "cddb/cddb_regex.h"
- #include "cddb/cddb.h"
- #include "cddb/cddb_conn_ni.h"