aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-03 02:34:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-03 02:34:04 +0000
commit7f4fbe7104e039aa1cf61ea18450c77f789243a1 (patch)
treeec8caa4e1f17c5ea8757a115ff43520f38e4e0d4
parent589185483787d0a80d5cceadfa17398cbaa31f91 (diff)
downloadports-7f4fbe7104e039aa1cf61ea18450c77f789243a1.tar.gz
ports-7f4fbe7104e039aa1cf61ea18450c77f789243a1.zip
Unbreak by properly checking if left-over files are empty after
removing our own entered values.
Notes
Notes: svn path=/head/; revision=147065
-rw-r--r--www/w3/Makefile4
-rw-r--r--www/w3/files/DEINSTALL.tmpl6
2 files changed, 6 insertions, 4 deletions
diff --git a/www/w3/Makefile b/www/w3/Makefile
index 1f8e8f25078d..68830df675ff 100644
--- a/www/w3/Makefile
+++ b/www/w3/Makefile
@@ -17,10 +17,6 @@ COMMENT?= WWW browser based on emacs/mule
BUILD_DEPENDS?= emacs-19.34:${PORTSDIR}/editors/emacs19
RUN_DEPENDS?= emacs-19.34:${PORTSDIR}/editors/emacs19
-BROKEN= Incomplete pkg-plist
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
WRKSRC= ${WRKDIR}/w3
MAKE_ENV+= EMACSCMD=${EMACSCMD} ELISPDIR=${ELISPDIR} \
MKDIR="${MKDIR}" CP=${CP} \
diff --git a/www/w3/files/DEINSTALL.tmpl b/www/w3/files/DEINSTALL.tmpl
index 48f1b91fd511..06436bc73419 100644
--- a/www/w3/files/DEINSTALL.tmpl
+++ b/www/w3/files/DEINSTALL.tmpl
@@ -16,6 +16,9 @@ if [ "X$2" = X"DEINSTALL" ]; then
${elispdir}/site-start.el \
> ${elispdir}/site-start.el.bak
mv ${elispdir}/site-start.el.bak ${elispdir}/site-start.el
+ if [ -e ${elispdir}/site-start.el ]; then
+ rm ${elispdir}/site-start.el
+ fi
fi
OptionStart="!!! Emacs-w3 configuration options"
OptionEnd="!!! End of Emacs-w3 configuration options"
@@ -25,6 +28,9 @@ if [ "X$2" = X"DEINSTALL" ]; then
-e "/^${OptionStart}/,/^${OptionEnd}/d" \
${addir}/Emacs > ${addir}/Emacs.bak
mv ${addir}/Emacs.bak ${addir}/Emacs
+ if [ -e ${addir}/Emacs ]; then
+ rm ${addir}/Emacs
+ fi
fi
else
exit 0