aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-07 23:53:22 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-07 23:53:22 +0000
commitb0a10d2ab7e5d880ca905b0c5c777fce09b9dfa5 (patch)
treea3232fa5580271c96dc20848ab8cac625ed5d579
parent34e58bc6ad53f4c9d927e45c4d46d0a495c52710 (diff)
downloadports-b0a10d2ab7e5d880ca905b0c5c777fce09b9dfa5.tar.gz
ports-b0a10d2ab7e5d880ca905b0c5c777fce09b9dfa5.zip
New Port: ssh_askpass_gtk2 - A tiny GTK2 ssh askpass replacement
A small SSH Askpass replacement written with GTK2. Features fullscreen dialog and translucent background. PR: ports/56537 Submitted by: Manuel Rabade <mig@mig-29.net>
Notes
Notes: svn path=/head/; revision=90572
-rw-r--r--security/Makefile1
-rw-r--r--security/ssh_askpass_gtk2/Makefile27
-rw-r--r--security/ssh_askpass_gtk2/distinfo1
-rw-r--r--security/ssh_askpass_gtk2/pkg-descr7
-rw-r--r--security/ssh_askpass_gtk2/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 90205be60d75..a282cab76950 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -359,6 +359,7 @@
SUBDIR += ssh-gui
SUBDIR += ssh-multiadd
SUBDIR += ssh2
+ SUBDIR += ssh_askpass_gtk2
SUBDIR += sslproxy
SUBDIR += sslsniffer
SUBDIR += sslwrap
diff --git a/security/ssh_askpass_gtk2/Makefile b/security/ssh_askpass_gtk2/Makefile
new file mode 100644
index 000000000000..bdefbdfff30d
--- /dev/null
+++ b/security/ssh_askpass_gtk2/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ssh_askpass_gtk2
+# Date created: 21 Aug 2003
+# Whom: mig
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssh_askpass_gtk2
+PORTVERSION= 0.3
+CATEGORIES= security
+MASTER_SITES= http://www.cgabriel.org/sw/gtk2-ssh-askpass/
+DISTNAME= gtk2-ssh-askpass-0.3
+
+MAINTAINER= mig@mig-29.net
+COMMENT= A tiny GTK2 ssh askpass replacement
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+
+MAN1= ssh-askpass-gtk2.1
+
+do-install:
+ cd ${WRKSRC};\
+ ${INSTALL_PROGRAM} gtk2-ssh-askpass ${PREFIX}/bin/ssh-askpass-gtk2;\
+ ${INSTALL_MAN} debian/gtk2-ssh-askpass.1 ${PREFIX}/man/man1/ssh-askpass-gtk2.1
+
+.include <bsd.port.mk>
diff --git a/security/ssh_askpass_gtk2/distinfo b/security/ssh_askpass_gtk2/distinfo
new file mode 100644
index 000000000000..da7090c2ea8b
--- /dev/null
+++ b/security/ssh_askpass_gtk2/distinfo
@@ -0,0 +1 @@
+MD5 (gtk2-ssh-askpass-0.3.tar.gz) = 14ca8c653ad19699b7299198d7a94e0a
diff --git a/security/ssh_askpass_gtk2/pkg-descr b/security/ssh_askpass_gtk2/pkg-descr
new file mode 100644
index 000000000000..3366185132be
--- /dev/null
+++ b/security/ssh_askpass_gtk2/pkg-descr
@@ -0,0 +1,7 @@
+A small SSH Askpass replacement written with GTK2. Features fullscreen
+dialog and translucent background.
+
+WWW: http://www.cgabriel.org/sw/gtk2-ssh-askpass/
+
+- Manuel Rodrigo Rabade Garcia
+mig@mig-29.net
diff --git a/security/ssh_askpass_gtk2/pkg-plist b/security/ssh_askpass_gtk2/pkg-plist
new file mode 100644
index 000000000000..3b2fb3354bc8
--- /dev/null
+++ b/security/ssh_askpass_gtk2/pkg-plist
@@ -0,0 +1 @@
+bin/ssh-askpass-gtk2