aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2007-02-12 22:22:15 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2007-02-12 22:22:15 +0000
commitb5cf8c644543ad426129bf42f7c74c67a66a823e (patch)
treeec57c3b54f761611d31adf4b0c34a12ea93d7a8d
parent9e999f103280d530e9811b536acf2729bba62574 (diff)
downloadports-b5cf8c644543ad426129bf42f7c74c67a66a823e.tar.gz
ports-b5cf8c644543ad426129bf42f7c74c67a66a823e.zip
- Fix a small bug that causes a garbage errormessage printed to stderr
Don't try to print an unitialized buf. Don't print to stderr because the condition is not a bug - Bump PORTREVISION Approved by: maintainer
Notes
Notes: svn path=/head/; revision=185042
-rw-r--r--www/swiggle/Makefile1
-rw-r--r--www/swiggle/files/patch-swiggle.c23
2 files changed, 17 insertions, 7 deletions
diff --git a/www/swiggle/Makefile b/www/swiggle/Makefile
index cff56bd62af3..6118d73a847f 100644
--- a/www/swiggle/Makefile
+++ b/www/swiggle/Makefile
@@ -6,6 +6,7 @@
PORTNAME= swiggle
PORTVERSION= 0.4
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://homepage.univie.ac.at/l.ertl/swiggle/files/ \
http://bsd-geek.de/FreeBSD/distfiles/
diff --git a/www/swiggle/files/patch-swiggle.c b/www/swiggle/files/patch-swiggle.c
index 96b6bfc52380..33dc13258f9a 100644
--- a/www/swiggle/files/patch-swiggle.c
+++ b/www/swiggle/files/patch-swiggle.c
@@ -1,5 +1,5 @@
---- swiggle.c.orig Sat Oct 23 22:58:37 2004
-+++ swiggle.c Wed Nov 1 16:34:10 2006
+--- swiggle.c.orig Sun Jan 14 13:03:36 2007
++++ swiggle.c Sun Feb 11 16:32:41 2007
@@ -66,12 +66,14 @@
char generated[1024];
char *progname = "";
@@ -15,7 +15,7 @@
int (*sort_func)();
#define MAX_PER_PAGE (cols*rows)
-@@ -113,7 +115,7 @@
+@@ -115,7 +117,7 @@
progname = argv[0];
sort_func = sort_by_filename;
@@ -24,7 +24,7 @@
switch (i) {
case 'c':
cols = (int) strtol(optarg, &eptr, 10);
-@@ -163,6 +165,12 @@
+@@ -165,6 +167,12 @@
usage();
}
break;
@@ -37,7 +37,7 @@
case 'f':
force = 1;
break;
-@@ -172,6 +180,9 @@
+@@ -174,6 +182,9 @@
case 'o':
rm_orphans = 0;
break;
@@ -47,7 +47,7 @@
case 'v':
version();
break;
-@@ -353,7 +364,7 @@
+@@ -380,7 +391,7 @@
qsort(imglist, imgcount, sizeof(struct imginfo), sort_func);
create_html(dir, imglist, imgcount);
@@ -56,7 +56,16 @@
printf("%d thumbnail index pages created.\n", x);
}
-@@ -1040,6 +1051,11 @@
+@@ -868,7 +879,7 @@
+ if (closedir(curdir))
+ fprintf(stderr, "can't closedir(%s)\n", path);
+ } else
+- fprintf(stderr, "can't opendir(%s)\n", buf);
++ fprintf(stdout, "can't opendir(%s)\n", path);
+ }
+
+ /*
+@@ -1076,6 +1087,11 @@
"(default: %d)\n", thumbheight);
fprintf(stderr, " -H <j> ... height of the scaled images in pixel "
"(default: %d)\n", scaleheight);