aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2006-07-09 20:59:24 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2006-07-09 20:59:24 +0000
commitb1a42e06119df78499453f18b77d88b12c26e4d3 (patch)
tree8eddab0b2fb4594215cfc42556583ddff3d3ed6d
parent7ecfed784da5abf7f10b55803145718f681ed07d (diff)
downloadports-b1a42e06119df78499453f18b77d88b12c26e4d3.tar.gz
ports-b1a42e06119df78499453f18b77d88b12c26e4d3.zip
Give encoding of metadata to/from UTF-8 a fighting chance.
Dug up by Heino Tiedemann <rotkap@GMX.de> who kept going on and on about this on various mailing lists without ever bothering to contact the maintainer. Obtained from: upstream CVS
Notes
Notes: svn path=/head/; revision=167303
-rw-r--r--audio/vorbis-tools/Makefile1
-rw-r--r--audio/vorbis-tools/files/patch-share_charset.c16
-rw-r--r--audio/vorbis-tools/files/patch-share_iconvert.c16
-rw-r--r--audio/vorbis-tools/files/patch-share_utf8.c16
4 files changed, 49 insertions, 0 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index 0d14801f492f..1d2f389d29df 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vorbis-tools
PORTVERSION= 1.1.1
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= audio
MASTER_SITES= http://downloads.xiph.org/releases/vorbis/
diff --git a/audio/vorbis-tools/files/patch-share_charset.c b/audio/vorbis-tools/files/patch-share_charset.c
new file mode 100644
index 000000000000..b06e5ddfa0f9
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-share_charset.c
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- share/charset.c.orig
++++ share/charset.c
+@@ -27,6 +27,10 @@
+ * 8-bit char, 16-bit short and 32-bit int.
+ */
+
++#ifdef HAVE_CONFIG_H
++# include <config.h>
++#endif
++
+ #ifndef HAVE_ICONV /* should be ifdef USE_CHARSET_CONVERT */
+
+ #include <stdlib.h>
diff --git a/audio/vorbis-tools/files/patch-share_iconvert.c b/audio/vorbis-tools/files/patch-share_iconvert.c
new file mode 100644
index 000000000000..fdf48d1ebd62
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-share_iconvert.c
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- share/iconvert.c.orig
++++ share/iconvert.c
+@@ -16,6 +16,10 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#ifdef HAVE_CONFIG_H
++# include <config.h>
++#endif
++
+ #ifdef HAVE_ICONV
+
+ #include <assert.h>
diff --git a/audio/vorbis-tools/files/patch-share_utf8.c b/audio/vorbis-tools/files/patch-share_utf8.c
new file mode 100644
index 000000000000..ed61f1f558a9
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-share_utf8.c
@@ -0,0 +1,16 @@
+
+$FreeBSD$
+
+--- share/utf8.c.orig
++++ share/utf8.c
+@@ -21,6 +21,10 @@
+ * Convert a string between UTF-8 and the locale's charset.
+ */
+
++#ifdef HAVE_CONFIG_H
++# include <config.h>
++#endif
++
+ #include <stdlib.h>
+ #include <string.h>
+