aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-21 22:15:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-21 22:15:45 +0000
commit1cb458c20befe3a4310488102e8d4a5899925bcd (patch)
tree64811c4db9dd468ffef1ab5d14eb959a93fedeaf
parentfeb7b457a05615630751b8c5a0f6d078e943c79d (diff)
downloadports-1cb458c20befe3a4310488102e8d4a5899925bcd.tar.gz
ports-1cb458c20befe3a4310488102e8d4a5899925bcd.zip
Implement PERL_BUILD_DEPENDS / PERL_RUN_DEPENDS for my ports.
Notes
Notes: svn path=/head/; revision=154095
-rw-r--r--misc/tinderbox/Makefile10
-rw-r--r--ports-mgmt/newportsversioncheck/Makefile7
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile10
-rw-r--r--ports-mgmt/tinderbox/Makefile10
-rw-r--r--sysutils/lire/Makefile20
-rw-r--r--sysutils/newportsversioncheck/Makefile7
6 files changed, 34 insertions, 30 deletions
diff --git a/misc/tinderbox/Makefile b/misc/tinderbox/Makefile
index c29b26f656c7..7a7103944bc7 100644
--- a/misc/tinderbox/Makefile
+++ b/misc/tinderbox/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= edwin@mavetju.org
COMMENT= Port build tinderbox system
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+PERL_RUN_DEPENDS= Digest-MD5:${PORTSDIR}/security/p5-Digest-MD5 \
+ Net-SMTP:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
cvsup:${PORTSDIR}/net/cvsup-without-gui
OPTIONS= PGSQL "With pgsql" On \
@@ -37,13 +37,13 @@ USE_PHP= session
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+PERL_RUN_DEPENDS+= DBD-Pg:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+PERL_RUN_DEPENDS+= DBD-mysql:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.include "${PORTSDIR}/Mk/bsd.php.mk"
diff --git a/ports-mgmt/newportsversioncheck/Makefile b/ports-mgmt/newportsversioncheck/Makefile
index ee30daf4c613..816444ee6211 100644
--- a/ports-mgmt/newportsversioncheck/Makefile
+++ b/ports-mgmt/newportsversioncheck/Makefile
@@ -14,9 +14,10 @@ MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= edwin@mavetju.org
COMMENT= Ports new version checker
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
- ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+PERL_RUN_DEPENDS= \
+ DBD/SQLite:${PORTSDIR}/databases/p5-DBD-SQLite \
+ MIME/Lite:${PORTSDIR}/mail/p5-MIME-Lite \
+ LWP:${PORTSDIR}/www/p5-libwww
USE_PERL_RUN= yes
USE_SQLITE= yes
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index c29b26f656c7..7a7103944bc7 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= edwin@mavetju.org
COMMENT= Port build tinderbox system
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+PERL_RUN_DEPENDS= Digest-MD5:${PORTSDIR}/security/p5-Digest-MD5 \
+ Net-SMTP:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
cvsup:${PORTSDIR}/net/cvsup-without-gui
OPTIONS= PGSQL "With pgsql" On \
@@ -37,13 +37,13 @@ USE_PHP= session
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+PERL_RUN_DEPENDS+= DBD-Pg:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+PERL_RUN_DEPENDS+= DBD-mysql:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.include "${PORTSDIR}/Mk/bsd.php.mk"
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index c29b26f656c7..7a7103944bc7 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= edwin@mavetju.org
COMMENT= Port build tinderbox system
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+PERL_RUN_DEPENDS= Digest-MD5:${PORTSDIR}/security/p5-Digest-MD5 \
+ Net-SMTP:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
cvsup:${PORTSDIR}/net/cvsup-without-gui
OPTIONS= PGSQL "With pgsql" On \
@@ -37,13 +37,13 @@ USE_PHP= session
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
+PERL_RUN_DEPENDS+= DBD-Pg:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+PERL_RUN_DEPENDS+= DBD-mysql:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.include "${PORTSDIR}/Mk/bsd.php.mk"
diff --git a/sysutils/lire/Makefile b/sysutils/lire/Makefile
index cf7edcce4b47..f382e1f81a3c 100644
--- a/sysutils/lire/Makefile
+++ b/sysutils/lire/Makefile
@@ -23,14 +23,15 @@ COMMENT= Logfile analyse toolkit for multiple applications
LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
\
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/MIME/Tools.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/Time/Timezone.pm:${PORTSDIR}/devel/p5-Time-modules \
- ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite2.pm:${PORTSDIR}/databases/p5-DBD-SQLite2 \
- ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/${PERL_ARCH}/Curses.pm:${PORTSDIR}/devel/p5-Curses \
- ${SITE_PERL}/Curses/UI.pm:${PORTSDIR}/devel/p5-Curses-UI \
- ${SITE_PERL}/Locale/TextDomain.pm:${PORTSDIR}/devel/p5-Locale-libintl
+PERL_BUILD_DEPENDS= \
+ Digest-MD5:${PORTSDIR}/security/p5-Digest-MD5 \
+ MIME-Tools:${PORTSDIR}/mail/p5-MIME-Tools \
+ Time-Timezone:${PORTSDIR}/devel/p5-Time-modules \
+ DBD-SQLite2:${PORTSDIR}/databases/p5-DBD-SQLite2 \
+ XML-Parser:${PORTSDIR}/textproc/p5-XML-Parser \
+ Curses:${PORTSDIR}/devel/p5-Curses \
+ Curses-UI:${PORTSDIR}/devel/p5-Curses-UI \
+ Locale-TextDomain:${PORTSDIR}/devel/p5-Locale-libintl
OPTIONS= CHARTS "Have Charts output format" On \
HTML "Have HTML or DocBook output format" On \
@@ -259,7 +260,7 @@ IGNORE= sysutils/lire requires are least Perl 5.6.1, while Perl 5.8.2 is recomm
.ifdef(WITH_CHARTS)
RUN_DEPENDS+= ploticus:${PORTSDIR}/math/ploticus-nox11 \
dia:${PORTSDIR}/graphics/dia
-BUILD_DEPENDS+= ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph
+PERL_BUILD_DEPENDS+= GD-Graph:${PORTSDIR}/graphics/p5-GD-Graph
.endif
.ifdef(WITH_HTML)
RUN_DEPENDS+= lynx:${PORTSDIR}/www/lynx
@@ -277,6 +278,7 @@ BUILD_DEPENDS+= ${SITE_PERL}/Spreadsheet/WriteExcel.pm:${PORTSDIR}/textproc/p5-S
.endif
RUN_DEPENDS+= ${BUILD_DEPENDS}
+PERL_RUN_DEPENDS+= ${PERL_BUILD_DEPENDS}
post-install:
@${CAT} pkg-message
diff --git a/sysutils/newportsversioncheck/Makefile b/sysutils/newportsversioncheck/Makefile
index ee30daf4c613..816444ee6211 100644
--- a/sysutils/newportsversioncheck/Makefile
+++ b/sysutils/newportsversioncheck/Makefile
@@ -14,9 +14,10 @@ MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= edwin@mavetju.org
COMMENT= Ports new version checker
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
- ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
+PERL_RUN_DEPENDS= \
+ DBD/SQLite:${PORTSDIR}/databases/p5-DBD-SQLite \
+ MIME/Lite:${PORTSDIR}/mail/p5-MIME-Lite \
+ LWP:${PORTSDIR}/www/p5-libwww
USE_PERL_RUN= yes
USE_SQLITE= yes