aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBeat Gaetzi <beat@FreeBSD.org>2009-05-21 20:07:38 +0000
committerBeat Gaetzi <beat@FreeBSD.org>2009-05-21 20:07:38 +0000
commite80d879eec2d00dc1670cfd5df4c1ec2961f249e (patch)
tree1f23bca8fcef30fda7616af990fa93e754713744
parent858b75b2826799656b09533cad24a64d6dc8c7a2 (diff)
downloadports-e80d879eec2d00dc1670cfd5df4c1ec2961f249e.tar.gz
ports-e80d879eec2d00dc1670cfd5df4c1ec2961f249e.zip
Petite Chez Scheme is a complete Scheme system that is fully compatible
with Chez Scheme but uses high-speed threaded interpreter technology in place of Chez Scheme's incremental native-code compiler. Programs written for Chez Scheme run unchanged in Petite Chez Scheme, as long as they do not depend specifically on the compiler. In fact, Petite Chez Scheme is built from the same sources as Chez Scheme, with all but the compiler sources included. Petite Chez Scheme was conceived as a freely distributable run-time environment for compiled Chez Scheme applications. To serve this purpose, it needed to have a complete run-time environment, including, for many applications, a working evaluator. The result is a system that is useful not only to our customers for the applications they distribute, but also to people who want to use a top-quality Scheme system and can't justify purchasing Chez Scheme. WWW: http://www.scheme.com/petitechezscheme.html PR: ports/133437 Submitted by: Vitaly Magerya <vmagerya AT gmail.com> Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=234360
-rw-r--r--LEGAL1
-rw-r--r--lang/Makefile1
-rw-r--r--lang/petite-chez/Makefile71
-rw-r--r--lang/petite-chez/distinfo6
-rw-r--r--lang/petite-chez/pkg-descr17
-rw-r--r--lang/petite-chez/pkg-plist30
6 files changed, 126 insertions, 0 deletions
diff --git a/LEGAL b/LEGAL
index 5cc53efdc5fc..481f5f159298 100644
--- a/LEGAL
+++ b/LEGAL
@@ -753,3 +753,4 @@ festlex-ogi audio/festlex-ogi No commercial use
festvox-abc audio/festvox-abc No commercial use
festvox-hvs audio/festvox-hvs No commercial use
apache2/mod_h264_streaming-* www/mod_h264_streaming No commercial use
+pcsv*i3fb.tar.gz lang/petite-chez Must acknowledge license
diff --git a/lang/Makefile b/lang/Makefile
index 6f6babae5eae..e5210dffc2f3 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -234,6 +234,7 @@
SUBDIR += perl5.6
SUBDIR += perl5.8
SUBDIR += perl5.10
+ SUBDIR += petite-chez
SUBDIR += pexts
SUBDIR += pfe-devel
SUBDIR += phc
diff --git a/lang/petite-chez/Makefile b/lang/petite-chez/Makefile
new file mode 100644
index 000000000000..54ffafd6897f
--- /dev/null
+++ b/lang/petite-chez/Makefile
@@ -0,0 +1,71 @@
+# New ports collection makefile for: petite-chez
+# Date created: 27 Mar 2009
+# Whom: Vitaly Magerya <vmagerya@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= petite-chez
+PORTVERSION= 7.4
+CATEGORIES= lang scheme
+MASTER_SITES= http://www.scheme.com/download/
+DISTNAME= pcsv${PORTVERSION}-${CHEZ_MACHTYPE}
+
+MAINTAINER= vmagerya@gmail.com
+COMMENT= Free interpreter for Chez Scheme system
+
+ONLY_FOR_ARCHS= i386
+
+NO_PACKAGE= user must accept license terms before installation
+
+.if defined(PACKAGE_BUILDING)
+IGNORE= user must accept license terms before installation
+.endif
+
+OPTIONS= THREADS "Install threaded version" off
+
+WRKSRC= ${WRKDIR}/csv${PORTVERSION}/custom
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --installprefix=${PREFIX} \
+ --installman=${MANPREFIX}/man \
+ --force-relink \
+ -m=${CHEZ_MACHTYPE}
+
+ALL_TARGET= build
+
+MAN1= petite.1
+
+PLIST_SUB= CHEZ_VERSION="${PORTVERSION}" \
+ CHEZ_MACHTYPE="${CHEZ_MACHTYPE}"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_THREADS)
+CHEZ_MACHTYPE= ti3fb
+.else
+CHEZ_MACHTYPE= i3fb
+.endif
+
+post-extract:
+.if !defined(PETITECHEZ_AGREE_LICENSE) || ${PETITECHEZ_AGREE_LICENSE} != "yes"
+ @${ECHO}
+ @${ECHO} "AGREEMENT: ${WRKDIR}/csv${PORTVERSION}/petite.lic"
+ @${ECHO}
+ @${ECHO} "BEFORE PROCEEDING WITH THE INSTALLATION, YOU MUST FIRST READ"
+ @${ECHO} "THE ENTIRE AGREEMENT. BY PROCEEDING WITH THE INSTALLATION,"
+ @${ECHO} "YOU EXPRESSLY AGREE TO BE BOUND BY THE TERMS AND CONDITIONS"
+ @${ECHO} "OF THE AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS"
+ @${ECHO} "AND CONDITIONS OF THIS AGREEMENT, DO NOT PROCEED WITH"
+ @${ECHO} "THE INSTALLATION."
+ @${ECHO}
+ @${ECHO} "Build with PETITECHEZ_AGREE_LICENSE=yes to continue."
+ @${FALSE}
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|group=root|group=wheel|' \
+ ${WRKSRC}/Mf-${CHEZ_MACHTYPE}
+ @${REINPLACE_CMD} -e 's|C=gcc|C=${CC}|' \
+ ${WRKSRC}/Mf-${CHEZ_MACHTYPE}
+
+.include <bsd.port.post.mk>
diff --git a/lang/petite-chez/distinfo b/lang/petite-chez/distinfo
new file mode 100644
index 000000000000..f3311a71ae57
--- /dev/null
+++ b/lang/petite-chez/distinfo
@@ -0,0 +1,6 @@
+MD5 (pcsv7.4-i3fb.tar.gz) = 393e1af1d40d77f32468bfd72bb6a73a
+SHA256 (pcsv7.4-i3fb.tar.gz) = 9e886fed0cd086b78ba9c3c520325a60f1b4073e4cc1a331b6def2fed92e883b
+SIZE (pcsv7.4-i3fb.tar.gz) = 1033242
+MD5 (pcsv7.4-ti3fb.tar.gz) = 7805b359820fdc2e81b33c81158e33f0
+SHA256 (pcsv7.4-ti3fb.tar.gz) = 28764c017e025ee4ca3da177a0908e99f4cf39534d76a4b465bf01740c326ade
+SIZE (pcsv7.4-ti3fb.tar.gz) = 1057879
diff --git a/lang/petite-chez/pkg-descr b/lang/petite-chez/pkg-descr
new file mode 100644
index 000000000000..0daaf442a8d2
--- /dev/null
+++ b/lang/petite-chez/pkg-descr
@@ -0,0 +1,17 @@
+Petite Chez Scheme is a complete Scheme system that is fully compatible
+with Chez Scheme but uses high-speed threaded interpreter technology in
+place of Chez Scheme's incremental native-code compiler. Programs written
+for Chez Scheme run unchanged in Petite Chez Scheme, as long as they do
+not depend specifically on the compiler. In fact, Petite Chez Scheme is
+built from the same sources as Chez Scheme, with all but the compiler
+sources included.
+
+Petite Chez Scheme was conceived as a freely distributable run-time
+environment for compiled Chez Scheme applications. To serve this purpose,
+it needed to have a complete run-time environment, including, for many
+applications, a working evaluator. The result is a system that is useful
+not only to our customers for the applications they distribute, but also
+to people who want to use a top-quality Scheme system and can't justify
+purchasing Chez Scheme.
+
+WWW: http://www.scheme.com/petitechezscheme.html
diff --git a/lang/petite-chez/pkg-plist b/lang/petite-chez/pkg-plist
new file mode 100644
index 000000000000..64ad9fc303d8
--- /dev/null
+++ b/lang/petite-chez/pkg-plist
@@ -0,0 +1,30 @@
+bin/petite
+lib/csv%%CHEZ_VERSION%%/%%CHEZ_MACHTYPE%%/petite.boot
+lib/csv%%CHEZ_VERSION%%/%%CHEZ_MACHTYPE%%/scheme.h
+lib/csv%%CHEZ_VERSION%%/lib/Makefile
+lib/csv%%CHEZ_VERSION%%/lib/compat.ss
+lib/csv%%CHEZ_VERSION%%/lib/csocket.c
+lib/csv%%CHEZ_VERSION%%/lib/def.ss
+lib/csv%%CHEZ_VERSION%%/lib/edit.ss
+lib/csv%%CHEZ_VERSION%%/lib/fact.ss
+lib/csv%%CHEZ_VERSION%%/lib/fatfib.ss
+lib/csv%%CHEZ_VERSION%%/lib/fft.ss
+lib/csv%%CHEZ_VERSION%%/lib/fib.ss
+lib/csv%%CHEZ_VERSION%%/lib/foreign.ss
+lib/csv%%CHEZ_VERSION%%/lib/freq.ss
+lib/csv%%CHEZ_VERSION%%/lib/interpret.ss
+lib/csv%%CHEZ_VERSION%%/lib/m4.ss
+lib/csv%%CHEZ_VERSION%%/lib/macro.ss
+lib/csv%%CHEZ_VERSION%%/lib/matrix.ss
+lib/csv%%CHEZ_VERSION%%/lib/object.ss
+lib/csv%%CHEZ_VERSION%%/lib/power.ss
+lib/csv%%CHEZ_VERSION%%/lib/queue.ss
+lib/csv%%CHEZ_VERSION%%/lib/rabbit.ss
+lib/csv%%CHEZ_VERSION%%/lib/rsa.ss
+lib/csv%%CHEZ_VERSION%%/lib/scons.ss
+lib/csv%%CHEZ_VERSION%%/lib/setof.ss
+lib/csv%%CHEZ_VERSION%%/lib/socket.ss
+lib/csv%%CHEZ_VERSION%%/lib/unify.ss
+@dirrm lib/csv%%CHEZ_VERSION%%/lib
+@dirrm lib/csv%%CHEZ_VERSION%%/%%CHEZ_MACHTYPE%%
+@dirrm lib/csv%%CHEZ_VERSION%%