aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-12-07 09:44:57 +0000
committerWen Heping <wen@FreeBSD.org>2009-12-07 09:44:57 +0000
commitf1f3574a4cee9ee267c193f7b7a8ba0cee8ef286 (patch)
treed5f71a91c71afb8446d29b4c4c897780c2d6377b
parent35ea1b99a38b6328f4bfa8a220e2c19ad06cf49b (diff)
downloadports-f1f3574a4cee9ee267c193f7b7a8ba0cee8ef286.tar.gz
ports-f1f3574a4cee9ee267c193f7b7a8ba0cee8ef286.zip
Force Repocopy Commit.
Notes
Notes: svn path=/head/; revision=245328
-rw-r--r--security/pear-Crypt_HMAC2/Makefile27
-rw-r--r--security/pear-Crypt_HMAC2/distinfo3
-rw-r--r--security/pear-Crypt_HMAC2/pkg-descr6
3 files changed, 36 insertions, 0 deletions
diff --git a/security/pear-Crypt_HMAC2/Makefile b/security/pear-Crypt_HMAC2/Makefile
new file mode 100644
index 000000000000..e3e69d652393
--- /dev/null
+++ b/security/pear-Crypt_HMAC2/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: pear-Crypt_HMAC2
+# Date created: 23 Nov, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_HMAC2
+PORTVERSION= 0.2.1
+CATEGORIES= security www pear
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Implementation of Hashed Message Authentication Code for PHP5
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Crypt
+FILES= HMAC2.php HMAC2/Exception.php
+TESTS= AllTests.php HMAC2Test.php \
+ TestConfiguration.php.dist \
+ TestHelper.php
+DOCS= intro.xml
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/security/pear-Crypt_HMAC2/distinfo b/security/pear-Crypt_HMAC2/distinfo
new file mode 100644
index 000000000000..f60b5e7dd3b0
--- /dev/null
+++ b/security/pear-Crypt_HMAC2/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Crypt_HMAC2-0.2.1.tgz) = b2d35e1844d8a319ec3bd8e7b3207450
+SHA256 (PEAR/Crypt_HMAC2-0.2.1.tgz) = 053f9b9511cdf424df5774275ca149e345093d00cdc45b1b0b188e2dca7e19ee
+SIZE (PEAR/Crypt_HMAC2-0.2.1.tgz) = 7339
diff --git a/security/pear-Crypt_HMAC2/pkg-descr b/security/pear-Crypt_HMAC2/pkg-descr
new file mode 100644
index 000000000000..270b5fe71b5a
--- /dev/null
+++ b/security/pear-Crypt_HMAC2/pkg-descr
@@ -0,0 +1,6 @@
+pear-Crypt_HMAC2 is a implementation of Hashed Message Authentication
+Code for PHP5.It use the hash or mhash extensions when enabled to
+extend the range of cryptographic hash functions beyond the natively
+implemented MD5 and SHA1.
+
+WWW: http://pear.php.net/package/Crypt_HMAC2/