aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSahil Tandon <sahil@FreeBSD.org>2010-05-07 01:51:37 +0000
committerSahil Tandon <sahil@FreeBSD.org>2010-05-07 01:51:37 +0000
commit288bf0caf96cc15824b38ebb3a0863ac9e65c822 (patch)
tree3050a573296a9d02db408a56e1af6fa57b002908
parenta2456c61a1e36a9b0020d6d12b7d3c89f5f65405 (diff)
downloadports-288bf0caf96cc15824b38ebb3a0863ac9e65c822.tar.gz
ports-288bf0caf96cc15824b38ebb3a0863ac9e65c822.zip
- Update to 4.9.2
- Add USE_LDCONFIG to register shared libs - Pass maintainership to submitter PR: ports/145239 Submitted by: Krzysztof Stryjek <ports@bsdserwis.com> Approved by: Daniel Roethlisberger <daniel@roe.ch> (maintainer) wxs@ (mentor)
Notes
Notes: svn path=/head/; revision=253866
-rw-r--r--net-mgmt/collectd/Makefile116
-rw-r--r--net-mgmt/collectd/distinfo6
-rw-r--r--net-mgmt/collectd/pkg-plist65
-rw-r--r--net-mgmt/collectd5/Makefile116
-rw-r--r--net-mgmt/collectd5/distinfo6
-rw-r--r--net-mgmt/collectd5/pkg-plist65
6 files changed, 316 insertions, 58 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index a801671accea..1b7cedf55c8b 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -6,38 +6,43 @@
#
PORTNAME= collectd
-PORTVERSION= 4.5.1
-PORTREVISION= 3
+PORTVERSION= 4.9.2
CATEGORIES= net-mgmt
-MASTER_SITES= http://collectd.org/files/ \
- http://mirror.roe.ch/dist/${PORTNAME}/
+MASTER_SITES= http://collectd.org/files/
-MAINTAINER= daniel@roe.ch
+MAINTAINER= ports@bsdserwis.com
COMMENT= Systems & network statistics collection daemon
USE_GMAKE= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
-OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
- DEBUG "Enable debugging" Off \
- APACHE "Input: Apache mod_status (libcurl)" Off \
- APCUPS "Input: APC UPS (apcupsd)" Off \
- NUTUPS "Input: NUT UPS daemon" Off \
- INTERFACE "Input: Network interfaces (libstatgrab)" On \
- MBMON "Input: MBMon" Off \
- MYSQL "Input: MySQL" Off \
- PING "Input: Network latency (liboping)" On \
- SNMP "Input: SNMP" On \
- XMMS "Input: XMMS" Off \
- RRDTOOL "Output: RRDTool" On
+OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
+ DEBUG "Enable debugging" Off \
+ APACHE "Input: Apache mod_status (libcurl)" Off \
+ APCUPS "Input: APC UPS (apcupsd)" Off \
+ CURL "Input: CURL generic web statistics" Off \
+ NUTUPS "Input: NUT UPS daemon" Off \
+ INTERFACE "Input: Network interfaces (libstatgrab)" On \
+ MBMON "Input: MBMon" Off \
+ MYSQL "Input: MySQL" Off \
+ NGINX "Input: Nginx" Off \
+ PDNS "Input: PowerDNS" Off \
+ PGSQL "Input: PostgreSQL" Off \
+ PING "Input: Network latency (liboping)" On \
+ SNMP "Input: SNMP" On \
+ XMMS "Input: XMMS" Off \
+ RRDTOOL "Output: RRDTool" On
MAN1= collectd.1 collectd-nagios.1 collectdmon.1
MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
collectd-snmp.5 collectd-unixsock.5 collectd-perl.5 \
- types.db.5
+ collectd-java.5 collectd-python.5 types.db.5
USE_RC_SUBR= collectd collectdmon
+USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME} \
+ ${PREFIX}/lib
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -53,35 +58,66 @@ BROKEN= Need bind9 import post 6.1
# these are Linux specific, but others will probably run on
# FreeBSD as well, given a bit of careful attention.
CONFIGURE_ARGS= --localstatedir=/var \
+ --disable-getifaddrs \
--disable-apple_sensors \
--disable-ascent \
--disable-battery \
+ --disable-bind \
+ --disable-conntrack \
+ --disable-contextswitch \
--disable-cpufreq \
+ --disable-curl_json \
+ --disable-dbi \
--disable-disk \
--disable-entropy \
+ --disable-fscache \
+ --disable-gmond \
--disable-hddtemp \
--disable-iptables \
--disable-ipmi \
--disable-ipvs \
--disable-irq \
+ --disable-java \
--disable-libvirt \
+ --disable-madwifi \
+ --disable-match_empty_counter \
+ --disable-match_hashed \
+ --disable-match_regex \
+ --disable-match_timediff \
+ --disable-match_value \
+ --disable-memcachec \
--disable-multimeter \
+ --disable-netapp \
--disable-netlink \
--disable-nfs \
- --disable-nginx \
--disable-notify_desktop \
--disable-notify_email \
+ --disable-olsrd \
--disable-onewire \
+ --disable-openvpn \
+ --disable-oracle \
--disable-perl \
- --disable-postgresql \
+ --disable-python \
+ --disable-protocols \
+ --disable-routeros \
+ --disable-rrdcached \
--disable-sensors \
--disable-serial \
+ --disable-table \
--disable-tape \
+ --disable-target_notification \
+ --disable-target_replace \
+ --disable-target_scale \
+ --disable-target_set \
+ --disable-ted \
--disable-thermal \
+ --disable-tokyotyrant \
--disable-users \
--disable-vmem \
--disable-vserver \
--disable-wireless \
+ --disable-write_http \
+ --disable-zfs_arc \
--without-perl-bindings
.if defined(WITH_DEBUG)
@@ -115,6 +151,15 @@ CONFIGURE_ARGS+=--disable-apcups
PLIST_SUB+= APCUPS="@comment "
.endif
+.if defined(WITH_CURL)
+CONFIGURE_ARGS+=--enable-curl --with-libcurl=${LOCALBASE}
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+PLIST_SUB+= CURL=""
+.else
+CONFIGURE_ARGS+=--disable-curl
+PLIST_SUB+= CURL="@comment "
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut
@@ -153,6 +198,34 @@ CONFIGURE_ARGS+=--disable-mysql
PLIST_SUB+= MYSQL="@comment "
.endif
+.if defined(WITH_NGINX)
+USE_NGINX= yes
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+=--enable-nginx
+PLIST_SUB+= NGINX=""
+.else
+CONFIGURE_ARGS+=--disable-nginx
+PLIST_SUB+= NGINX="@comment "
+.endif
+
+.if defined(WITH_PDNS)
+USE_PDNS= yes
+CONFIGURE_ARGS+=--enable-powerdns
+PLIST_SUB+= PDNS=""
+.else
+CONFIGURE_ARGS+=--disable-powerdns
+PLIST_SUB+= PDNS="@comment "
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+CONFIGURE_ARGS+=--enable-postgresql
+PLIST_SUB+= PGSQL=""
+.else
+CONFIGURE_ARGS+=--disable-postgresql
+PLIST_SUB+= PGSQL="@comment "
+.endif
+
.if defined(WITH_PING)
LIB_DEPENDS+= oping:${PORTSDIR}/net/liboping
CONFIGURE_ARGS+=--enable-ping
@@ -206,6 +279,9 @@ post-patch:
-e 's;/opt/collectd/var/lib;/var/db;' \
-e 's;/opt/collectd/lib;${PREFIX}/lib;' \
${WRKSRC}/contrib/collection.conf
+ @${REINPLACE_CMD} \
+ -e 's;{libdir}/pkgconfig;{prefix}/libdata/pkgconfig;' \
+ ${WRKSRC}/configure
post-install:
${MKDIR} /var/db/collectd
diff --git a/net-mgmt/collectd/distinfo b/net-mgmt/collectd/distinfo
index 24b577a02551..ba957ae32ec2 100644
--- a/net-mgmt/collectd/distinfo
+++ b/net-mgmt/collectd/distinfo
@@ -1,3 +1,3 @@
-MD5 (collectd-4.5.1.tar.gz) = ab900d15662859b8793abf99eda15c29
-SHA256 (collectd-4.5.1.tar.gz) = 9ab967b7909d9c229cfcd4d1a5503da42f38a1246a53fc5cfaaf1dfde6fae8a1
-SIZE (collectd-4.5.1.tar.gz) = 1279434
+MD5 (collectd-4.9.2.tar.gz) = 2734f272753bfa8523dfed133866ae04
+SHA256 (collectd-4.9.2.tar.gz) = a171adf3f94136df3f56148084531e786ed72bda807dc0b3d9fb2bebe53b904d
+SIZE (collectd-4.9.2.tar.gz) = 1691127
diff --git a/net-mgmt/collectd/pkg-plist b/net-mgmt/collectd/pkg-plist
index f1eb8e179469..34cfb4a6af84 100644
--- a/net-mgmt/collectd/pkg-plist
+++ b/net-mgmt/collectd/pkg-plist
@@ -10,73 +10,126 @@ etc/collectd.conf.sample
%%CGI%%@exec if [ ! -f %B/collection.conf ] ; then cp -p %B/%f %B/collection.conf; fi
%%CGI%%@dirrmtry %%WWWDIR%%
bin/collectd-nagios
-lib/collectd/types.db
+lib/libcollectdclient.a
+lib/libcollectdclient.la
+lib/libcollectdclient.so
+lib/libcollectdclient.so.0
+%%APACHE%%lib/collectd/apache.a
%%APACHE%%lib/collectd/apache.la
%%APACHE%%lib/collectd/apache.so
+%%APCUPS%%lib/collectd/apcups.a
%%APCUPS%%lib/collectd/apcups.la
%%APCUPS%%lib/collectd/apcups.so
+lib/collectd/cpu.a
lib/collectd/cpu.la
lib/collectd/cpu.so
+lib/collectd/csv.a
lib/collectd/csv.la
lib/collectd/csv.so
+%%CURL%%lib/collectd/curl.a
+%%CURL%%lib/collectd/curl.la
+%%CURL%%lib/collectd/curl.so
+lib/collectd/df.a
lib/collectd/df.la
lib/collectd/df.so
+lib/collectd/dns.a
lib/collectd/dns.la
lib/collectd/dns.so
+lib/collectd/email.a
lib/collectd/email.la
lib/collectd/email.so
+lib/collectd/exec.a
lib/collectd/exec.la
lib/collectd/exec.so
lib/collectd/filecount.so
lib/collectd/filecount.la
+lib/collectd/filecount.a
+%%INTERFACE%%lib/collectd/interface.a
%%INTERFACE%%lib/collectd/interface.la
%%INTERFACE%%lib/collectd/interface.so
+lib/collectd/load.a
lib/collectd/load.la
lib/collectd/load.so
+lib/collectd/logfile.a
lib/collectd/logfile.la
lib/collectd/logfile.so
+%%MBMON%%lib/collectd/mbmon.a
%%MBMON%%lib/collectd/mbmon.la
%%MBMON%%lib/collectd/mbmon.so
lib/collectd/memcached.so
lib/collectd/memcached.la
+lib/collectd/memcached.a
+lib/collectd/memory.a
lib/collectd/memory.la
lib/collectd/memory.so
+%%MYSQL%%lib/collectd/mysql.a
%%MYSQL%%lib/collectd/mysql.la
%%MYSQL%%lib/collectd/mysql.so
+%%NGINX%%lib/collectd/nginx.a
+%%NGINX%%lib/collectd/nginx.la
+%%NGINX%%lib/collectd/nginx.so
+lib/collectd/network.a
lib/collectd/network.la
lib/collectd/network.so
+%%NUTUPS%%lib/collectd/nut.a
%%NUTUPS%%lib/collectd/nut.la
%%NUTUPS%%lib/collectd/nut.so
+lib/collectd/ntpd.a
lib/collectd/ntpd.la
lib/collectd/ntpd.so
+%%PGSQL%%lib/collectd/postgresql.a
+%%PGSQL%%lib/collectd/postgresql.la
+%%PGSQL%%lib/collectd/postgresql.so
+%%PING%%lib/collectd/ping.a
%%PING%%lib/collectd/ping.la
%%PING%%lib/collectd/ping.so
-lib/collectd/powerdns.so
-lib/collectd/powerdns.la
+%%PDNS%%lib/collectd/powerdns.so
+%%PDNS%%lib/collectd/powerdns.a
+%%PDNS%%lib/collectd/powerdns.la
lib/collectd/processes.so
lib/collectd/processes.la
+lib/collectd/processes.a
+%%RRD%%lib/collectd/rrdtool.a
%%RRD%%lib/collectd/rrdtool.la
%%RRD%%lib/collectd/rrdtool.so
+%%SNMP%%lib/collectd/snmp.a
%%SNMP%%lib/collectd/snmp.la
%%SNMP%%lib/collectd/snmp.so
+lib/collectd/swap.a
lib/collectd/swap.la
lib/collectd/swap.so
+lib/collectd/syslog.a
lib/collectd/syslog.la
lib/collectd/syslog.so
lib/collectd/tail.so
lib/collectd/tail.la
+lib/collectd/tail.a
lib/collectd/tcpconns.so
lib/collectd/tcpconns.la
+lib/collectd/tcpconns.a
lib/collectd/teamspeak2.so
lib/collectd/teamspeak2.la
+lib/collectd/teamspeak2.a
+lib/collectd/unixsock.a
lib/collectd/unixsock.la
lib/collectd/unixsock.so
+lib/collectd/uptime.so
+lib/collectd/uptime.la
+lib/collectd/uptime.a
lib/collectd/uuid.so
lib/collectd/uuid.la
+lib/collectd/uuid.a
+include/collectd/client.h
+include/collectd/lcc_features.h
+libdata/pkgconfig/libcollectdclient.pc
+%%XMMS%%lib/collectd/xmms.a
%%XMMS%%lib/collectd/xmms.la
%%XMMS%%lib/collectd/xmms.so
-share/collectd/postgresql_default.conf
+%%DATADIR%%/postgresql_default.conf
+%%DATADIR%%/types.db
@dirrm lib/collectd
-@dirrm share/collectd
+@dirrm include/collectd
+@dirrm %%DATADIR%%
@exec mkdir -p /var/db/collectd
-@unexec rmdir /var/db/collectd 2>/dev/null || true
+@cwd /
+@dirrmtry /var/db/collectd
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index a801671accea..1b7cedf55c8b 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -6,38 +6,43 @@
#
PORTNAME= collectd
-PORTVERSION= 4.5.1
-PORTREVISION= 3
+PORTVERSION= 4.9.2
CATEGORIES= net-mgmt
-MASTER_SITES= http://collectd.org/files/ \
- http://mirror.roe.ch/dist/${PORTNAME}/
+MASTER_SITES= http://collectd.org/files/
-MAINTAINER= daniel@roe.ch
+MAINTAINER= ports@bsdserwis.com
COMMENT= Systems & network statistics collection daemon
USE_GMAKE= yes
GNU_CONFIGURE= yes
WANT_GNOME= yes
-OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
- DEBUG "Enable debugging" Off \
- APACHE "Input: Apache mod_status (libcurl)" Off \
- APCUPS "Input: APC UPS (apcupsd)" Off \
- NUTUPS "Input: NUT UPS daemon" Off \
- INTERFACE "Input: Network interfaces (libstatgrab)" On \
- MBMON "Input: MBMon" Off \
- MYSQL "Input: MySQL" Off \
- PING "Input: Network latency (liboping)" On \
- SNMP "Input: SNMP" On \
- XMMS "Input: XMMS" Off \
- RRDTOOL "Output: RRDTool" On
+OPTIONS= CGI "Install collection.cgi (requires RRDTOOL)" Off \
+ DEBUG "Enable debugging" Off \
+ APACHE "Input: Apache mod_status (libcurl)" Off \
+ APCUPS "Input: APC UPS (apcupsd)" Off \
+ CURL "Input: CURL generic web statistics" Off \
+ NUTUPS "Input: NUT UPS daemon" Off \
+ INTERFACE "Input: Network interfaces (libstatgrab)" On \
+ MBMON "Input: MBMon" Off \
+ MYSQL "Input: MySQL" Off \
+ NGINX "Input: Nginx" Off \
+ PDNS "Input: PowerDNS" Off \
+ PGSQL "Input: PostgreSQL" Off \
+ PING "Input: Network latency (liboping)" On \
+ SNMP "Input: SNMP" On \
+ XMMS "Input: XMMS" Off \
+ RRDTOOL "Output: RRDTool" On
MAN1= collectd.1 collectd-nagios.1 collectdmon.1
MAN5= collectd.conf.5 collectd-email.5 collectd-exec.5 \
collectd-snmp.5 collectd-unixsock.5 collectd-perl.5 \
- types.db.5
+ collectd-java.5 collectd-python.5 types.db.5
USE_RC_SUBR= collectd collectdmon
+USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME} \
+ ${PREFIX}/lib
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -53,35 +58,66 @@ BROKEN= Need bind9 import post 6.1
# these are Linux specific, but others will probably run on
# FreeBSD as well, given a bit of careful attention.
CONFIGURE_ARGS= --localstatedir=/var \
+ --disable-getifaddrs \
--disable-apple_sensors \
--disable-ascent \
--disable-battery \
+ --disable-bind \
+ --disable-conntrack \
+ --disable-contextswitch \
--disable-cpufreq \
+ --disable-curl_json \
+ --disable-dbi \
--disable-disk \
--disable-entropy \
+ --disable-fscache \
+ --disable-gmond \
--disable-hddtemp \
--disable-iptables \
--disable-ipmi \
--disable-ipvs \
--disable-irq \
+ --disable-java \
--disable-libvirt \
+ --disable-madwifi \
+ --disable-match_empty_counter \
+ --disable-match_hashed \
+ --disable-match_regex \
+ --disable-match_timediff \
+ --disable-match_value \
+ --disable-memcachec \
--disable-multimeter \
+ --disable-netapp \
--disable-netlink \
--disable-nfs \
- --disable-nginx \
--disable-notify_desktop \
--disable-notify_email \
+ --disable-olsrd \
--disable-onewire \
+ --disable-openvpn \
+ --disable-oracle \
--disable-perl \
- --disable-postgresql \
+ --disable-python \
+ --disable-protocols \
+ --disable-routeros \
+ --disable-rrdcached \
--disable-sensors \
--disable-serial \
+ --disable-table \
--disable-tape \
+ --disable-target_notification \
+ --disable-target_replace \
+ --disable-target_scale \
+ --disable-target_set \
+ --disable-ted \
--disable-thermal \
+ --disable-tokyotyrant \
--disable-users \
--disable-vmem \
--disable-vserver \
--disable-wireless \
+ --disable-write_http \
+ --disable-zfs_arc \
--without-perl-bindings
.if defined(WITH_DEBUG)
@@ -115,6 +151,15 @@ CONFIGURE_ARGS+=--disable-apcups
PLIST_SUB+= APCUPS="@comment "
.endif
+.if defined(WITH_CURL)
+CONFIGURE_ARGS+=--enable-curl --with-libcurl=${LOCALBASE}
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+PLIST_SUB+= CURL=""
+.else
+CONFIGURE_ARGS+=--disable-curl
+PLIST_SUB+= CURL="@comment "
+.endif
+
.if defined(WITH_NUTUPS)
CONFIGURE_ARGS+=--enable-nut
BUILD_DEPENDS+= ${LOCALBASE}/include/upsclient.h:${PORTSDIR}/sysutils/nut
@@ -153,6 +198,34 @@ CONFIGURE_ARGS+=--disable-mysql
PLIST_SUB+= MYSQL="@comment "
.endif
+.if defined(WITH_NGINX)
+USE_NGINX= yes
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl
+CONFIGURE_ARGS+=--enable-nginx
+PLIST_SUB+= NGINX=""
+.else
+CONFIGURE_ARGS+=--disable-nginx
+PLIST_SUB+= NGINX="@comment "
+.endif
+
+.if defined(WITH_PDNS)
+USE_PDNS= yes
+CONFIGURE_ARGS+=--enable-powerdns
+PLIST_SUB+= PDNS=""
+.else
+CONFIGURE_ARGS+=--disable-powerdns
+PLIST_SUB+= PDNS="@comment "
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+CONFIGURE_ARGS+=--enable-postgresql
+PLIST_SUB+= PGSQL=""
+.else
+CONFIGURE_ARGS+=--disable-postgresql
+PLIST_SUB+= PGSQL="@comment "
+.endif
+
.if defined(WITH_PING)
LIB_DEPENDS+= oping:${PORTSDIR}/net/liboping
CONFIGURE_ARGS+=--enable-ping
@@ -206,6 +279,9 @@ post-patch:
-e 's;/opt/collectd/var/lib;/var/db;' \
-e 's;/opt/collectd/lib;${PREFIX}/lib;' \
${WRKSRC}/contrib/collection.conf
+ @${REINPLACE_CMD} \
+ -e 's;{libdir}/pkgconfig;{prefix}/libdata/pkgconfig;' \
+ ${WRKSRC}/configure
post-install:
${MKDIR} /var/db/collectd
diff --git a/net-mgmt/collectd5/distinfo b/net-mgmt/collectd5/distinfo
index 24b577a02551..ba957ae32ec2 100644
--- a/net-mgmt/collectd5/distinfo
+++ b/net-mgmt/collectd5/distinfo
@@ -1,3 +1,3 @@
-MD5 (collectd-4.5.1.tar.gz) = ab900d15662859b8793abf99eda15c29
-SHA256 (collectd-4.5.1.tar.gz) = 9ab967b7909d9c229cfcd4d1a5503da42f38a1246a53fc5cfaaf1dfde6fae8a1
-SIZE (collectd-4.5.1.tar.gz) = 1279434
+MD5 (collectd-4.9.2.tar.gz) = 2734f272753bfa8523dfed133866ae04
+SHA256 (collectd-4.9.2.tar.gz) = a171adf3f94136df3f56148084531e786ed72bda807dc0b3d9fb2bebe53b904d
+SIZE (collectd-4.9.2.tar.gz) = 1691127
diff --git a/net-mgmt/collectd5/pkg-plist b/net-mgmt/collectd5/pkg-plist
index f1eb8e179469..34cfb4a6af84 100644
--- a/net-mgmt/collectd5/pkg-plist
+++ b/net-mgmt/collectd5/pkg-plist
@@ -10,73 +10,126 @@ etc/collectd.conf.sample
%%CGI%%@exec if [ ! -f %B/collection.conf ] ; then cp -p %B/%f %B/collection.conf; fi
%%CGI%%@dirrmtry %%WWWDIR%%
bin/collectd-nagios
-lib/collectd/types.db
+lib/libcollectdclient.a
+lib/libcollectdclient.la
+lib/libcollectdclient.so
+lib/libcollectdclient.so.0
+%%APACHE%%lib/collectd/apache.a
%%APACHE%%lib/collectd/apache.la
%%APACHE%%lib/collectd/apache.so
+%%APCUPS%%lib/collectd/apcups.a
%%APCUPS%%lib/collectd/apcups.la
%%APCUPS%%lib/collectd/apcups.so
+lib/collectd/cpu.a
lib/collectd/cpu.la
lib/collectd/cpu.so
+lib/collectd/csv.a
lib/collectd/csv.la
lib/collectd/csv.so
+%%CURL%%lib/collectd/curl.a
+%%CURL%%lib/collectd/curl.la
+%%CURL%%lib/collectd/curl.so
+lib/collectd/df.a
lib/collectd/df.la
lib/collectd/df.so
+lib/collectd/dns.a
lib/collectd/dns.la
lib/collectd/dns.so
+lib/collectd/email.a
lib/collectd/email.la
lib/collectd/email.so
+lib/collectd/exec.a
lib/collectd/exec.la
lib/collectd/exec.so
lib/collectd/filecount.so
lib/collectd/filecount.la
+lib/collectd/filecount.a
+%%INTERFACE%%lib/collectd/interface.a
%%INTERFACE%%lib/collectd/interface.la
%%INTERFACE%%lib/collectd/interface.so
+lib/collectd/load.a
lib/collectd/load.la
lib/collectd/load.so
+lib/collectd/logfile.a
lib/collectd/logfile.la
lib/collectd/logfile.so
+%%MBMON%%lib/collectd/mbmon.a
%%MBMON%%lib/collectd/mbmon.la
%%MBMON%%lib/collectd/mbmon.so
lib/collectd/memcached.so
lib/collectd/memcached.la
+lib/collectd/memcached.a
+lib/collectd/memory.a
lib/collectd/memory.la
lib/collectd/memory.so
+%%MYSQL%%lib/collectd/mysql.a
%%MYSQL%%lib/collectd/mysql.la
%%MYSQL%%lib/collectd/mysql.so
+%%NGINX%%lib/collectd/nginx.a
+%%NGINX%%lib/collectd/nginx.la
+%%NGINX%%lib/collectd/nginx.so
+lib/collectd/network.a
lib/collectd/network.la
lib/collectd/network.so
+%%NUTUPS%%lib/collectd/nut.a
%%NUTUPS%%lib/collectd/nut.la
%%NUTUPS%%lib/collectd/nut.so
+lib/collectd/ntpd.a
lib/collectd/ntpd.la
lib/collectd/ntpd.so
+%%PGSQL%%lib/collectd/postgresql.a
+%%PGSQL%%lib/collectd/postgresql.la
+%%PGSQL%%lib/collectd/postgresql.so
+%%PING%%lib/collectd/ping.a
%%PING%%lib/collectd/ping.la
%%PING%%lib/collectd/ping.so
-lib/collectd/powerdns.so
-lib/collectd/powerdns.la
+%%PDNS%%lib/collectd/powerdns.so
+%%PDNS%%lib/collectd/powerdns.a
+%%PDNS%%lib/collectd/powerdns.la
lib/collectd/processes.so
lib/collectd/processes.la
+lib/collectd/processes.a
+%%RRD%%lib/collectd/rrdtool.a
%%RRD%%lib/collectd/rrdtool.la
%%RRD%%lib/collectd/rrdtool.so
+%%SNMP%%lib/collectd/snmp.a
%%SNMP%%lib/collectd/snmp.la
%%SNMP%%lib/collectd/snmp.so
+lib/collectd/swap.a
lib/collectd/swap.la
lib/collectd/swap.so
+lib/collectd/syslog.a
lib/collectd/syslog.la
lib/collectd/syslog.so
lib/collectd/tail.so
lib/collectd/tail.la
+lib/collectd/tail.a
lib/collectd/tcpconns.so
lib/collectd/tcpconns.la
+lib/collectd/tcpconns.a
lib/collectd/teamspeak2.so
lib/collectd/teamspeak2.la
+lib/collectd/teamspeak2.a
+lib/collectd/unixsock.a
lib/collectd/unixsock.la
lib/collectd/unixsock.so
+lib/collectd/uptime.so
+lib/collectd/uptime.la
+lib/collectd/uptime.a
lib/collectd/uuid.so
lib/collectd/uuid.la
+lib/collectd/uuid.a
+include/collectd/client.h
+include/collectd/lcc_features.h
+libdata/pkgconfig/libcollectdclient.pc
+%%XMMS%%lib/collectd/xmms.a
%%XMMS%%lib/collectd/xmms.la
%%XMMS%%lib/collectd/xmms.so
-share/collectd/postgresql_default.conf
+%%DATADIR%%/postgresql_default.conf
+%%DATADIR%%/types.db
@dirrm lib/collectd
-@dirrm share/collectd
+@dirrm include/collectd
+@dirrm %%DATADIR%%
@exec mkdir -p /var/db/collectd
-@unexec rmdir /var/db/collectd 2>/dev/null || true
+@cwd /
+@dirrmtry /var/db/collectd