aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-02-06 14:07:03 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-02-06 14:07:03 +0000
commit4cba0bf8a0a9cf63da02dd3ae8a743d06120d9f3 (patch)
treec4a9a5f1ac03914be9ae6985413493a7e17c1441
parent1b0ee9fc7ffddb396918ae29e2dcb15a76dc4233 (diff)
downloadports-4cba0bf8a0a9cf63da02dd3ae8a743d06120d9f3.tar.gz
ports-4cba0bf8a0a9cf63da02dd3ae8a743d06120d9f3.zip
Term::RawInput is a simple drop-in replacement for <STDIN> in scripts
with the additional ability to capture and return the non-standard keys like 'End', 'Escape', 'Insert', etc. WWW: http://search.cpan.org/dist/Term-RawInput/ This new port is needed to update devel/p5-Term-Menus. Approved by: sahil@/wen@ (mentors, implicit) Feature safe: yes
Notes
Notes: svn path=/head/; revision=268721
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Term-RawInput/Makefile25
-rw-r--r--devel/p5-Term-RawInput/distinfo2
-rw-r--r--devel/p5-Term-RawInput/pkg-descr5
-rw-r--r--devel/p5-Term-RawInput/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index be6313028bf4..b830330be9ac 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2240,6 +2240,7 @@
SUBDIR += p5-Term-ProgressBar
SUBDIR += p5-Term-Prompt
SUBDIR += p5-Term-Query
+ SUBDIR += p5-Term-RawInput
SUBDIR += p5-Term-ReadKey
SUBDIR += p5-Term-ReadLine-Zoid
SUBDIR += p5-Term-ReadPassword
diff --git a/devel/p5-Term-RawInput/Makefile b/devel/p5-Term-RawInput/Makefile
new file mode 100644
index 000000000000..d0bb97cc6d1f
--- /dev/null
+++ b/devel/p5-Term-RawInput/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Term-RawInput
+# Date created: 2011-02-06
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-RawInput
+PORTVERSION= 1.14
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/R/RE/REEDFISH/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Drop-in replacement for <STDIN> with handling of non-standard keys
+
+BUILD_DEPENDS= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::RawInput.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Term-RawInput/distinfo b/devel/p5-Term-RawInput/distinfo
new file mode 100644
index 000000000000..aed55e001b8b
--- /dev/null
+++ b/devel/p5-Term-RawInput/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Term-RawInput-1.14.tar.gz) = dfaadd751a269d1b15aa289276f28916076d1a1e6a25ecf24215c816eed49249
+SIZE (Term-RawInput-1.14.tar.gz) = 35696
diff --git a/devel/p5-Term-RawInput/pkg-descr b/devel/p5-Term-RawInput/pkg-descr
new file mode 100644
index 000000000000..02a0def505dc
--- /dev/null
+++ b/devel/p5-Term-RawInput/pkg-descr
@@ -0,0 +1,5 @@
+Term::RawInput is a simple drop-in replacement for <STDIN> in scripts
+with the additional ability to capture and return the non-standard keys
+like 'End', 'Escape', 'Insert', etc.
+
+WWW: http://search.cpan.org/dist/Term-RawInput/
diff --git a/devel/p5-Term-RawInput/pkg-plist b/devel/p5-Term-RawInput/pkg-plist
new file mode 100644
index 000000000000..dc6df79a6243
--- /dev/null
+++ b/devel/p5-Term-RawInput/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/RawInput/.packlist
+%%SITE_PERL%%/Term/RawInput.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/RawInput
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term
+@dirrmtry %%SITE_PERL%%/Term