aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-08-22 06:23:04 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-08-22 06:23:04 +0000
commitab13dfc26b31c6192bc80bddab1c044e58a7fb74 (patch)
tree962b59bdb07d7786d943b6acb69f325e39c075e6
parentda468fb883381b38e8b378529e6f401b11815980 (diff)
downloadports-ab13dfc26b31c6192bc80bddab1c044e58a7fb74.tar.gz
ports-ab13dfc26b31c6192bc80bddab1c044e58a7fb74.zip
Remove game: not worth trying to keep it afloat with the new GCC.
Notes
Notes: svn path=/head/; revision=198102
-rw-r--r--MOVED1
-rw-r--r--games/Makefile1
-rw-r--r--games/groundhog/Makefile22
-rw-r--r--games/groundhog/distinfo3
-rw-r--r--games/groundhog/files/patch-src-highscore.cc40
-rw-r--r--games/groundhog/files/patch-src-options_dialog.h35
-rw-r--r--games/groundhog/files/patch-src__game.cc49
-rw-r--r--games/groundhog/files/patch-src__pocket.h19
-rw-r--r--games/groundhog/files/patch-src__score.cc74
-rw-r--r--games/groundhog/files/patch-src__score.h50
-rw-r--r--games/groundhog/files/patch-src_highscore_tab.cc51
-rw-r--r--games/groundhog/files/patch-src_new_highscore_dialog.h19
-rw-r--r--games/groundhog/files/patch-src_solved_dialog.cc27
-rw-r--r--games/groundhog/pkg-descr3
-rw-r--r--games/groundhog/pkg-plist3
15 files changed, 1 insertions, 396 deletions
diff --git a/MOVED b/MOVED
index 64bb1917e8e8..7416addc0f75 100644
--- a/MOVED
+++ b/MOVED
@@ -3191,3 +3191,4 @@ editors/iiimecf||2007-08-19|Has expired: emacs20 and related ports are obsolete;
editors/gnuserv-emacs20||2007-08-19|Has expired: emacs20 and related ports are obsolete; please use a more recent version
devel/semantic-emacs20||2007-08-19|Has expired: emacs20 and related ports are obsolete; please use a more recent version
net/ddc||2007-08-22|Usability expired
+games/groundhog||2007-08-22|Game is not worth keeping
diff --git a/games/Makefile b/games/Makefile
index 795b0e2bf4ff..bbd64120c76e 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -310,7 +310,6 @@
SUBDIR += gretools
SUBDIR += grhino
SUBDIR += gridlock
- SUBDIR += groundhog
SUBDIR += gru
SUBDIR += grubik
SUBDIR += grubinvaders
diff --git a/games/groundhog/Makefile b/games/groundhog/Makefile
deleted file mode 100644
index 8ca6002fbc47..000000000000
--- a/games/groundhog/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-# New ports collection makefile for: groundhog
-# Date created: 23 May 2002
-# Whom: Edwin Groothuis
-#
-# $FreeBSD$
-#
-
-PORTNAME= groundhog
-PORTVERSION= 1.4
-PORTREVISION= 9
-CATEGORIES= games
-MASTER_SITES= http://home-2.tiscali.nl/~cb007736/
-
-MAINTAINER= edwin@mavetju.org
-COMMENT= Groundhog, a simple logic game
-
-USE_GMAKE= yes
-USE_GNOME= gtk20
-USE_GCC= 3.4
-GNU_CONFIGURE= yes
-
-.include <bsd.port.mk>
diff --git a/games/groundhog/distinfo b/games/groundhog/distinfo
deleted file mode 100644
index c7cfdb09ed9a..000000000000
--- a/games/groundhog/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (groundhog-1.4.tar.gz) = d350b9c214e4f3743d6f992c1fa72124
-SHA256 (groundhog-1.4.tar.gz) = 75567245a041a70f1ecb29503a424889136fcde81123234aedf5fb3ef9fad549
-SIZE (groundhog-1.4.tar.gz) = 221871
diff --git a/games/groundhog/files/patch-src-highscore.cc b/games/groundhog/files/patch-src-highscore.cc
deleted file mode 100644
index a616a816cd5b..000000000000
--- a/games/groundhog/files/patch-src-highscore.cc
+++ /dev/null
@@ -1,40 +0,0 @@
---- src/highscore.cc.orig Sat May 4 23:43:58 2002
-+++ src/highscore.cc Sun Oct 30 00:49:25 2005
-@@ -17,27 +17,30 @@
- */
-
- #include <fstream.h>
-+using namespace std;
-
- #include "highscore.h"
-
- void
- HighScore::Read()
- {
-- std::string filename = getenv("HOME");
-+ string filename = getenv("HOME");
- filename += "/.groundhog.highscore";
-- std::ifstream in(filename.c_str());
-+ ifstream in(filename.c_str());
-+ if (in==NULL)
-+ return;
- in >> _beginner >> _intermediate >> _expert;
- }
-
- void
- HighScore::Write()
- {
-- std::string filename = getenv("HOME");
-+ string filename = getenv("HOME");
- filename += "/.groundhog.highscore";
-- std::ofstream out(filename.c_str());
-- out << _beginner << std::endl
-- << _intermediate << std::endl
-- << _expert << std::endl;
-+ ofstream out(filename.c_str());
-+ out << _beginner << endl
-+ << _intermediate << endl
-+ << _expert << endl;
- }
-
-
diff --git a/games/groundhog/files/patch-src-options_dialog.h b/games/groundhog/files/patch-src-options_dialog.h
deleted file mode 100644
index b0c64880a5a1..000000000000
--- a/games/groundhog/files/patch-src-options_dialog.h
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: files/patch-src-element.h
-===================================================================
-RCS file: files/patch-src-element.h
-diff -N files/patch-src-element.h
---- /dev/null 1 Jan 1970 00:00:00 -0000
-+++ files/patch-src-element.h 16 Dec 2006 13:15:54 -0000
-@@ -0,0 +1,10 @@
-+--- src/element.h.orig Sat Dec 16 18:57:18 2006
-++++ src/element.h Sat Dec 16 18:57:31 2006
-+@@ -24,6 +24,7 @@
-+ class Element {
-+ public:
-+ Element() {}
-++ virtual ~Element() {}
-+ virtual void PutBall(Ball* ball);
-+ virtual void MoveBall(Ball* ball) = 0;
-+ virtual void ConnectLeft(Element* element) = 0;
-Index: files/patch-src-options_dialog.h
-===================================================================
-RCS file: files/patch-src-options_dialog.h
-diff -N files/patch-src-options_dialog.h
---- /dev/null 1 Jan 1970 00:00:00 -0000
-+++ files/patch-src-options_dialog.h 16 Dec 2006 13:16:14 -0000
-@@ -0,0 +1,11 @@
-+--- src/options_dialog.h.orig Sat Dec 16 18:57:43 2006
-++++ src/options_dialog.h Sat Dec 16 18:57:50 2006
-+@@ -28,7 +28,7 @@
-+ Game* _game;
-+ GtkWidget* _tooltips;
-+
-+- void OptionsDialog::OnOk();
-++ void OnOk();
-+ public:
-+ OptionsDialog(Game* game);
-+ };
diff --git a/games/groundhog/files/patch-src__game.cc b/games/groundhog/files/patch-src__game.cc
deleted file mode 100644
index 4fd3e4e53590..000000000000
--- a/games/groundhog/files/patch-src__game.cc
+++ /dev/null
@@ -1,49 +0,0 @@
---- src/game.cc.orig Sun May 5 04:30:51 2002
-+++ src/game.cc Sun Oct 30 00:48:40 2005
-@@ -18,10 +18,15 @@
-
- #include <config.h>
-
--#include <strstream.h>
-+#include <sstream>
-+#include <iostream>
-+#include <string>
-+
- #include <time.h>
- #include <unistd.h>
-
-+using namespace std;
-+
- #include "about_dialog.h"
- #include "ball.h"
- #include "game.h"
-@@ -193,21 +198,19 @@
- void
- Game::DisplayMoves()
- {
-- char info[128];
-- ostrstream ost(info, sizeof(info));
--
-- ost << _("Moves: ") << _nr_of_moves << std::ends;
-- gtk_label_set(GTK_LABEL(_moves), info);
-+ ostringstream ost;
-+ ost << _("Moves: ") << _nr_of_moves << ends; // format string
-+ string info = ost.str(); // retrieve formatted string
-+ gtk_label_set(GTK_LABEL(_moves), info.c_str());
- }
-
- void
- Game::DisplayTime()
- {
-- char info[128];
-- ostrstream ost(info, sizeof(info));
--
-- ost << _("Time: ") << _seconds << std::ends;
-- gtk_label_set(GTK_LABEL(_time), info);
-+ ostringstream ost;
-+ ost << _("Time: ") << _seconds << ends; // format string
-+ string info = ost.str(); // retrieve formatted string
-+ gtk_label_set(GTK_LABEL(_time), info.c_str());
- }
-
- void
diff --git a/games/groundhog/files/patch-src__pocket.h b/games/groundhog/files/patch-src__pocket.h
deleted file mode 100644
index d57e15350b4a..000000000000
--- a/games/groundhog/files/patch-src__pocket.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/pocket.h.orig Sun Oct 30 00:51:58 2005
-+++ src/pocket.h Sun Oct 30 00:52:09 2005
-@@ -20,6 +20,7 @@
- #define _POCKET_H_
-
- #include <list>
-+using namespace std;
-
- #include <gtk/gtk.h>
-
-@@ -54,7 +55,7 @@
- };
-
- class SetOffPockets {
-- std::list<Pocket*> _set;
-+ list<Pocket*> _set;
- public:
- SetOffPockets() {}
- void Add(Pocket* pocket) {_set.push_back(pocket);}
diff --git a/games/groundhog/files/patch-src__score.cc b/games/groundhog/files/patch-src__score.cc
deleted file mode 100644
index 11a2bf06fb76..000000000000
--- a/games/groundhog/files/patch-src__score.cc
+++ /dev/null
@@ -1,74 +0,0 @@
---- src/score.cc.orig Sun Oct 30 00:52:15 2005
-+++ src/score.cc Sun Oct 30 00:53:45 2005
-@@ -17,20 +17,21 @@
- */
-
- #include <iostream>
-+using namespace std;
- #include "score.h"
-
--std::ostream&
--operator<<(std::ostream& s, const Score& score)
-+ostream&
-+operator<<(ostream& s, const Score& score)
- {
- return s << "(\"" << score._name << "\" " << score._seconds << ')';
- }
-
--std::istream&
--operator>>(std::istream& s, Score& score)
-+istream&
-+operator>>(istream& s, Score& score)
- {
- char c;
-- std::ios::fmtflags flag = s.flags();
-- s.flags(flag & ~std::ios::skipws);
-+ ios::fmtflags flag = s.flags();
-+ s.flags(flag & ~ios::skipws);
-
- score._name = "";
- s >> c >> c;
-@@ -54,14 +55,14 @@
- bool
- ScoreList::IsNewHighScore(int seconds)
- {
-- std::list<Score>::iterator last = _list.end();
-+ list<Score>::iterator last = _list.end();
- return _list.size() < 10 || seconds < (*--last).GetSeconds();
- }
-
- void
- ScoreList::AddHighScore(Score& score)
- {
-- std::list<Score>::iterator i;
-+ list<Score>::iterator i;
- for (i = _list.begin(); i != _list.end(); i++)
- if (score < *i)
- break;
-@@ -74,18 +75,18 @@
- }
- }
-
--std::ostream&
--operator<<(std::ostream& s, const ScoreList& slist)
-+ostream&
-+operator<<(ostream& s, const ScoreList& slist)
- {
-- s << '(' << std::endl;
-- for (std::list<Score>::const_iterator i = slist._list.begin();
-+ s << '(' << endl;
-+ for (list<Score>::const_iterator i = slist._list.begin();
- i != slist._list.end(); i++)
-- s << *i << std::endl;
-- return s << ')' << std::endl;
-+ s << *i << endl;
-+ return s << ')' << endl;
- }
-
--std::istream&
--operator>>(std::istream& s, ScoreList& slist)
-+istream&
-+operator>>(istream& s, ScoreList& slist)
- {
- char c;
- s >> c;
diff --git a/games/groundhog/files/patch-src__score.h b/games/groundhog/files/patch-src__score.h
deleted file mode 100644
index 2aab7b586dfc..000000000000
--- a/games/groundhog/files/patch-src__score.h
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/score.h.orig Sun Oct 30 00:53:49 2005
-+++ src/score.h Sun Oct 30 00:54:22 2005
-@@ -20,34 +20,37 @@
- #define _SCORE_H
-
- #include <list>
-+#include <iostream>
- #include <string>
-
-+using namespace std;
-+
- class Score {
-- std::string _name;
-+ string _name;
- int _seconds;
- protected:
- public:
- Score() {}
-- Score(const std::string& name, int seconds) : _name(name),
-+ Score(const string& name, int seconds) : _name(name),
- _seconds(seconds) {}
- int operator<(Score& score);
-- friend std::ostream& operator<<(std::ostream& s, const Score& score);
-- friend std::istream& operator>>(std::istream& s, Score& score);
-- const std::string& GetName() const {return _name;}
-+ friend ostream& operator<<(ostream& s, const Score& score);
-+ friend istream& operator>>(istream& s, Score& score);
-+ const string& GetName() const {return _name;}
- int GetSeconds() const {return _seconds;}
- };
-
- class ScoreList {
-- std::list<Score> _list;
-+ list<Score> _list;
- protected:
- public:
- ScoreList() {}
- bool IsNewHighScore(int seconds);
- void AddHighScore(Score& score);
-- friend std::ostream& operator<<(std::ostream& s, const ScoreList& slist);
-- friend std::istream& operator>>(std::istream& s, ScoreList& slist);
-- std::list<Score>::const_iterator Begin() const {return _list.begin();}
-- std::list<Score>::const_iterator End() const {return _list.end();}
-+ friend ostream& operator<<(ostream& s, const ScoreList& slist);
-+ friend istream& operator>>(istream& s, ScoreList& slist);
-+ list<Score>::const_iterator Begin() const {return _list.begin();}
-+ list<Score>::const_iterator End() const {return _list.end();}
- };
-
- #endif // _SCORE_H
diff --git a/games/groundhog/files/patch-src_highscore_tab.cc b/games/groundhog/files/patch-src_highscore_tab.cc
deleted file mode 100644
index 522783dd64f0..000000000000
--- a/games/groundhog/files/patch-src_highscore_tab.cc
+++ /dev/null
@@ -1,51 +0,0 @@
---- src/highscore_tab.cc.orig Sun Oct 30 00:49:30 2005
-+++ src/highscore_tab.cc Sun Oct 30 00:51:04 2005
-@@ -16,7 +16,9 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- */
-
--#include <strstream.h>
-+#include <sstream>
-+#include <string>
-+using namespace std;
-
- #include "highscore_tab.h"
- #include "intl.h"
-@@ -37,11 +39,12 @@
- gtk_table_attach_defaults(GTK_TABLE(table), label, 2, 3, 0, 1);
-
- for (int i = 1; i <= 10; i++) {
-- char scratch[16];
-- std::ostrstream ost(scratch, sizeof(scratch));
--
-- ost << i << std::ends;
-- GtkWidget* index_label = gtk_label_new(scratch);
-+ ostringstream ost;
-+ ost << i << ends; // format string
-+ string temp = ost.str(); // retrieve formatted string
-+
-+ GtkWidget* index_label = gtk_label_new(temp.c_str());
-+
- gtk_table_attach_defaults(GTK_TABLE(table), index_label, 0, 1, i, i + 1);
-
- _names[i] = gtk_label_new(N_(""));
-@@ -66,14 +69,12 @@
- HighScoreTab::Fill(const ScoreList& slist)
- {
- int index = 1;
-- for (std::list<Score>::const_iterator i = slist.Begin();
-+ for (list<Score>::const_iterator i = slist.Begin();
- i != slist.End(); i++) {
-- char scratch[16];
-- std::ostrstream ost(scratch, sizeof(scratch));
--
-- ost << (*i).GetSeconds() << std::ends;
--
-- FillOneScore(index++, (*i).GetName().c_str(), scratch);
-+ ostringstream ost;
-+ ost << (*i).GetSeconds() << ends; // format string
-+ string temp = ost.str(); // retrieve string
-+ FillOneScore(index++, (*i).GetName().c_str(), temp.c_str());
- }
-
- for (; index <= 10; index++)
diff --git a/games/groundhog/files/patch-src_new_highscore_dialog.h b/games/groundhog/files/patch-src_new_highscore_dialog.h
deleted file mode 100644
index 234fc30bde8a..000000000000
--- a/games/groundhog/files/patch-src_new_highscore_dialog.h
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/new_highscore_dialog.h.orig Sun Oct 30 00:51:13 2005
-+++ src/new_highscore_dialog.h Sun Oct 30 00:51:28 2005
-@@ -20,6 +20,7 @@
- #define _NEW_HIGHSCORE_DIALOG_H
-
- #include <string>
-+using namespace std;
- #include "dialog.h"
-
- class Game;
-@@ -28,7 +29,7 @@
- Game* _game;
- GtkWidget* _name;
- char* GetLoginName();
-- std::string GetUserName();
-+ string GetUserName();
- protected:
- void OnOk();
- public:
diff --git a/games/groundhog/files/patch-src_solved_dialog.cc b/games/groundhog/files/patch-src_solved_dialog.cc
deleted file mode 100644
index 8514b318fb59..000000000000
--- a/games/groundhog/files/patch-src_solved_dialog.cc
+++ /dev/null
@@ -1,27 +0,0 @@
---- src/solved_dialog.cc.orig Sun Oct 30 00:54:28 2005
-+++ src/solved_dialog.cc Sun Oct 30 00:54:56 2005
-@@ -16,7 +16,9 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
- */
-
--#include <strstream.h>
-+#include <sstream>
-+#include <string>
-+using namespace std;
-
- #include "intl.h"
- #include "solved_dialog.h"
-@@ -33,9 +35,8 @@
- void
- SolvedDialog::SetLabel(int moves)
- {
-- char info[128];
-- std::ostrstream ost(info, sizeof(info));
--
-- ost << _(" Game solved in ") << moves << _(" moves!") << std::ends;
-- gtk_label_set(GTK_LABEL(_label), info);
-+ ostringstream ost;
-+ ost << _(" Game solved in ") << moves << _(" moves!") << ends;
-+ string info = ost.str();
-+ gtk_label_set(GTK_LABEL(_label), info.c_str());
- }
diff --git a/games/groundhog/pkg-descr b/games/groundhog/pkg-descr
deleted file mode 100644
index f7deb9793b22..000000000000
--- a/games/groundhog/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-Groundhog, a simple logic game.
-
-WWW: http://home-2.tiscali.nl/~cb007736/groundhog.html
diff --git a/games/groundhog/pkg-plist b/games/groundhog/pkg-plist
deleted file mode 100644
index ccb86a05fef2..000000000000
--- a/games/groundhog/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/groundhog
-share/locale/fr/LC_MESSAGES/groundhog.mo
-share/locale/nl/LC_MESSAGES/groundhog.mo