aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-22 09:53:42 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-22 09:53:42 +0000
commitb6557814826748ac134d3f042fb14956f15c19e4 (patch)
tree809d261d47c647c61d301c6ee95594993b3b96fe
parent3c3e126e730e4f93280878aedb94008a410d3621 (diff)
downloadports-b6557814826748ac134d3f042fb14956f15c19e4.tar.gz
ports-b6557814826748ac134d3f042fb14956f15c19e4.zip
- Add a patch to reverted execve command used when running make to
system( "make" ) so entire environment may be passed when building apache22. - Bump PORTREVISION PR: ports/90790 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=151823
-rw-r--r--ports-mgmt/portmanager/Makefile2
-rw-r--r--ports-mgmt/portmanager/files/patch-0.4.1_3133
-rw-r--r--sysutils/portmanager/Makefile2
-rw-r--r--sysutils/portmanager/files/patch-0.4.1_3133
4 files changed, 268 insertions, 2 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index a3d337c9454a..cb680f7b89bc 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portmanager
PORTVERSION= 0.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://portmanager.sunsite.dk/distfiles/ \
${MASTER_SITE_SOURCEFORGE}
diff --git a/ports-mgmt/portmanager/files/patch-0.4.1_3 b/ports-mgmt/portmanager/files/patch-0.4.1_3
new file mode 100644
index 000000000000..5a8a8ac1913e
--- /dev/null
+++ b/ports-mgmt/portmanager/files/patch-0.4.1_3
@@ -0,0 +1,133 @@
+diff -ruN ../0.4.1_2/libMGPM/src/MGPMrUpdate.c ./libMGPM/src/MGPMrUpdate.c
+--- ../0.4.1_2/libMGPM/src/MGPMrUpdate.c Mon Dec 19 11:45:50 2005
++++ ./libMGPM/src/MGPMrUpdate.c Wed Dec 21 22:16:31 2005
+@@ -979,114 +979,29 @@
+ /************************************************************************/
+ /* Command "9" " make" */
+ /************************************************************************/
+- env = malloc( sizeof( char** ) * 4 );
+- env[0] = malloc( MAXSTRINGSIZE );
+- env[1] = malloc( MAXSTRINGSIZE );
+- env[2] = malloc( MAXSTRINGSIZE );
+- env[3] = malloc( MAXSTRINGSIZE );
+- env[4] = 0;
+-
+- /*
+- * setup environment
+- */
+- MGmStrcpy( env[0], "PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin:/usr/X11R6/bin" );
+-
+- MGmStrcpy( env[1], "TERM=" );
+- MGmStrcat( env[1], getenv( "TERM" ) );
+-
+- if( getenv( "CCACHE_DIR" ) != NULL )
+- {
+- MGmStrcpy( env[2], "CCACHE_DIR=" );
+- MGmStrcat( env[2], getenv( "CCACHE_DIR" ) );
+- }
+- else
+- {
+- env[2][0] = 0;
+- }
+-
+- if( getenv( "CCACHE_PATH" ) != NULL )
+- {
+- MGmStrcpy( env[3], "CCACHE_PATH=/usr/bin:/usr/local/bin" );
+- }
+- else
+- {
+- env[3][0] = 0;
+- }
+-
++ MGmStrcpy( localProperty.command, "cd " );
++ MGmStrcat( localProperty.command, PORTSDIR );
++ MGmStrcat( localProperty.command, oldPortDir );
++ MGmStrcat( localProperty.command, " && make " );
+ if( MGrStrlen( localProperty.options ) > 0 )
+ {
+- cmd = malloc( sizeof( char** ) * 3 );
+- cmd[0] = malloc( MAXSTRINGSIZE );
+- cmd[1] = malloc( MAXBUFFERSIZE );
+- cmd[2] = 0;
+- MGmStrcpy( cmd[0], PORTSDIR );
+- MGmStrcat( cmd[0], oldPortDir );
+- if( chdir( cmd[0] ) != 0 )
+- {
+- fprintf( stderr, "%s error: chdir %s failed\n", id, cmd[0] );
+- perror( "chroot" );
+- while( fflush( stderr ) );
+- assert( 0 );
+- }
+- MGmStrcpy( cmd[0], "/usr/bin/make" );
+- MGmBuffercpy( cmd[1], localProperty.options, MAXBUFFERSIZE );
+- fprintf( stdout, "%s\n", SINGLE_LINES );
+- fprintf( stdout, "update %s \n", oldPortName );
+- fprintf( stdout, "%s %s command: #9 of 14 %s\nOPTIONS-=>%s\n", id, PACKAGE_VERSION, cmd[0], cmd[1] );
+- fprintf( stdout, "%s\n", SINGLE_LINES );
+- while( fflush( stdout ) );
+- MGmSystem( cmd, env );
+- free( cmd[0] );
+- free( cmd[1] );
+- free( cmd );
+- }
+- else
+- {
+- cmd = malloc( sizeof( char** ) * 2 );
+- cmd[0] = malloc( MAXSTRINGSIZE );
+- cmd[1] = 0;
+- MGmStrcpy( cmd[0], PORTSDIR );
+- MGmStrcat( cmd[0], oldPortDir );
+- if( chdir( cmd[0] ) != 0 )
+- {
+- fprintf( stderr, "%s error: chdir %s failed\n", id, cmd[0] );
+- perror( "chroot" );
+- while( fflush( stderr ) );
+- assert( 0 );
+- }
+- MGmStrcpy( cmd[0], "/usr/bin/make" );
+- fprintf( stdout, "%s\n", SINGLE_LINES );
+- fprintf( stdout, "update %s \n", oldPortName );
+- fprintf( stdout, "%s %s command: #9 of 14 %s\n", id, PACKAGE_VERSION, cmd[0] );
+- fprintf( stdout, "%s\n", SINGLE_LINES );
+- while( fflush( stdout ) );
+- MGmSystem( cmd, env );
+- free( cmd[0] );
+- free( cmd );
++ MGmStrcat( localProperty.command, localProperty.options );
+ }
+
+- if( MGrIfDirEntry( localProperty.workFullPath, ".build_done" ) == 0 )
++ fprintf( stdout, "%s\n", SINGLE_LINES );
++ fprintf( stdout, "update %s \n", oldPortName );
++ fprintf( stdout, "%s %s command: #9 of 14 %s\n", id, PACKAGE_VERSION, localProperty.command );
++ fprintf( stdout, "%s\n", SINGLE_LINES );
++ while( fflush( stdout ) );
++ if( ( errorCode = system(localProperty.command) ) )
+ {
+- fprintf( stderr, "%s\n", SINGLE_LINES );
+- fprintf( stderr, "%s error: %s %s failed during make, adding to ignore.db\n", id, oldPortName, oldPortDir );
+- fprintf( stderr, "%s\n", SINGLE_LINES );
+- while( fflush( stderr ) );
+- MGPMlogAdd( property, oldPortName, oldPortDir, "port failed to build during make, adding to ignore.db", " ", " " );
+- MGdbAdd( property->ignoreDb, oldPortDir, "port failed to build during make\n", NULL );
++ MGPMlogAdd( property, oldPortName, oldPortDir, "failed during make, adding to ignore.db", " ", " " );
++ fprintf( stdout, "%s %s error: make returned an error, adding %s to ignore.db\n", id, PACKAGE_VERSION, oldPortDir );
++ while( fflush( stdout ) );
++ MGdbAdd( property->ignoreDb, oldPortDir, "failed during make", NULL );
+ rCleanUp( property, &localProperty );
+- free( env[0] );
+- free( env[1] );
+- free( env[2] );
+- free( env );
+ return(0);
+ }
+-
+- free( env[0] );
+- free( env[1] );
+- free( env[2] );
+- free( env[3] );
+- free( env );
+-
+ /************************************************************************/
+ /* Command "10" pkg_create -b */
+ /************************************************************************/
diff --git a/sysutils/portmanager/Makefile b/sysutils/portmanager/Makefile
index a3d337c9454a..cb680f7b89bc 100644
--- a/sysutils/portmanager/Makefile
+++ b/sysutils/portmanager/Makefile
@@ -7,7 +7,7 @@
PORTNAME= portmanager
PORTVERSION= 0.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
MASTER_SITES= http://portmanager.sunsite.dk/distfiles/ \
${MASTER_SITE_SOURCEFORGE}
diff --git a/sysutils/portmanager/files/patch-0.4.1_3 b/sysutils/portmanager/files/patch-0.4.1_3
new file mode 100644
index 000000000000..5a8a8ac1913e
--- /dev/null
+++ b/sysutils/portmanager/files/patch-0.4.1_3
@@ -0,0 +1,133 @@
+diff -ruN ../0.4.1_2/libMGPM/src/MGPMrUpdate.c ./libMGPM/src/MGPMrUpdate.c
+--- ../0.4.1_2/libMGPM/src/MGPMrUpdate.c Mon Dec 19 11:45:50 2005
++++ ./libMGPM/src/MGPMrUpdate.c Wed Dec 21 22:16:31 2005
+@@ -979,114 +979,29 @@
+ /************************************************************************/
+ /* Command "9" " make" */
+ /************************************************************************/
+- env = malloc( sizeof( char** ) * 4 );
+- env[0] = malloc( MAXSTRINGSIZE );
+- env[1] = malloc( MAXSTRINGSIZE );
+- env[2] = malloc( MAXSTRINGSIZE );
+- env[3] = malloc( MAXSTRINGSIZE );
+- env[4] = 0;
+-
+- /*
+- * setup environment
+- */
+- MGmStrcpy( env[0], "PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/bin:/usr/X11R6/bin" );
+-
+- MGmStrcpy( env[1], "TERM=" );
+- MGmStrcat( env[1], getenv( "TERM" ) );
+-
+- if( getenv( "CCACHE_DIR" ) != NULL )
+- {
+- MGmStrcpy( env[2], "CCACHE_DIR=" );
+- MGmStrcat( env[2], getenv( "CCACHE_DIR" ) );
+- }
+- else
+- {
+- env[2][0] = 0;
+- }
+-
+- if( getenv( "CCACHE_PATH" ) != NULL )
+- {
+- MGmStrcpy( env[3], "CCACHE_PATH=/usr/bin:/usr/local/bin" );
+- }
+- else
+- {
+- env[3][0] = 0;
+- }
+-
++ MGmStrcpy( localProperty.command, "cd " );
++ MGmStrcat( localProperty.command, PORTSDIR );
++ MGmStrcat( localProperty.command, oldPortDir );
++ MGmStrcat( localProperty.command, " && make " );
+ if( MGrStrlen( localProperty.options ) > 0 )
+ {
+- cmd = malloc( sizeof( char** ) * 3 );
+- cmd[0] = malloc( MAXSTRINGSIZE );
+- cmd[1] = malloc( MAXBUFFERSIZE );
+- cmd[2] = 0;
+- MGmStrcpy( cmd[0], PORTSDIR );
+- MGmStrcat( cmd[0], oldPortDir );
+- if( chdir( cmd[0] ) != 0 )
+- {
+- fprintf( stderr, "%s error: chdir %s failed\n", id, cmd[0] );
+- perror( "chroot" );
+- while( fflush( stderr ) );
+- assert( 0 );
+- }
+- MGmStrcpy( cmd[0], "/usr/bin/make" );
+- MGmBuffercpy( cmd[1], localProperty.options, MAXBUFFERSIZE );
+- fprintf( stdout, "%s\n", SINGLE_LINES );
+- fprintf( stdout, "update %s \n", oldPortName );
+- fprintf( stdout, "%s %s command: #9 of 14 %s\nOPTIONS-=>%s\n", id, PACKAGE_VERSION, cmd[0], cmd[1] );
+- fprintf( stdout, "%s\n", SINGLE_LINES );
+- while( fflush( stdout ) );
+- MGmSystem( cmd, env );
+- free( cmd[0] );
+- free( cmd[1] );
+- free( cmd );
+- }
+- else
+- {
+- cmd = malloc( sizeof( char** ) * 2 );
+- cmd[0] = malloc( MAXSTRINGSIZE );
+- cmd[1] = 0;
+- MGmStrcpy( cmd[0], PORTSDIR );
+- MGmStrcat( cmd[0], oldPortDir );
+- if( chdir( cmd[0] ) != 0 )
+- {
+- fprintf( stderr, "%s error: chdir %s failed\n", id, cmd[0] );
+- perror( "chroot" );
+- while( fflush( stderr ) );
+- assert( 0 );
+- }
+- MGmStrcpy( cmd[0], "/usr/bin/make" );
+- fprintf( stdout, "%s\n", SINGLE_LINES );
+- fprintf( stdout, "update %s \n", oldPortName );
+- fprintf( stdout, "%s %s command: #9 of 14 %s\n", id, PACKAGE_VERSION, cmd[0] );
+- fprintf( stdout, "%s\n", SINGLE_LINES );
+- while( fflush( stdout ) );
+- MGmSystem( cmd, env );
+- free( cmd[0] );
+- free( cmd );
++ MGmStrcat( localProperty.command, localProperty.options );
+ }
+
+- if( MGrIfDirEntry( localProperty.workFullPath, ".build_done" ) == 0 )
++ fprintf( stdout, "%s\n", SINGLE_LINES );
++ fprintf( stdout, "update %s \n", oldPortName );
++ fprintf( stdout, "%s %s command: #9 of 14 %s\n", id, PACKAGE_VERSION, localProperty.command );
++ fprintf( stdout, "%s\n", SINGLE_LINES );
++ while( fflush( stdout ) );
++ if( ( errorCode = system(localProperty.command) ) )
+ {
+- fprintf( stderr, "%s\n", SINGLE_LINES );
+- fprintf( stderr, "%s error: %s %s failed during make, adding to ignore.db\n", id, oldPortName, oldPortDir );
+- fprintf( stderr, "%s\n", SINGLE_LINES );
+- while( fflush( stderr ) );
+- MGPMlogAdd( property, oldPortName, oldPortDir, "port failed to build during make, adding to ignore.db", " ", " " );
+- MGdbAdd( property->ignoreDb, oldPortDir, "port failed to build during make\n", NULL );
++ MGPMlogAdd( property, oldPortName, oldPortDir, "failed during make, adding to ignore.db", " ", " " );
++ fprintf( stdout, "%s %s error: make returned an error, adding %s to ignore.db\n", id, PACKAGE_VERSION, oldPortDir );
++ while( fflush( stdout ) );
++ MGdbAdd( property->ignoreDb, oldPortDir, "failed during make", NULL );
+ rCleanUp( property, &localProperty );
+- free( env[0] );
+- free( env[1] );
+- free( env[2] );
+- free( env );
+ return(0);
+ }
+-
+- free( env[0] );
+- free( env[1] );
+- free( env[2] );
+- free( env[3] );
+- free( env );
+-
+ /************************************************************************/
+ /* Command "10" pkg_create -b */
+ /************************************************************************/