aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-02-07 14:28:34 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-02-07 14:28:34 +0000
commite904154f16b24a90fcaa97ba78febe1fb92e0cfb (patch)
treeea75e6bebccc95b6e81f710684ff7991d870401b
parentcbef4fa3fb2352c1a993df61bd4a470bfb5adf40 (diff)
downloadports-e904154f16b24a90fcaa97ba78febe1fb92e0cfb.tar.gz
ports-e904154f16b24a90fcaa97ba78febe1fb92e0cfb.zip
- Fix build on amd64.
Approved by: gahr (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=268755
-rw-r--r--devel/dcmtk/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/dcmtk/Makefile b/devel/dcmtk/Makefile
index bf40de68def7..ae777e44aaf6 100644
--- a/devel/dcmtk/Makefile
+++ b/devel/dcmtk/Makefile
@@ -29,6 +29,12 @@ SHLIBS= dcmdata dcmdsig dcmimage dcmimgle dcmjpeg dcmnet \
SHLIBVER= ${PORTVERSION:R:R}
PLIST_SUB= SHLIBVER=${SHLIBVER}
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CFLAGS+= -fPIC
+.endif
+
post-install:
.for shlib in ${SHLIBS}
@${MV} ${PREFIX}/lib/lib${shlib}.so ${PREFIX}/lib/lib${shlib}.so.${SHLIBVER}
@@ -36,4 +42,4 @@ post-install:
.endfor
#.include "Makefile.man"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>