aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-29 18:05:44 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-29 18:05:44 +0000
commitf80701e818b7616f386f82912ce3a228ca7f2e81 (patch)
treec9d06e36458b6c4363356a787d2ef0f0b5cc19eb
parent0a7d6dc15287b47c5c9403a782696e864cb8b7b6 (diff)
downloadports-f80701e818b7616f386f82912ce3a228ca7f2e81.tar.gz
ports-f80701e818b7616f386f82912ce3a228ca7f2e81.zip
Douglas Thrift's Search Engine is an indexing search engine for use on small
websites such as personal or small business sites. It is designed to be very similar to Google for end users and its output is customizable. For indexing, it supports both the Robots Exclusion Protocol and the Robots META Tag as specified at http://www.robotstxt.org/wc/exclusion.html. WWW: http://computers.douglasthrift.net/searchengine/ PR: ports/64794 Submitted by: Douglas Thrift <douglas@douglasthrift.net>
Notes
Notes: svn path=/head/; revision=105638
-rw-r--r--www/Makefile1
-rw-r--r--www/dtse/Makefile39
-rw-r--r--www/dtse/distinfo2
-rw-r--r--www/dtse/pkg-descr10
-rw-r--r--www/dtse/pkg-plist17
5 files changed, 69 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 41e25a2f16b0..1180fc5d4e61 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -76,6 +76,7 @@
SUBDIR += dillo
SUBDIR += drivel
SUBDIR += drupal
+ SUBDIR += dtse
SUBDIR += eldav.el
SUBDIR += elinks
SUBDIR += emacs-w3m
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
new file mode 100644
index 000000000000..2c02ded017bb
--- /dev/null
+++ b/www/dtse/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: dtse
+# Date created: 7 Mar 2004
+# Whom: Douglas Thrift <douglas@douglasthrift.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dtse
+PORTVERSION= 1.2
+CATEGORIES= www perl5
+MASTER_SITES= http://computers.douglasthrift.net/searchengine/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= An indexing search engine for use on small websites
+
+.if defined(WITH_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
+.endif
+
+USE_PERL5= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}/${PORTNAME}
+
+MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.3
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/dtse/distinfo b/www/dtse/distinfo
new file mode 100644
index 000000000000..e4e502ed8b67
--- /dev/null
+++ b/www/dtse/distinfo
@@ -0,0 +1,2 @@
+MD5 (dtse-1.2-src.tar.bz2) = b7f7570f4f3ef96b66bafc236c4d91cd
+SIZE (dtse-1.2-src.tar.bz2) = 84957
diff --git a/www/dtse/pkg-descr b/www/dtse/pkg-descr
new file mode 100644
index 000000000000..c0b9012273ae
--- /dev/null
+++ b/www/dtse/pkg-descr
@@ -0,0 +1,10 @@
+Douglas Thrift's Search Engine is an indexing search engine for use on small
+websites such as personal or small business sites. It is designed to be
+very similar to Google for end users and its output is customizable. For
+indexing, it supports both the Robots Exclusion Protocol and the Robots META
+Tag as specified at http://www.robotstxt.org/wc/exclusion.html.
+
+WWW: http://computers.douglasthrift.net/searchengine/
+
+- Douglas Thrift
+douglas@douglasthrift.net
diff --git a/www/dtse/pkg-plist b/www/dtse/pkg-plist
new file mode 100644
index 000000000000..5a4bd3b5f27b
--- /dev/null
+++ b/www/dtse/pkg-plist
@@ -0,0 +1,17 @@
+dtse/LICENSE
+dtse/LICENSE.html
+dtse/README
+dtse/README.html
+dtse/osi-certified-90x75.png
+dtse/bin/Search
+dtse/http/dtse_pb.png
+dtse/http/search.cgi
+dtse/data/header.html
+dtse/data/body.html
+dtse/data/footer.html
+dtse/data/notfound.html
+dtse/data/pages.html
+@dirrm dtse/bin
+@dirrm dtse/http
+@dirrm dtse/data
+@dirrm dtse