aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2009-11-20 23:43:09 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2009-11-20 23:43:09 +0000
commit2bfb3ea41fa3ed2b8ed4f200f62c19cad6d315c9 (patch)
tree18de66688ff51fcadf4432378e65093fc93409df
parent38eb8c5339e31bce015d6652caf364542965d4d0 (diff)
downloadports-2bfb3ea41fa3ed2b8ed4f200f62c19cad6d315c9.tar.gz
ports-2bfb3ea41fa3ed2b8ed4f200f62c19cad6d315c9.zip
o Update to 1.6.0.18.
o comment section that explicitly includes bsd.port.options.mk, we don't need this functionality now, while it creates issues with Makefile.local PR: 135332 Reported by: Piotr Grabowski o add libexecinfo into the LIB_DEPENDS and fix linking with it. PR: 139776 Submitted by: Alexander V. Chernikov o add spandsp support (optional, turned off by default). PR: 133843 Submitted by: Alexander V. Chernikov
Notes
Notes: svn path=/head/; revision=244568
-rw-r--r--net/asterisk16/Makefile27
-rw-r--r--net/asterisk16/distinfo6
-rw-r--r--net/asterisk16/files/nocodecnego-patch-Makefile33
-rw-r--r--net/asterisk16/files/patch-main::Makefile10
-rw-r--r--net/asterisk16/pkg-plist24
5 files changed, 58 insertions, 42 deletions
diff --git a/net/asterisk16/Makefile b/net/asterisk16/Makefile
index 37a1ecec0698..23b45ef6a293 100644
--- a/net/asterisk16/Makefile
+++ b/net/asterisk16/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= asterisk
-PORTVERSION= 1.6.0.15
+PORTVERSION= 1.6.0.18
PKGNAMESUFFIX= 16
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
@@ -16,7 +16,8 @@ MAINTAINER= sobomax@FreeBSD.org
COMMENT= An Open Source PBX and telephony toolkit
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
- newt.51:${PORTSDIR}/devel/newt
+ newt.51:${PORTSDIR}/devel/newt \
+ execinfo:${PORTSDIR}/devel/libexecinfo
RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
ONLY_FOR_ARCHS= i386 sparc64 amd64 powerpc
@@ -53,17 +54,18 @@ OPTIONS= OGGVORBIS "Enable Ogg Vorbis support" on \
GSM "Enable GSM codec" on \
CURL "Enable CURL support" on \
ILBC "Enable iLBC codec" off \
+ SPANDSP "Enable Spandsp faxing support" off \
# CODEC_PATCH "Apply codec negotiation patch" off \
# MISC_PATCHES "Apply additional patches" off
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" || ${ARCH} == "amd64"
+#.if ${ARCH} == "i386" || ${ARCH} == "amd64"
#OPTIONS+= ZAPTEL "Enable Zaptel support" off
# Include this since we have altered OPTIONS.
-.include "$(PORTSDIR)/Mk/bsd.port.options.mk"
-.endif
+#.include "$(PORTSDIR)/Mk/bsd.port.options.mk"
+#.endif
.if !defined(WITH_H323)
PLIST_SUB+= WITH_H323="@comment "
@@ -182,13 +184,24 @@ LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
.if !defined(WITH_CURL)
PLIST_SUB+= WITH_CURL="@comment "
-CONFIGURE_ARGS+= --without-curl
+CONFIGURE_ARGS+= --with-curl=no \
+ --with-libcurl=no
.else
PLIST_SUB+= WITH_CURL=""
-CONFIGURE_ARGS+= --with-curl
+CONFIGURE_ARGS+= --with-curl \
+ --with-libcurl
LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
.endif
+.if !defined(WITH_SPANDSP)
+PLIST_SUB+= WITH_SPANDSP="@comment "
+CONFIGURE_ARGS+= --without-spandsp
+.else
+PLIST_SUB+= WITH_SPANDSP=""
+CONFIGURE_ARGS+= --with-spandsp
+LIB_DEPENDS+= spandsp.2:${PORTSDIR}/comms/spandsp-devel
+.endif
+
.if defined(WITH_CODEC_PATCH)
PATCHFILES= asterisk-1.4.22-codec-negotiation-20081110.diff.gz
PATCH_SITES= http://b2bua.org/chrome/site/
diff --git a/net/asterisk16/distinfo b/net/asterisk16/distinfo
index 9e6bc2b6b19c..3a786b27b438 100644
--- a/net/asterisk16/distinfo
+++ b/net/asterisk16/distinfo
@@ -1,3 +1,3 @@
-MD5 (asterisk-1.6.0.15.tar.gz) = d319f52d8d1d70f69583901e56720c30
-SHA256 (asterisk-1.6.0.15.tar.gz) = 159bf2c39ed2926d97f535c8d46bcf6c80853bab1269d596241c6ed30b27b92a
-SIZE (asterisk-1.6.0.15.tar.gz) = 23070325
+MD5 (asterisk-1.6.0.18.tar.gz) = b8bb4379fb4fde3ed705eb82999081b8
+SHA256 (asterisk-1.6.0.18.tar.gz) = d0d6ed924be8b5d552a4a17e843dae902f62bba8190173859e9525673595b9dc
+SIZE (asterisk-1.6.0.18.tar.gz) = 23068750
diff --git a/net/asterisk16/files/nocodecnego-patch-Makefile b/net/asterisk16/files/nocodecnego-patch-Makefile
index 7039a3d2cd43..ad36c7ac3288 100644
--- a/net/asterisk16/files/nocodecnego-patch-Makefile
+++ b/net/asterisk16/files/nocodecnego-patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2009-08-04 07:54:00.000000000 -0700
-+++ Makefile 2009-09-10 15:10:11.000000000 -0700
-@@ -111,7 +111,7 @@
+--- Makefile.orig 2009-11-03 12:00:27.000000000 -0800
++++ Makefile 2009-11-20 13:13:06.000000000 -0800
+@@ -118,7 +118,7 @@
OVERWRITE=y
# Include debug and macro symbols in the executables (-g) and profiling info (-pg)
@@ -9,7 +9,7 @@
# Define standard directories for various platforms
-@@ -141,7 +141,7 @@
+@@ -148,7 +148,7 @@
ASTMANDIR=$(mandir)
ifneq ($(findstring BSD,$(OSARCH)),)
ASTVARLIBDIR=$(prefix)/share/asterisk
@@ -18,7 +18,7 @@
ASTDBDIR=$(localstatedir)/db/asterisk
else
ASTVARLIBDIR=$(localstatedir)/lib/asterisk
-@@ -241,9 +241,11 @@
+@@ -248,9 +248,11 @@
_ASTCFLAGS+=-isystem /usr/local/include
endif
@@ -30,7 +30,7 @@
ifeq ($(PROC),ppc)
_ASTCFLAGS+=-fsigned-char
-@@ -251,7 +253,7 @@
+@@ -258,7 +260,7 @@
ifeq ($(OSARCH),FreeBSD)
# -V is understood by BSD Make, not by GNU make.
@@ -39,12 +39,7 @@
_ASTCFLAGS+=$(shell if test $(BSDVERSION) -lt 500016 ; then echo "-D_THREAD_SAFE"; fi)
endif
-@@ -454,25 +456,25 @@
- rm -f build_tools/menuselect-deps
-
- datafiles: _all
-- if [ x`$(ID) -un` = xroot ]; then CFLAGS="$(_ASTCFLAGS) $(ASTCFLAGS)" bash build_tools/mkpkgconfig $(DESTDIR)/usr/lib/pkgconfig; fi
-+ #if [ x`$(ID) -un` = xroot ]; then CFLAGS="$(_ASTCFLAGS) $(ASTCFLAGS)" bash build_tools/mkpkgconfig $(DESTDIR)/usr/lib/pkgconfig; fi
+@@ -467,21 +469,21 @@
# Should static HTTP be installed during make samples or even with its own target ala
# webvoicemail? There are portions here that *could* be customized but might also be
# improved a lot. I'll put it here for now.
@@ -63,17 +58,17 @@
done \
fi
- mkdir -p $(DESTDIR)$(ASTDATADIR)/images
-+ $(MKDIR) $(DESTDIR)$(ASTDATADIR)/images
++ $(MKDIR) $(DESTDIR)$(DOCSDIR)/images
for x in images/*.jpg; do \
- $(INSTALL) -m 644 $$x $(DESTDIR)$(ASTDATADIR)/images ; \
-+ $(BSD_INSTALL_DATA) $$x $(DESTDIR)$(ASTDATADIR)/images ; \
++ $(BSD_INSTALL_DATA) $$x $(DESTDIR)$(DOCSDIR)/images ; \
done
- mkdir -p $(DESTDIR)$(AGI_DIR)
+ $(MKDIR) $(DESTDIR)$(AGI_DIR)
$(MAKE) -C sounds install
update:
-@@ -496,47 +498,47 @@
+@@ -505,47 +507,47 @@
OLDHEADERS=$(filter-out $(NEWHEADERS),$(notdir $(wildcard $(DESTDIR)$(ASTHEADERDIR)/*.h)))
installdirs:
@@ -153,7 +148,7 @@
fi
$(SUBDIRS_INSTALL):
-@@ -570,7 +572,7 @@
+@@ -579,7 +581,7 @@
@exit 1
endif
@@ -162,7 +157,7 @@
@if [ -x /usr/sbin/asterisk-post-install ]; then \
/usr/sbin/asterisk-post-install $(DESTDIR) . ; \
fi
-@@ -602,38 +604,25 @@
+@@ -611,38 +613,25 @@
# XXX why *.adsi is installed first ?
adsi:
@echo Installing adsi config files...
@@ -209,7 +204,7 @@
echo "Creating asterisk.conf"; \
( \
echo "[directories](!) ; remove the (!) to enable this" ; \
-@@ -689,13 +678,16 @@
+@@ -698,13 +687,16 @@
echo "pbx_realtime=1.6" ; \
echo "res_agi=1.6" ; \
echo "app_set=1.6" ; \
@@ -229,7 +224,7 @@
@for x in phoneprov/*; do \
dst="$(DESTDIR)$(ASTDATADIR)/$$x" ; \
if [ -f $${dst} ]; then \
-@@ -711,14 +703,14 @@
+@@ -720,14 +712,14 @@
fi ;\
fi ; \
echo "Installing file $$x"; \
diff --git a/net/asterisk16/files/patch-main::Makefile b/net/asterisk16/files/patch-main::Makefile
index 34f320468cbc..836cee89062d 100644
--- a/net/asterisk16/files/patch-main::Makefile
+++ b/net/asterisk16/files/patch-main::Makefile
@@ -14,7 +14,7 @@ $FreeBSD$
ast_expr2.c ast_expr2.h:
bison -o $@ -d --name-prefix=ast_yy ast_expr2.y
-@@ -159,7 +159,7 @@
+@@ -159,13 +159,13 @@
GMIMELDFLAGS+=$(GMIME_LIB)
endif
@@ -23,3 +23,11 @@ $FreeBSD$
@$(CC) -c -o buildinfo.o $(_ASTCFLAGS) buildinfo.c $(ASTCFLAGS)
$(ECHO_PREFIX) echo " [LD] $^ -> $@"
ifneq ($(findstring chan_h323,$(MENUSELECT_CHANNELS)),)
+- $(CMD_PREFIX) $(CC) $(STATIC_BUILD) -o $@ $(ASTLINK) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS) $(GMIMELDFLAGS)
++ $(CMD_PREFIX) $(CC) $(STATIC_BUILD) -o $@ $(ASTLINK) $(LDFLAGS) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS) $(GMIMELDFLAGS)
+ else
+- $(CMD_PREFIX) $(CXX) $(STATIC_BUILD) -o $@ $(ASTLINK) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $(H323LDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS) $(H323LDLIBS) $(GMIMELDFLAGS)
++ $(CMD_PREFIX) $(CXX) $(STATIC_BUILD) -o $@ $(ASTLINK) $(LDFLAGS) $(AST_EMBED_LDFLAGS) $(ASTLDFLAGS) $(H323LDFLAGS) $^ buildinfo.o $(AST_LIBS) $(AST_EMBED_LIBS) $(H323LDLIBS) $(GMIMELDFLAGS)
+ endif
+ $(CMD_PREFIX) $(ASTTOPDIR)/build_tools/strip_nonapi $@ || rm $@
+
diff --git a/net/asterisk16/pkg-plist b/net/asterisk16/pkg-plist
index 5cc0709634de..8fdf4a6f06b9 100644
--- a/net/asterisk16/pkg-plist
+++ b/net/asterisk16/pkg-plist
@@ -326,7 +326,6 @@ lib/asterisk/modules/app_pickupchan.so
lib/asterisk/modules/app_readexten.so
lib/asterisk/modules/app_waituntil.so
%%WITH_ODBC%%lib/asterisk/modules/cdr_adaptive_odbc.so
-lib/asterisk/modules/cdr_sqlite3_custom.so
%%WITH_JABBER%%lib/asterisk/modules/chan_jingle.so
lib/asterisk/modules/chan_unistim.so
lib/asterisk/modules/codec_g722.so
@@ -371,6 +370,7 @@ lib/asterisk/modules/app_dumpchan.so
lib/asterisk/modules/app_echo.so
lib/asterisk/modules/app_exec.so
lib/asterisk/modules/app_externalivr.so
+%%WITH_SPANDSP%%lib/asterisk/modules/app_fax.so
lib/asterisk/modules/app_festival.so
lib/asterisk/modules/app_followme.so
lib/asterisk/modules/app_forkcdr.so
@@ -506,15 +506,12 @@ share/asterisk/agi-bin/agi-test.agi
share/asterisk/agi-bin/eagi-sphinx-test
share/asterisk/agi-bin/eagi-test
share/asterisk/agi-bin/jukebox.agi
-share/asterisk/firmware/iax/iaxy.bin
-share/asterisk/images/asterisk-intro.jpg
-share/asterisk/images/kpad2.jpg
share/asterisk/keys/freeworlddialup.pub
share/asterisk/keys/iaxtel.pub
share/asterisk/moh/.asterisk-moh-opsound-wav
-share/asterisk/moh/CHANGES-asterisk-moh-opsound-2.01
-share/asterisk/moh/CREDITS-asterisk-moh-opsound-2.01
-share/asterisk/moh/LICENSE-asterisk-moh-opsound-2.01
+share/asterisk/moh/CHANGES-asterisk-moh-opsound-wav
+share/asterisk/moh/CREDITS-asterisk-moh-opsound-wav
+share/asterisk/moh/LICENSE-asterisk-moh-opsound-wav
share/asterisk/moh/macroform-cold_day.wav
share/asterisk/moh/macroform-robot_dity.wav
share/asterisk/moh/macroform-the_simplicity.wav
@@ -524,8 +521,8 @@ share/asterisk/phoneprov/000000000000-directory.xml
share/asterisk/phoneprov/000000000000-phone.cfg
share/asterisk/phoneprov/000000000000.cfg
share/asterisk/phoneprov/polycom.xml
-share/asterisk/sounds/.asterisk-core-sounds-en-gsm-1.4.15
-share/asterisk/sounds/en/LICENSE-asterisk-core-en-1.4.15
+share/asterisk/sounds/.asterisk-core-sounds-en-gsm-1.4.16
+share/asterisk/sounds/en/LICENSE-asterisk-core-en-1.4.16
share/asterisk/sounds/en/conf-adminmenu-162.gsm
share/asterisk/sounds/en/conf-extended.gsm
share/asterisk/sounds/en/conf-nonextended.gsm
@@ -536,11 +533,12 @@ share/asterisk/sounds/en/vm-forward-multiple.gsm
share/asterisk/sounds/en/vm-invalid-password.gsm
share/asterisk/sounds/en/vm-marked-nonurgent.gsm
share/asterisk/sounds/en/vm-marked-urgent.gsm
+share/asterisk/sounds/en/vm-pls-try-again.gsm
share/asterisk/sounds/en/vm-record-prepend.gsm
share/asterisk/sounds/en/vm-review-nonurgent.gsm
share/asterisk/sounds/en/vm-review-urgent.gsm
-share/asterisk/sounds/en/CHANGES-asterisk-core-en-1.4.15
-share/asterisk/sounds/en/CREDITS-asterisk-core-en-1.4.15
+share/asterisk/sounds/en/CHANGES-asterisk-core-en-1.4.16
+share/asterisk/sounds/en/CREDITS-asterisk-core-en-1.4.16
share/asterisk/sounds/en/dir-usingkeypad.gsm
share/asterisk/sounds/en/dir-welcome.gsm
share/asterisk/sounds/en/agent-alreadyon.gsm
@@ -979,6 +977,8 @@ share/asterisk/static-http/prototype.js
%%DOCSDIR%%/WARNINGS
%%DOCSDIR%%/asterisk.css
%%DOCSDIR%%/asterisk.html
+%%DOCSDIR%%/images/asterisk-intro.jpg
+%%DOCSDIR%%/images/kpad2.jpg
%%DOCSDIR%%/images.aux
%%DOCSDIR%%/images.log
%%DOCSDIR%%/images.out
@@ -1271,6 +1271,7 @@ share/asterisk/static-http/prototype.js
%%DOCSDIR%%/node97.html
%%DOCSDIR%%/node98.html
%%DOCSDIR%%/node99.html
+@dirrm %%DOCSDIR%%/images
@dirrm %%DOCSDIR%%
@dirrm share/asterisk/static-http
@dirrm share/asterisk/sounds/en/silence
@@ -1286,7 +1287,6 @@ share/asterisk/static-http/prototype.js
@dirrm share/asterisk/phoneprov
@dirrm share/asterisk/moh
@dirrm share/asterisk/keys
-@dirrm share/asterisk/images
@dirrm share/asterisk/firmware/iax
@dirrm share/asterisk/firmware
@dirrm share/asterisk/agi-bin