aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-09-01 11:07:58 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-09-01 11:07:58 +0000
commit439a1ff205ac482db17279dd6e1ac8261e54de9c (patch)
tree9c8e1ad22768b7f403c9abbd4e8434263e67590b
parent60b9f91571a176de2388656d50ff8afae7d7bd9b (diff)
downloadports-439a1ff205ac482db17279dd6e1ac8261e54de9c.tar.gz
ports-439a1ff205ac482db17279dd6e1ac8261e54de9c.zip
Socketpipe connects over a TCP/IP socket a remote command to a local
input generation command and/or a local output processing command. The connection is made by redirecting the input/output file descriptors to the socket. This saves the context switching and data copying overhead associated with piping data through ssh(1) or rsh(1). Socketpipe must be installed on both machines and user authentication is still performed by a command like ssh(1) or rsh(1). The confidentiality and integrity of the data in transit is not protected against mallicious attacks; the command is designed for use in a trusted LAN environment. Submitted by: dds
Notes
Notes: svn path=/head/; revision=88262
-rw-r--r--net/Makefile1
-rw-r--r--net/socketpipe/Makefile20
-rw-r--r--net/socketpipe/distinfo1
-rw-r--r--net/socketpipe/pkg-descr14
-rw-r--r--net/socketpipe/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 31a1413f327c..9276d9efa32a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -654,6 +654,7 @@
SUBDIR += sntop
SUBDIR += socat
SUBDIR += socketbind
+ SUBDIR += socketpipe
SUBDIR += socks5
SUBDIR += spread
SUBDIR += spread-j
diff --git a/net/socketpipe/Makefile b/net/socketpipe/Makefile
new file mode 100644
index 000000000000..147eac1871b2
--- /dev/null
+++ b/net/socketpipe/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: socketpipe
+# Date created: 29 August 2003
+# Whom: dds
+#
+# $FreeBSD$
+#
+
+PORTNAME= socketpipe
+PORTVERSION= 1.3
+CATEGORIES= net
+MASTER_SITES= http://www.spinellis.gr/sw/unix/socketpipe/ \
+ http://www.dmst.aueb.gr/dds/sw/unix/socketpipe/
+
+MAINTAINER= dds@FreeBSD.org
+COMMENT= Zero overhead remote process plumbing
+
+MAN1= socketpipe.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/net/socketpipe/distinfo b/net/socketpipe/distinfo
new file mode 100644
index 000000000000..d97b12939e53
--- /dev/null
+++ b/net/socketpipe/distinfo
@@ -0,0 +1 @@
+MD5 (socketpipe-1.3.tar.gz) = ea76f7d5aff27347fd82c0bc129385a2
diff --git a/net/socketpipe/pkg-descr b/net/socketpipe/pkg-descr
new file mode 100644
index 000000000000..0f7f45b67835
--- /dev/null
+++ b/net/socketpipe/pkg-descr
@@ -0,0 +1,14 @@
+Socketpipe connects over a TCP/IP socket a remote command to a local
+input generation command and/or a local output processing command.
+The connection is made by redirecting the input/output file descriptors
+to the socket. This saves the context switching and data copying
+overhead associated with piping data through ssh(1) or rsh(1).
+Socketpipe must be installed on both machines and user authentication
+is still performed by a command like ssh(1) or rsh(1). The
+confidentiality and integrity of the data in transit is not protected
+against mallicious attacks; the command is designed for use in a
+trusted LAN environment.
+
+WWW: http://www.spinellis.gr/sw/unix/socketpipe
+
+- Diomidis Spinellis dds@aueb.gr
diff --git a/net/socketpipe/pkg-plist b/net/socketpipe/pkg-plist
new file mode 100644
index 000000000000..8b7ed9d686f6
--- /dev/null
+++ b/net/socketpipe/pkg-plist
@@ -0,0 +1 @@
+bin/socketpipe