aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-07-25 16:59:21 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-07-25 16:59:21 +0000
commit7efd508f1cecf3e08fc1169a139b20fe5c7b15ea (patch)
tree8b1fc1660ca6fe45e8e5acc96d7b41ac8f220084
parent88c0d0313e47e5a9ea8771c9a069adb171fabd08 (diff)
downloadports-7efd508f1cecf3e08fc1169a139b20fe5c7b15ea.tar.gz
ports-7efd508f1cecf3e08fc1169a139b20fe5c7b15ea.zip
- Update to 1.4.2
- Transfer maintainership PR: ports/99441 Submitted by: acm
Notes
Notes: svn path=/head/; revision=168739
-rw-r--r--devel/commoncpp/Makefile10
-rw-r--r--devel/commoncpp/distinfo6
-rw-r--r--devel/commoncpp/files/patch-src_nat.cpp12
-rw-r--r--devel/commoncpp/pkg-plist86
4 files changed, 51 insertions, 63 deletions
diff --git a/devel/commoncpp/Makefile b/devel/commoncpp/Makefile
index 0d8e11605ca9..14678f930c9d 100644
--- a/devel/commoncpp/Makefile
+++ b/devel/commoncpp/Makefile
@@ -5,15 +5,15 @@
# $FreeBSD$
#
-PORTNAME= commoncpp2
-PORTVERSION= 1.3.21
-PORTREVISION= 1
+PORTNAME= commoncpp
+PORTVERSION= 1.4.2
PORTEPOCH= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gnutelephony
+DISTNAME= ${PORTNAME:S/$/2/}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= acm@FreeBSD.org
COMMENT= GNU project portable class framework for C++
USE_GNOME= gnomehack gnometarget
@@ -27,7 +27,7 @@ CONFIGURE_ARGS= --without-libxml2
USE_GETOPT_LONG=yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GCC= 3.4
+USE_GCC= 3.4+
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_path_DOXYGEN=no
INSTALLS_SHLIB= yes
diff --git a/devel/commoncpp/distinfo b/devel/commoncpp/distinfo
index c637632a0617..e4671f860cf8 100644
--- a/devel/commoncpp/distinfo
+++ b/devel/commoncpp/distinfo
@@ -1,3 +1,3 @@
-MD5 (commoncpp2-1.3.21.tar.gz) = a7614e7d81d3dfd6d0cb19a9daf6e29b
-SHA256 (commoncpp2-1.3.21.tar.gz) = 4450638079ce60dabaa0b333ae1f1994172550301ac9997c19e342938ad19e6e
-SIZE (commoncpp2-1.3.21.tar.gz) = 833359
+MD5 (commoncpp2-1.4.2.tar.gz) = 4153ec41bc11c52f05f2f2e35cf66953
+SHA256 (commoncpp2-1.4.2.tar.gz) = 640a2201209d4b2b9795729219036b3f058907675c18f8848addb3a69f8e4202
+SIZE (commoncpp2-1.4.2.tar.gz) = 851571
diff --git a/devel/commoncpp/files/patch-src_nat.cpp b/devel/commoncpp/files/patch-src_nat.cpp
deleted file mode 100644
index a4dc33331450..000000000000
--- a/devel/commoncpp/files/patch-src_nat.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/nat.cpp.orig Tue Jun 28 23:19:51 2005
-+++ src/nat.cpp Tue Jun 28 23:26:15 2005
-@@ -127,6 +127,9 @@
- #else
- # define NAT_SYSCALL "ioctl"
- # ifdef HAVE_NAT_IPF
-+# ifndef IPL_NAT
-+# define IPL_NAT IPNAT_NAME
-+# endif
- # define NAT_DEVICE IPL_NAT
- # else
- # ifdef HAVE_NAT_PF
diff --git a/devel/commoncpp/pkg-plist b/devel/commoncpp/pkg-plist
index d187835ba412..fbd591ad4c6d 100644
--- a/devel/commoncpp/pkg-plist
+++ b/devel/commoncpp/pkg-plist
@@ -1,53 +1,53 @@
bin/ccgnu2-config
-include/cc++2/cc++/address.h
-include/cc++2/cc++/buffer.h
-include/cc++2/cc++/cmdoptns.h
-include/cc++2/cc++/common.h
-include/cc++2/cc++/config.h
-include/cc++2/cc++/counter.h
-include/cc++2/cc++/digest.h
-include/cc++2/cc++/exception.h
-include/cc++2/cc++/export.h
-include/cc++2/cc++/file.h
-include/cc++2/cc++/functions.h
-include/cc++2/cc++/mime.h
-include/cc++2/cc++/misc.h
-include/cc++2/cc++/missing.h
-include/cc++2/cc++/network.h
-include/cc++2/cc++/numbers.h
-include/cc++2/cc++/objcount.h
-include/cc++2/cc++/objlink.h
-include/cc++2/cc++/objmap.h
-include/cc++2/cc++/objsync.h
-include/cc++2/cc++/oststring.h
-include/cc++2/cc++/persist.h
-include/cc++2/cc++/pointer.h
-include/cc++2/cc++/process.h
-include/cc++2/cc++/serial.h
-include/cc++2/cc++/slog.h
-include/cc++2/cc++/socket.h
-include/cc++2/cc++/socketport.h
-include/cc++2/cc++/strchar.h
-include/cc++2/cc++/string.h
-include/cc++2/cc++/template.h
-include/cc++2/cc++/thread.h
-include/cc++2/cc++/tokenizer.h
-include/cc++2/cc++/unix.h
-include/cc++2/cc++/url.h
-include/cc++2/cc++/xml.h
-include/cc++2/cc++/zstream.h
-lib/libccext2-1.3.so
-lib/libccext2-1.3.so.1
+include/cc++/address.h
+include/cc++/buffer.h
+include/cc++/cmdoptns.h
+include/cc++/common.h
+include/cc++/config.h
+include/cc++/counter.h
+include/cc++/digest.h
+include/cc++/exception.h
+include/cc++/export.h
+include/cc++/file.h
+include/cc++/functions.h
+include/cc++/mime.h
+include/cc++/misc.h
+include/cc++/missing.h
+include/cc++/network.h
+include/cc++/numbers.h
+include/cc++/objcount.h
+include/cc++/object.h
+include/cc++/objlink.h
+include/cc++/objmap.h
+include/cc++/objsync.h
+include/cc++/oststring.h
+include/cc++/persist.h
+include/cc++/pointer.h
+include/cc++/process.h
+include/cc++/serial.h
+include/cc++/slog.h
+include/cc++/socket.h
+include/cc++/socketport.h
+include/cc++/strchar.h
+include/cc++/string.h
+include/cc++/template.h
+include/cc++/thread.h
+include/cc++/tokenizer.h
+include/cc++/unix.h
+include/cc++/url.h
+include/cc++/xml.h
+include/cc++/zstream.h
+lib/libccext2-1.4.so
+lib/libccext2-1.4.so.0
lib/libccext2.a
lib/libccext2.la
lib/libccext2.so
-lib/libccgnu2-1.3.so
-lib/libccgnu2-1.3.so.1
+lib/libccgnu2-1.4.so
+lib/libccgnu2-1.4.so.0
lib/libccgnu2.a
lib/libccgnu2.la
lib/libccgnu2.so
libdata/pkgconfig/libccext2.pc
libdata/pkgconfig/libccgnu2.pc
share/aclocal/ost_check2.m4
-@dirrm include/cc++2/cc++
-@dirrm include/cc++2
+@dirrm include/cc++