aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-05-26 06:53:07 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-05-26 06:53:07 +0000
commit9e92525fd977777a3bf86e56def5fcecf1d36b8e (patch)
tree31e2bc053ed200d0c9be3d9ffc5a70538252d3a8
parente949724ea8634d88a492fa4319592adafc4b3ed8 (diff)
downloadports-9e92525fd977777a3bf86e56def5fcecf1d36b8e.tar.gz
ports-9e92525fd977777a3bf86e56def5fcecf1d36b8e.zip
Fix a potential crash in Evolution when closing a window.
Notes
Notes: svn path=/head/; revision=136147
-rw-r--r--x11-toolkits/gal2/Makefile1
-rw-r--r--x11-toolkits/gal2/files/patch-gal_widgets_e-canvas.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/x11-toolkits/gal2/Makefile b/x11-toolkits/gal2/Makefile
index 9968f70ecad0..f7e3ae1e2f3c 100644
--- a/x11-toolkits/gal2/Makefile
+++ b/x11-toolkits/gal2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gal2
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
diff --git a/x11-toolkits/gal2/files/patch-gal_widgets_e-canvas.c b/x11-toolkits/gal2/files/patch-gal_widgets_e-canvas.c
new file mode 100644
index 000000000000..10dc71d4cb9f
--- /dev/null
+++ b/x11-toolkits/gal2/files/patch-gal_widgets_e-canvas.c
@@ -0,0 +1,11 @@
+--- gal/widgets/e-canvas.c.orig Tue May 24 01:16:33 2005
++++ gal/widgets/e-canvas.c Tue May 24 01:16:51 2005
+@@ -1015,7 +1015,7 @@ void e_canvas_popup_tooltip (ECanvas *ca
+
+ void e_canvas_hide_tooltip (ECanvas *canvas)
+ {
+- if (canvas->tooltip_window) {
++ if (canvas && canvas->tooltip_window) {
+ gtk_widget_destroy (canvas->tooltip_window);
+ canvas->tooltip_window = NULL;
+ }