aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-09-03 05:13:45 +0000
committerYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-09-03 05:13:45 +0000
commitbb4a876c06db9389ff34c6a79df61f7447f5558c (patch)
tree2fe2ac777a552f6182735dd724b1446c2705521c
parentd8e7c17f9b401d63829ce3b01805d6094c9c6a89 (diff)
downloadports-bb4a876c06db9389ff34c6a79df61f7447f5558c.tar.gz
ports-bb4a876c06db9389ff34c6a79df61f7447f5558c.zip
Import mode-info, which provides a set of functions on Emacsen
to refer manuals with describe-* like interface. Repo-copied from: japanese/elisp-info
Notes
Notes: svn path=/head/; revision=65530
-rw-r--r--editors/mode-info/Makefile66
-rw-r--r--editors/mode-info/distinfo2
-rw-r--r--editors/mode-info/files/ELISP_CFG3
-rw-r--r--editors/mode-info/files/elisp-info-setup.el11
-rw-r--r--editors/mode-info/pkg-comment2
-rw-r--r--editors/mode-info/pkg-descr11
-rw-r--r--editors/mode-info/pkg-message8
-rw-r--r--editors/mode-info/pkg-plist39
8 files changed, 92 insertions, 50 deletions
diff --git a/editors/mode-info/Makefile b/editors/mode-info/Makefile
index 3c621c521c78..395bce5cf964 100644
--- a/editors/mode-info/Makefile
+++ b/editors/mode-info/Makefile
@@ -5,36 +5,58 @@
# $FreeBSD$
#
-PORTNAME= elisp-info
-PORTVERSION= 2.11
-CATEGORIES= japanese elisp
+PORTNAME= mode-info
+PORTVERSION= 0.1.3
+CATEGORIES= elisp
MASTER_SITES= http://namazu.org/~tsuchiya/elisp/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX= .el
MAINTAINER= yoichi@FreeBSD.org
-BUILD_DEPENDS= ${LOCALBASE}/info/elisp-ja:${PORTSDIR}/japanese/elisp-manual
-RUN_DEPENDS= ${LOCALBASE}/info/elisp-ja:${PORTSDIR}/japanese/elisp-manual
+MI_INDEX+= mi-emacs.idx
+MI_WITH_ELISP?= yes
+MI_ELISP_LANG?= en
-NO_WRKSUBDIR= yes
-EXTRACT_CMD= ${CP}
-EXTRACT_BEFORE_ARGS= -p
-EXTRACT_AFTER_ARGS= ./
+.if (${MI_WITH_ELISP} == "yes")
+.if (${MI_ELISP_LANG} == "en")
+BUILD_DEPENDS+= ${LOCALBASE}/info/elisp:${PORTSDIR}/lang/elisp-manual
+RUN_DEPENDS+= ${LOCALBASE}/info/elisp:${PORTSDIR}/lang/elisp-manual
+.elif (${MI_ELISP_LANG} == "ja")
+BUILD_DEPENDS+= ${LOCALBASE}/info/elisp-ja:${PORTSDIR}/japanese/elisp-manual
+RUN_DEPENDS+= ${LOCALBASE}/info/elisp-ja:${PORTSDIR}/japanese/elisp-manual
+.else
+.error MI_ELISP_LANG should be "en" or "ja".
+.endif
+MI_INDEX+= mi-elisp.idx
+PLIST_SUB+= MI_WITH_ELISP=""
+.else
+PLIST_SUB+= MI_WITH_ELISP="@comment "
+.endif
EMACS_PORT_NAME?= emacs21
EMACS_NO_RUN_DEPENDS= yes
LISPDIR?= ${PREFIX}/${EMACS_SITE_LISPDIR}/${PORTNAME}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-emacs=${EMACS_CMD} \
+ --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/mode-info
+ALL_TARGET= default index
+#INSTALL_TARGET= install install-index
-post-extract:
- ${CP} ${FILESDIR}/ELISP_CFG ${WRKDIR}
-do-build:
- (cd ${WRKDIR}; \
- ${EMACS_CMD} -batch -l ./ELISP_CFG -l ./${PORTNAME}.el -f ${PORTNAME}-make-index)
-do-install:
- ${MKDIR} ${LISPDIR}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}.el ${LISPDIR}
- ${INSTALL_DATA} ${WRKDIR}/${PORTNAME}-index.el ${LISPDIR}
- ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}-setup.el ${LISPDIR}
-
+post-configure:
+.if (${MI_ELISP_LANG} == "en")
+ ${ECHO_CMD} "(setq mode-info-elisp-titles (list \"elisp\"))" >> ${WRKSRC}/elisp-comp
+.elif (${MI_ELISP_LANG} == "ja")
+ ${ECHO_CMD} "(setq mode-info-elisp-titles (list \"elisp-ja\"))" >> ${WRKSRC}/elisp-comp
+.endif
+post-install:
+.for i in ${MI_INDEX}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/mode-info/
+.endfor
+ ${RM} ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/mode-info/ChangeLog
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README README.ja ChangeLog
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/editors/mode-info/distinfo b/editors/mode-info/distinfo
index 08cb74c396ca..e4424282f77c 100644
--- a/editors/mode-info/distinfo
+++ b/editors/mode-info/distinfo
@@ -1 +1 @@
-MD5 (elisp-info.el) = 8f1d82402b087992586186597a88fe4c
+MD5 (mode-info-0.1.3.tar.gz) = 114c3447e9af3a0003ca2fa06c3b06a0
diff --git a/editors/mode-info/files/ELISP_CFG b/editors/mode-info/files/ELISP_CFG
deleted file mode 100644
index a426e885e557..000000000000
--- a/editors/mode-info/files/ELISP_CFG
+++ /dev/null
@@ -1,3 +0,0 @@
-(require 'info)
-(info-initialize)
-(setq elisp-info-list '("elisp-ja"))
diff --git a/editors/mode-info/files/elisp-info-setup.el b/editors/mode-info/files/elisp-info-setup.el
deleted file mode 100644
index f1c56717c4b1..000000000000
--- a/editors/mode-info/files/elisp-info-setup.el
+++ /dev/null
@@ -1,11 +0,0 @@
-;; Setup for elisp-info.el
-(require 'elisp-info)
-(eval-after-load "help.el"
- (progn
- (define-key help-map "f" 'elisp-info-describe-function)
- (define-key help-map "d" 'elisp-info-describe-function)
- (define-key help-map "D" 'describe-function)
- (define-key help-map "v" 'elisp-info-describe-variable)
- (define-key help-map "V" 'describe-variable)
- (define-key help-mode-map "i" 'elisp-info-help-to-info)))
-(provide 'elisp-info-setup) \ No newline at end of file
diff --git a/editors/mode-info/pkg-comment b/editors/mode-info/pkg-comment
index eddebd1dbefd..450565e31a51 100644
--- a/editors/mode-info/pkg-comment
+++ b/editors/mode-info/pkg-comment
@@ -1 +1 @@
-Functions to refer Emacs-Lisp Reference Manual
+Functions to refer Manuals on Emacsen with describe-* like interface
diff --git a/editors/mode-info/pkg-descr b/editors/mode-info/pkg-descr
index ee499a09b98b..f54e22fb2005 100644
--- a/editors/mode-info/pkg-descr
+++ b/editors/mode-info/pkg-descr
@@ -1,9 +1,4 @@
-This package provide functions for Emacs with which you can
-find description of function or variable from Emacs-Lisp
-Reference Manual. If you put (require 'elisp-info-setup)
-in ~/.emacs then following key binds are provided.
+This package provide functions to refer Manuals (info files)
+on Emacs with similar interface to describe-{function,variable}.
-C-h f (C-h d) : elisp-info-describe-function
-C-h D : describe-function
-C-h v : elisp-info-describe-variable
-C-h V : describe-variable
+WWW: http://www.namazu.org/~tsuchiya/elisp/mode-info/ (Japanese)
diff --git a/editors/mode-info/pkg-message b/editors/mode-info/pkg-message
new file mode 100644
index 000000000000..9ac64faa8737
--- /dev/null
+++ b/editors/mode-info/pkg-message
@@ -0,0 +1,8 @@
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
+;; You should add following lines into your ~/.emacs
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
+(require 'mi-config)
+(global-set-key "\C-hf" 'mode-info-describe-function)
+(global-set-key "\C-hv" 'mode-info-describe-variable)
+(global-set-key "\M-." 'mode-info-find-tag)
+;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
diff --git a/editors/mode-info/pkg-plist b/editors/mode-info/pkg-plist
index 80f6c0e28173..6d274de497fa 100644
--- a/editors/mode-info/pkg-plist
+++ b/editors/mode-info/pkg-plist
@@ -1,4 +1,35 @@
-%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info.el
-%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info-index.el
-%%EMACS_SITE_LISPDIR%%/elisp-info/elisp-info-setup.el
-@dirrm %%EMACS_SITE_LISPDIR%%/elisp-info
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-config.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-config.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-elisp.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-elisp.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-emacs.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-emacs.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-fontify.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-fontify.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-gauche.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-gauche.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-guile.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-guile.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-index.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-index.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-libc.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-libc.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-octave.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-octave.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-perl.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-perl.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-ruby.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-ruby.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-scheme.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-scheme.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-util.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-util.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mode-info.el
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mode-info.elc
+%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-emacs.idx
+%%MI_WITH_ELISP%%%%EMACS_VERSION_SITE_LISPDIR%%/mode-info/mi-elisp.idx
+@dirrm %%EMACS_VERSION_SITE_LISPDIR%%/mode-info
+%%PORTDOCS%%share/doc/mode-info/ChangeLog
+%%PORTDOCS%%share/doc/mode-info/README
+%%PORTDOCS%%share/doc/mode-info/README.ja
+%%PORTDOCS%%@dirrm share/doc/mode-info