aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-03-25 21:46:08 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-03-25 21:46:08 +0000
commitc9eddf9897381aef26424bb68d5d2e0680a46790 (patch)
tree96bd9ab73af76ca2589636064c99dd573eb4328e
parentb874aa45afda30f4268d6dddbadb3247e1cd2d7f (diff)
downloadports-c9eddf9897381aef26424bb68d5d2e0680a46790.tar.gz
ports-c9eddf9897381aef26424bb68d5d2e0680a46790.zip
It seems these ports are still required on 7.x
Feature safe: yes
Notes
Notes: svn path=/head/; revision=293820
-rw-r--r--MOVED2
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/linux-tiff/Makefile32
-rw-r--r--graphics/linux-tiff/distinfo.i3864
-rw-r--r--graphics/linux-tiff/pkg-descr7
-rw-r--r--graphics/linux-tiff/pkg-plist.i38655
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/linux-pango/Makefile36
-rw-r--r--x11-toolkits/linux-pango/distinfo.i3864
-rw-r--r--x11-toolkits/linux-pango/pkg-descr14
-rw-r--r--x11-toolkits/linux-pango/pkg-plist36
11 files changed, 190 insertions, 2 deletions
diff --git a/MOVED b/MOVED
index 962417d18523..d732123e1c78 100644
--- a/MOVED
+++ b/MOVED
@@ -3261,5 +3261,3 @@ net-p2p/fidelio||2012-03-21|Has expired: Hotline services does not exists anymor
japanese/postgresql-tcltk||2012-03-21|Has expired: Broken for months with no-one caring, superseded by http://pgtclng.sourceforge.net/
databases/postgresql-tcltk|databases/pgtcl|2012-03-21|Has expired: Broken for months with no-one caring, superseded by http://pgtclng.sourceforge.net/
devel/p5-Make-Cache||2012-03-25|Has expired: Removed from CPAN, does not work, unmaintained
-graphics/linux-tiff||2012-03-25|Has expired
-x11-toolkits/linux-pango||2012-03-25|Has expired
diff --git a/graphics/Makefile b/graphics/Makefile
index b116c844cdb4..d786a340256a 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -533,6 +533,7 @@
SUBDIR += linux-png10
SUBDIR += linux-sdl_image
SUBDIR += linux-sdl_ttf
+ SUBDIR += linux-tiff
SUBDIR += linux-ungif
SUBDIR += linux_dri
SUBDIR += linux_glide
diff --git a/graphics/linux-tiff/Makefile b/graphics/linux-tiff/Makefile
new file mode 100644
index 000000000000..1971574d20ff
--- /dev/null
+++ b/graphics/linux-tiff/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: linux-tiff
+# Date created: 2001.02.08
+# Whom: taoka@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tiff
+PORTVERSION= 3.7.1
+PORTREVISION= 2
+CATEGORIES= graphics linux
+MASTER_SITES= CRITICAL/rpm/${LINUX_RPM_ARCH}/fedora/${LINUX_DIST_VER}
+DISTNAME= libtiff-${PORTVERSION}-6.fc4.2
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= TIFF library, Linux/i386 binary
+
+FORBIDDEN= Vulnerable since 2004-10-13, http://portaudit.freebsd.org/8816bf3a-7929-11df-bcce-0018f3e2eb82.html
+EXPIRATION_DATE= 2011-10-14
+
+CONFLICTS= linux-f8-tiff-[0-9]* linux-f10-tiff-[0-9]*
+
+ONLY_FOR_ARCHS= amd64 i386
+USE_LINUX_RPM= yes
+USE_LINUX_APPS= jpeg
+LINUX_DIST_VER= 4
+USE_LDCONFIG= yes
+BRANDELF_DIRS= usr/bin
+PLIST= pkg-plist.${LINUX_RPM_ARCH}
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-tiff/distinfo.i386 b/graphics/linux-tiff/distinfo.i386
new file mode 100644
index 000000000000..5d3de67e923a
--- /dev/null
+++ b/graphics/linux-tiff/distinfo.i386
@@ -0,0 +1,4 @@
+SHA256 (rpm/i386/fedora/4/libtiff-3.7.1-6.fc4.2.i386.rpm) = 9b6b41f210c38791bf388a81d5ed9f3d44591883313cc8c58797616d835b61ed
+SIZE (rpm/i386/fedora/4/libtiff-3.7.1-6.fc4.2.i386.rpm) = 306451
+SHA256 (rpm/i386/fedora/4/libtiff-3.7.1-6.fc4.2.src.rpm) = 93820f895507487e466fbee0d1696e2091178c7aa9d61bf4115bcc1cf08d57db
+SIZE (rpm/i386/fedora/4/libtiff-3.7.1-6.fc4.2.src.rpm) = 1269849
diff --git a/graphics/linux-tiff/pkg-descr b/graphics/linux-tiff/pkg-descr
new file mode 100644
index 000000000000..a0d231cc0527
--- /dev/null
+++ b/graphics/linux-tiff/pkg-descr
@@ -0,0 +1,7 @@
+This is a Linux/i386 binary of a library for reading and writing
+images in Tagged Image File Format.
+
+See http://www.awaresystems.be/imaging/tiff.html for information
+about the format.
+
+WWW: http://www.remotesensing.org/libtiff/
diff --git a/graphics/linux-tiff/pkg-plist.i386 b/graphics/linux-tiff/pkg-plist.i386
new file mode 100644
index 000000000000..302bf427b47b
--- /dev/null
+++ b/graphics/linux-tiff/pkg-plist.i386
@@ -0,0 +1,55 @@
+usr/bin/bmp2tiff
+usr/bin/fax2ps
+usr/bin/fax2tiff
+usr/bin/gif2tiff
+usr/bin/pal2rgb
+usr/bin/ppm2tiff
+usr/bin/ras2tiff
+usr/bin/raw2tiff
+usr/bin/rgb2ycbcr
+usr/bin/thumbnail
+usr/bin/tiff2bw
+usr/bin/tiff2pdf
+usr/bin/tiff2ps
+usr/bin/tiff2rgba
+usr/bin/tiffcmp
+usr/bin/tiffcp
+usr/bin/tiffdither
+usr/bin/tiffdump
+usr/bin/tiffinfo
+usr/bin/tiffgt
+usr/bin/tiffmedian
+usr/bin/tiffset
+usr/bin/tiffsplit
+usr/lib/libtiff.so.3
+usr/lib/libtiff.so.%%PORTVERSION%%
+usr/share/doc/libtiff-%%PORTVERSION%%/COPYRIGHT
+usr/share/doc/libtiff-%%PORTVERSION%%/README
+usr/share/doc/libtiff-%%PORTVERSION%%/RELEASE-DATE
+usr/share/doc/libtiff-%%PORTVERSION%%/VERSION
+usr/share/man/man1/bmp2tiff.1.gz
+usr/share/man/man1/fax2ps.1.gz
+usr/share/man/man1/fax2tiff.1.gz
+usr/share/man/man1/gif2tiff.1.gz
+usr/share/man/man1/pal2rgb.1.gz
+usr/share/man/man1/ppm2tiff.1.gz
+usr/share/man/man1/ras2tiff.1.gz
+usr/share/man/man1/raw2tiff.1.gz
+usr/share/man/man1/rgb2ycbcr.1.gz
+usr/share/man/man1/sgi2tiff.1.gz
+usr/share/man/man1/thumbnail.1.gz
+usr/share/man/man1/tiff2bw.1.gz
+usr/share/man/man1/tiff2pdf.1.gz
+usr/share/man/man1/tiff2ps.1.gz
+usr/share/man/man1/tiff2rgba.1.gz
+usr/share/man/man1/tiffcmp.1.gz
+usr/share/man/man1/tiffcp.1.gz
+usr/share/man/man1/tiffdither.1.gz
+usr/share/man/man1/tiffdump.1.gz
+usr/share/man/man1/tiffinfo.1.gz
+usr/share/man/man1/tiffgt.1.gz
+usr/share/man/man1/tiffmedian.1.gz
+usr/share/man/man1/tiffset.1.gz
+usr/share/man/man1/tiffsplit.1.gz
+usr/share/man/man1/tiffsv.1.gz
+@dirrm usr/share/doc/libtiff-%%PORTVERSION%%
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index a1a2d99104f3..bcdb8fbe8b07 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -129,6 +129,7 @@
SUBDIR += linux-gtk
SUBDIR += linux-gtk2
SUBDIR += linux-openmotif
+ SUBDIR += linux-pango
SUBDIR += linux-qt33
SUBDIR += mesgui
SUBDIR += movingmotif
diff --git a/x11-toolkits/linux-pango/Makefile b/x11-toolkits/linux-pango/Makefile
new file mode 100644
index 000000000000..e6248ec0e43e
--- /dev/null
+++ b/x11-toolkits/linux-pango/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: linux-pango
+# Date created: 2003-07-05
+# Whom: trevor
+#
+# $FreeBSD$
+
+PORTNAME= pango
+PORTVERSION= 1.10.2
+DISTVERSIONSUFFIX= -1.gst.1.4
+PORTREVISION= 4
+CATEGORIES= x11-toolkits linux
+MASTER_SITES= http://gstreamer.freedesktop.org/pkg/%SUBDIR%/ CRITICAL/rpm
+MASTER_SITE_SUBDIR= ${LINUX_DIST}/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}/RPMS.gst010
+MASTER_SITE_SRC_SUBDIR= ${LINUX_DIST}/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}/SRPMS.gst010
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Linux pango binary
+
+FORBIDDEN= Vulnerable since 2009-05-13, http://portaudit.freebsd.org/4b172278-3f46-11de-becb-001cc0377035.html
+EXPIRATION_DATE= 2011-10-14
+
+CONFLICTS= linux-f8-pango-[0-9]* linux-f10-pango-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX_RPM= yes
+# these libraries are required by pango-querymodules
+USE_LINUX_APPS= cairo expat fontconfig xorglibs
+LINUX_DIST_VER= 4
+USE_LDCONFIG= yes
+BRANDELF_DIRS= usr/bin
+PLIST_SUB+= LIBVERSION="1001.1" PORTVERSION="${PORTVERSION}"
+
+post-install:
+ @${PREFIX}/usr/bin/pango-querymodules-32 > ${PREFIX}/etc/pango/i686-redhat-linux-gnu/pango.modules
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/linux-pango/distinfo.i386 b/x11-toolkits/linux-pango/distinfo.i386
new file mode 100644
index 000000000000..5a4616c7f39c
--- /dev/null
+++ b/x11-toolkits/linux-pango/distinfo.i386
@@ -0,0 +1,4 @@
+SHA256 (rpm/i386/fedora/4/pango-1.10.2-1.gst.1.4.i386.rpm) = 62dd4631d4409a9d98d524f2222d7c7e36e99162575a56a3a5f3609558fe9698
+SIZE (rpm/i386/fedora/4/pango-1.10.2-1.gst.1.4.i386.rpm) = 304251
+SHA256 (rpm/i386/fedora/4/pango-1.10.2-1.gst.1.4.src.rpm) = 38d100485aa5f3c8220d240c484a26a379fffea88be5b1eaedcef4480501831e
+SIZE (rpm/i386/fedora/4/pango-1.10.2-1.gst.1.4.src.rpm) = 1095844
diff --git a/x11-toolkits/linux-pango/pkg-descr b/x11-toolkits/linux-pango/pkg-descr
new file mode 100644
index 000000000000..922f2bcf8586
--- /dev/null
+++ b/x11-toolkits/linux-pango/pkg-descr
@@ -0,0 +1,14 @@
+This is a Linux/i386 binary port of Pango.
+
+from the home page:
+
+ The goal of the Pango project is to provide an open-source
+ framework for the layout and rendering of internationalized
+ text. Pango is an offshoot of the GTK+ and GNOME projects,
+ and the initial focus is operation in those environments,
+ however there is nothing fundamentally GTK+- or GNOME-specific
+ about Pango. Pango uses Unicode for all of its encoding,
+ and will eventually support output in all the world's major
+ languages.
+
+WWW: http://pango.org
diff --git a/x11-toolkits/linux-pango/pkg-plist b/x11-toolkits/linux-pango/pkg-plist
new file mode 100644
index 000000000000..751a7d4a96a6
--- /dev/null
+++ b/x11-toolkits/linux-pango/pkg-plist
@@ -0,0 +1,36 @@
+etc/pango/i686-redhat-linux-gnu/pango.modules
+etc/pango/pangox.aliases
+usr/bin/pango-querymodules-32
+usr/lib/libpango-1.0.so.0
+usr/lib/libpango-1.0.so.0.%%LIBVERSION%%
+usr/lib/libpangocairo-1.0.so.0
+usr/lib/libpangocairo-1.0.so.0.%%LIBVERSION%%
+usr/lib/libpangoft2-1.0.so.0
+usr/lib/libpangoft2-1.0.so.0.%%LIBVERSION%%
+usr/lib/libpangox-1.0.so.0
+usr/lib/libpangox-1.0.so.0.%%LIBVERSION%%
+usr/lib/libpangoxft-1.0.so.0
+usr/lib/libpangoxft-1.0.so.0.%%LIBVERSION%%
+usr/lib/pango/1.4.0/modules/pango-arabic-fc.so
+usr/lib/pango/1.4.0/modules/pango-basic-fc.so
+usr/lib/pango/1.4.0/modules/pango-basic-x.so
+usr/lib/pango/1.4.0/modules/pango-hangul-fc.so
+usr/lib/pango/1.4.0/modules/pango-hebrew-fc.so
+usr/lib/pango/1.4.0/modules/pango-indic-fc.so
+usr/lib/pango/1.4.0/modules/pango-khmer-fc.so
+usr/lib/pango/1.4.0/modules/pango-syriac-fc.so
+usr/lib/pango/1.4.0/modules/pango-thai-fc.so
+usr/lib/pango/1.4.0/modules/pango-tibetan-fc.so
+usr/share/doc/pango-%%PORTVERSION%%/AUTHORS
+usr/share/doc/pango-%%PORTVERSION%%/COPYING
+usr/share/doc/pango-%%PORTVERSION%%/ChangeLog
+usr/share/doc/pango-%%PORTVERSION%%/HELLO.utf8
+usr/share/doc/pango-%%PORTVERSION%%/README
+usr/share/doc/pango-%%PORTVERSION%%/TODO
+usr/share/man/man1/pango-querymodules.1.gz
+@dirrm etc/pango/i686-redhat-linux-gnu
+@dirrm etc/pango
+@dirrm usr/lib/pango/1.4.0/modules
+@dirrm usr/lib/pango/1.4.0
+@dirrm usr/lib/pango
+@dirrm usr/share/doc/pango-%%PORTVERSION%%