aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-24 16:04:09 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-24 16:04:09 +0000
commitdc9f53624572456b771f4e17acc5e4e21be2b8fc (patch)
tree505c6cde840b7c2a359f385bdf08c5576a2fcaf1
parent58ba93d1acc40262ab1fcbe6c5cd0aad373063c0 (diff)
downloadports-dc9f53624572456b771f4e17acc5e4e21be2b8fc.tar.gz
ports-dc9f53624572456b771f4e17acc5e4e21be2b8fc.zip
- Update to 0.84
- Pass maintainership to submitter PR: 165947 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=293746
-rw-r--r--sysutils/mpiexec/Makefile4
-rw-r--r--sysutils/mpiexec/distinfo4
-rw-r--r--sysutils/mpiexec/files/patch-psm.c23
3 files changed, 27 insertions, 4 deletions
diff --git a/sysutils/mpiexec/Makefile b/sysutils/mpiexec/Makefile
index 84a90a02d13a..8f91f72d5d36 100644
--- a/sysutils/mpiexec/Makefile
+++ b/sysutils/mpiexec/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= mpiexec
-PORTVERSION= 0.83
+PORTVERSION= 0.84
CATEGORIES= sysutils parallel
MASTER_SITES= http://www.osc.edu/~djohnson/mpiexec/
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= 5u623l20@gmail.com
COMMENT= A tool to run a parallel job from within a PBS environment
LIB_DEPENDS= torque.2:${PORTSDIR}/sysutils/torque
diff --git a/sysutils/mpiexec/distinfo b/sysutils/mpiexec/distinfo
index 385ea2e161d2..1c38a1ce879e 100644
--- a/sysutils/mpiexec/distinfo
+++ b/sysutils/mpiexec/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mpiexec-0.83.tgz) = 4485c6f5ced0889ea7fb88b49af001904348dee24a23cd85dd8402f606e2128d
-SIZE (mpiexec-0.83.tgz) = 207619
+SHA256 (mpiexec-0.84.tgz) = 119619c035453718dc98c2eb72799ad1fa9a8a240336bc0481d2063cb5a88fc3
+SIZE (mpiexec-0.84.tgz) = 229323
diff --git a/sysutils/mpiexec/files/patch-psm.c b/sysutils/mpiexec/files/patch-psm.c
new file mode 100644
index 000000000000..22b152967860
--- /dev/null
+++ b/sysutils/mpiexec/files/patch-psm.c
@@ -0,0 +1,23 @@
+--- psm.c.orig 2012-03-12 02:52:24.120253238 +0600
++++ psm.c 2012-03-12 02:53:17.264235224 +0600
+@@ -209,8 +209,7 @@
+ #include <netdb.h>
+ #include <sys/socket.h>
+ #include <sys/time.h>
+-#include <endian.h>
+-#include <byteswap.h>
++#include <sys/endian.h>
+ #include "mpiexec.h"
+
+ #ifdef HAVE_POLL
+@@ -221,8 +220,8 @@
+ # define ntohu64(x) (x)
+ # define htonu64(x) (x)
+ #elif __BYTE_ORDER == __LITTLE_ENDIAN
+-# define ntohu64(x) __bswap_64(x)
+-# define htonu64(x) __bswap_64(x)
++# define ntohu64(x) bswap64(x)
++# define htonu64(x) bswap64(x)
+ #endif
+
+ #define EPID_INFO_GLOBAL 2