aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2007-05-26 20:23:12 +0000
committerKris Kennaway <kris@FreeBSD.org>2007-05-26 20:23:12 +0000
commitde1ccba75678e5ce47f59a40b2d2fcd61b3fe112 (patch)
tree68ebf2598e543180939a9b3b8c99d60c9c50de9d
parent90d066226dd1c911b582d427e238586ef204ee7f (diff)
downloadports-de1ccba75678e5ce47f59a40b2d2fcd61b3fe112.tar.gz
ports-de1ccba75678e5ce47f59a40b2d2fcd61b3fe112.zip
BROKEN with gcc 4.2
Notes
Notes: svn path=/head/; revision=191935
-rw-r--r--cad/alliance/Makefile4
-rw-r--r--comms/aldo/Makefile4
-rw-r--r--games/adonthell/Makefile4
-rw-r--r--graphics/amanith/Makefile4
-rw-r--r--lang/afnix/Makefile4
-rw-r--r--net-mgmt/ap-utils/Makefile8
-rw-r--r--net-p2p/amule1/Makefile4
-rw-r--r--sysutils/44bsd-more/Makefile8
8 files changed, 38 insertions, 2 deletions
diff --git a/cad/alliance/Makefile b/cad/alliance/Makefile
index d349a970d2a6..14e8a967f9bd 100644
--- a/cad/alliance/Makefile
+++ b/cad/alliance/Makefile
@@ -36,6 +36,10 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
ALLIANCE_TOP= ${PREFIX}/alliance
SRCDIRLIST!= ${CAT} ${FILESDIR}/srcdirs.list
CFLAGS+= ${SRCDIRLIST:S,^,-I${WRKSRC}/,}
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index 7c95bc4582b2..abd0208f13ae 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -29,6 +29,10 @@ MAN1= aldo.1
BROKEN= "Doesn't build on FreeBSD < 5.x"
.endif
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/aldo ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/aldo.1 ${MANPREFIX}/man/man1
diff --git a/games/adonthell/Makefile b/games/adonthell/Makefile
index 17f1665d1035..314a9a738b49 100644
--- a/games/adonthell/Makefile
+++ b/games/adonthell/Makefile
@@ -32,6 +32,10 @@ CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
.if ${ARCH} == "sparc64"
BROKEN= Does not build on sparc64
.endif
diff --git a/graphics/amanith/Makefile b/graphics/amanith/Makefile
index cfbf5bb9c91f..b17a40ac2286 100644
--- a/graphics/amanith/Makefile
+++ b/graphics/amanith/Makefile
@@ -44,6 +44,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
IGNORE= does not build on FreeBSD 4.x
.endif
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -i "" -e 's|3rdpart||' ${WRKSRC}/amanith.pro
diff --git a/lang/afnix/Makefile b/lang/afnix/Makefile
index 80c6bf2d64f8..1571c53fb8b6 100644
--- a/lang/afnix/Makefile
+++ b/lang/afnix/Makefile
@@ -39,6 +39,10 @@ MAN7= eul::afnix.7 vol-0::afnix.7 vol-1::afnix.7 vol-2::afnix.7
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-extract:
@cd ${WRKSRC}/cnf/mak && ${CP} -f afnix-gcc-3.mak afnix-freebsd.mak
diff --git a/net-mgmt/ap-utils/Makefile b/net-mgmt/ap-utils/Makefile
index d0f05dab366a..adaa5967ce13 100644
--- a/net-mgmt/ap-utils/Makefile
+++ b/net-mgmt/ap-utils/Makefile
@@ -30,6 +30,12 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|_nl_domain_bindings|libintl_nl_domain_bindings|' ${WRKSRC}/configure
@@ -40,4 +46,4 @@ post-install:
${INSTALL_DATA} FAQ Ovislink-HOWTO.html HARDWARE-NOTES README.ap-gl ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-p2p/amule1/Makefile b/net-p2p/amule1/Makefile
index a110fa34edc3..051fa2a68021 100644
--- a/net-p2p/amule1/Makefile
+++ b/net-p2p/amule1/Makefile
@@ -48,6 +48,10 @@ CURL_CONFIG?= ${LOCALBASE}/bin/curl-config
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
# Configure options
.if !defined(WITHOUT_OPTIMIZE)
CONFIGURE_ARGS+= --enable-optimise
diff --git a/sysutils/44bsd-more/Makefile b/sysutils/44bsd-more/Makefile
index b88b0db3fe9b..00cce5e51963 100644
--- a/sysutils/44bsd-more/Makefile
+++ b/sysutils/44bsd-more/Makefile
@@ -21,6 +21,12 @@ MAN1= 44bsd-more.1
RELDATE= 20000521
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 700042
+BROKEN= Broken with gcc 4.2
+.endif
+
post-extract:
-cd ${WRKSRC} && co RCS/*,v
@@ -45,4 +51,4 @@ tarup:
cd ${WRKSRC} && tar cyf /tmp/${DISTFILES} RCS
scp /tmp/${DISTFILES} freefall:public_html/dists
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>