aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-19 22:12:09 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-19 22:12:09 +0000
commited2da8c8846922e3e185b8ac5cecad1a2bb5a382 (patch)
tree8915817b7d924c84eee8f95f921716760fae6410
parent754be917f66624b846e433563e67fafd16190dea (diff)
downloadports-ed2da8c8846922e3e185b8ac5cecad1a2bb5a382.tar.gz
ports-ed2da8c8846922e3e185b8ac5cecad1a2bb5a382.zip
Comment extension_dir in sample php.ini's, since many copy the sample
configuration file blindly and then complain about wrong directory. PHP has the correct path compiled in statically.
Notes
Notes: svn path=/head/; revision=114252
-rw-r--r--lang/php4/Makefile1
-rw-r--r--lang/php5/Makefile1
-rw-r--r--lang/php53/Makefile1
3 files changed, 3 insertions, 0 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index ec0728682ea9..f66f3cce3276 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -165,6 +165,7 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PHP_SAPI} == "full"
pre-configure:
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 9798ba3f6972..a9b6c5d4c999 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -170,6 +170,7 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PHP_SAPI} == "full"
pre-configure:
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 9798ba3f6972..a9b6c5d4c999 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -170,6 +170,7 @@ PHP_PORT= ${.CURDIR:S|^${_PORTSDIR}||:S|^/||}
post-patch:
@${TOUCH} ${WRKSRC}/ext/php_config.h
+ @${REINPLACE_CMD} "s|^\(extension_dir\)|; \1|" ${WRKSRC}/php.ini-*
.if ${PHP_SAPI} == "full"
pre-configure: