aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2000-02-22 20:26:58 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2000-02-22 20:26:58 +0000
commitef14fd654f1adea04d0c85a6d9e85589efe61409 (patch)
tree9427b764954dfea38ca0e99e1dc61bdb56785c5e
parente0e114ae65e97cf74305e717ce73c1dbb39b1905 (diff)
downloadports-ef14fd654f1adea04d0c85a6d9e85589efe61409.tar.gz
ports-ef14fd654f1adea04d0c85a6d9e85589efe61409.zip
Initial import of malsync:
Sync to Mobile Application Link (MAL) compliant servers
Notes
Notes: svn path=/head/; revision=26156
-rw-r--r--palm/malsync/Makefile26
-rw-r--r--palm/malsync/distinfo1
-rw-r--r--palm/malsync/files/patch-aa50
-rw-r--r--palm/malsync/pkg-comment1
-rw-r--r--palm/malsync/pkg-descr15
-rw-r--r--palm/malsync/pkg-plist1
6 files changed, 94 insertions, 0 deletions
diff --git a/palm/malsync/Makefile b/palm/malsync/Makefile
new file mode 100644
index 000000000000..5b9989879e63
--- /dev/null
+++ b/palm/malsync/Makefile
@@ -0,0 +1,26 @@
+# ports collection makefile for: malsync
+# Version required: 1.8
+# Date created: Tue Feb 22 00:06:07 CET 2000
+# Whom: Dirk Froemberg <dirk@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= malsync_src_1_8
+PKGNAME= malsync-1.8
+CATEGORIES= palm
+MASTER_SITES= http://www.tomw.org/ \
+ http://people.FreeBSD.org/~dirk/ports/distfiles/
+
+MAINTAINER= dirk@FreeBSD.org
+
+LIB_DEPENDS= pisock.3:${PORTSDIR}/palm/pilot-link
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/malsync_src/mal/client/unix
+FETCH_BEFORE_ARGS= -b
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/malsync ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/palm/malsync/distinfo b/palm/malsync/distinfo
new file mode 100644
index 000000000000..d8d14bfcd1ab
--- /dev/null
+++ b/palm/malsync/distinfo
@@ -0,0 +1 @@
+MD5 (malsync_src_1_8.tar.gz) = d43dcc97b4b7288a2e36f9f08e44f00a
diff --git a/palm/malsync/files/patch-aa b/palm/malsync/files/patch-aa
new file mode 100644
index 000000000000..ae54dda55bbd
--- /dev/null
+++ b/palm/malsync/files/patch-aa
@@ -0,0 +1,50 @@
+--- Makefile.orig Wed Sep 22 01:48:40 1999
++++ Makefile Tue Feb 22 21:13:18 2000
+@@ -1,4 +1,3 @@
+-CC = gcc
+ TARGET = malsync
+
+ PLAT := $(shell uname)
+@@ -6,9 +5,14 @@
+
+
+ TREETOP = ../../..
+-PILOT_LINK_DIR = $(TREETOP)/vendor/pilot/pilot-link.0.9.3
++PILOT_LINK_DIR = $(PREFIX)/pilot
+
+ DEFINES = -DMALSYNC
++
++ifeq ($(PLAT),FreeBSD)
++LINKFLAGS = -Wl,--rpath -Wl,$(PILOT_LINK_DIR)/lib
++endif
++
+ ifeq ($(PLAT),Linux)
+ DEFINES += -DHAVE_GETOPTLONG
+ LINKFLAGS = -rdynamic
+@@ -21,7 +25,7 @@
+
+ endif
+
+-CFLAGS = -Wall -g $(DEFINES) -I$(TREETOP)/mal/common \
++CFLAGS += $(DEFINES) -I$(TREETOP)/mal/common \
+ -I$(TREETOP)/mal/client/common -I$(PILOT_LINK_DIR)/include -I.
+
+
+@@ -63,14 +67,13 @@
+ OBJS = $(SRC:.c=.o)
+
+
++all: $(TARGET)
++
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $(OBJS) -L${PILOT_LINK_DIR}/libsock -lpisock $(LINKLIBS)
++ $(CC) $(CFLAGS) -o $@ $(OBJS) -L${PILOT_LINK_DIR}/lib -lpisock $(LINKLIBS) $(LINKFLAGS)
+
+ clean:
+ rm -f $(OBJS) $(TARGET)
+-
+-.c.o:
+- gcc $(CFLAGS) -c -o $@ $<
+
+
+
diff --git a/palm/malsync/pkg-comment b/palm/malsync/pkg-comment
new file mode 100644
index 000000000000..93acc4d6973f
--- /dev/null
+++ b/palm/malsync/pkg-comment
@@ -0,0 +1 @@
+Sync to Mobile Application Link (MAL) compliant servers
diff --git a/palm/malsync/pkg-descr b/palm/malsync/pkg-descr
new file mode 100644
index 000000000000..3f06ef5bbc46
--- /dev/null
+++ b/palm/malsync/pkg-descr
@@ -0,0 +1,15 @@
+This is a bare bones utility to enable people who have Palm OS
+devices to sync to Mobile Application Link (MAL) compliant servers.
+AvantGo (www.avantgo.com) and Puma Technologies (www.pumatech.com)
+are the first two companies committing to producing servers which speak
+this protocol. This utility will allow a user to sync with multiple servers,
+simultaneously or separately. The AvantGo.com service (www.avantgo.com)
+is the first such server.
+
+There is currently no way to set server parameters on the desktop; you
+need to use the MobileLink application on the device.
+
+MALSync only operates from the command line. If you want to build it
+into some Unix-based, HotSync-like GUI, more power to you.
+
+WWW: http://www.tomw.org/malsync.html
diff --git a/palm/malsync/pkg-plist b/palm/malsync/pkg-plist
new file mode 100644
index 000000000000..6543e060ff99
--- /dev/null
+++ b/palm/malsync/pkg-plist
@@ -0,0 +1 @@
+bin/malsync