aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-04-13 13:47:23 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-04-13 13:47:23 +0000
commitfe6182e2fa50cb2e14e806b30cc55c71fb9cf780 (patch)
tree0951b3f2b412a92d1599954c49e3c2557a1b7967
parent6ea7b2827071ada686fcd188b0f9554152f6ca04 (diff)
downloadports-fe6182e2fa50cb2e14e806b30cc55c71fb9cf780.tar.gz
ports-fe6182e2fa50cb2e14e806b30cc55c71fb9cf780.zip
- Added patch files to fix some of the common compiler errors after the
PHP 5.3.2 upgrade, but still had to mark as BROKEN because of other less-obvious compiler errors. Will revisit after the other PHP modules are fixed. Reported by: pointyhat Approved by: portmgr (itetcu, erwin - blanket)
Notes
Notes: svn path=/head/; revision=252641
-rw-r--r--devel/php-dbg2/Makefile2
-rw-r--r--devel/php-dbg2/files/patch-dbg.c20
-rw-r--r--devel/php-dbg2/files/patch-dbg_cmd.c20
3 files changed, 42 insertions, 0 deletions
diff --git a/devel/php-dbg2/Makefile b/devel/php-dbg2/Makefile
index 7fe467d4e7fa..b396adc85d1a 100644
--- a/devel/php-dbg2/Makefile
+++ b/devel/php-dbg2/Makefile
@@ -23,6 +23,8 @@ CONFIGURE_ARGS= --enable-dbg=shared --with-dbg-profiler \
--prefix=${PREFIX}/lib/php/${PHP_EXT_DIR}
PKGMESSAGE= pkg-message
+BROKEN= does not compile with PHP 5.3.2
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/devel/php-dbg2/files/patch-dbg.c b/devel/php-dbg2/files/patch-dbg.c
new file mode 100644
index 000000000000..628ca6e75826
--- /dev/null
+++ b/devel/php-dbg2/files/patch-dbg.c
@@ -0,0 +1,20 @@
+--- ./dbg.c.orig 2010-04-13 09:40:15.000000000 -0400
++++ ./dbg.c 2010-04-13 09:41:12.000000000 -0400
+@@ -563,7 +563,7 @@
+ }
+ DBG(is_extension_activated) = 1;
+ if (DBG(cfgprm_enabled)) {
+- CG(extended_info) = 1;
++ CG(compiler_options) |= ZEND_COMPILE_EXTENDED_INFO;
+ }
+ }
+
+@@ -571,7 +571,7 @@
+ TSRMLS_FETCH1(C);
+
+ DBG_TRACE(("dbg_deactivate Zend extension\n"));
+- CG(extended_info) = 0;
++ CG(compiler_options) = 0;
+
+ /* TS_ALLOC_DTOR_CALL(DBG); */
+ }
diff --git a/devel/php-dbg2/files/patch-dbg_cmd.c b/devel/php-dbg2/files/patch-dbg_cmd.c
new file mode 100644
index 000000000000..20571784315b
--- /dev/null
+++ b/devel/php-dbg2/files/patch-dbg_cmd.c
@@ -0,0 +1,20 @@
+--- ./dbg_cmd.c.orig 2010-04-13 09:41:26.000000000 -0400
++++ ./dbg_cmd.c 2010-04-13 09:41:53.000000000 -0400
+@@ -601,7 +601,7 @@
+
+ memset(&data, 0, sizeof(data));
+ Z_TYPE_P(&data) = IS_STRING;
+- data.refcount++;
++ Z_ADDREF(data);
+
+ if (DBG(eval_error)) {
+ efree(DBG(eval_error));
+@@ -627,7 +627,7 @@
+
+ memset(&buf, 0, sizeof(buf));
+ Z_TYPE_P(&buf) = IS_STRING;
+- buf.refcount++;
++ Z_ADDREF(buf);
+
+ if (req->istr!=0 && (!dbg_packet_findstring(inpack, req->istr, &str, &sz) || sz<=0)) return 0;
+ if (str && strlen(str)==0) str = NULL;