aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2002-11-01 02:40:58 +0000
committerJames E. Housley <jeh@FreeBSD.org>2002-11-01 02:40:58 +0000
commit01b14fb7efbe6d3a1711b7c37fb4fc0a2049d0bb (patch)
tree37c479d139b65c620a5bd2fa2cc8d70ac5813fa1
parent0ee4b9379837839e53dd473d203450991f092c9a (diff)
downloadports-01b14fb7efbe6d3a1711b7c37fb4fc0a2049d0bb.tar.gz
ports-01b14fb7efbe6d3a1711b7c37fb4fc0a2049d0bb.zip
Update to the latest version of gdb, used by RTEMS -- 5.2
Notes
Notes: svn path=/head/; revision=69233
-rw-r--r--devel/arm-rtems-gdb/Makefile3
-rw-r--r--devel/i386-rtems-gdb/Makefile12
-rw-r--r--devel/i386-rtems-gdb/distinfo6
-rw-r--r--devel/i960-rtems-gdb/Makefile3
-rw-r--r--devel/mips-rtems-gdb/Makefile16
-rw-r--r--devel/powerpc-rtems-gdb/Makefile3
-rw-r--r--devel/sh-rtems-gdb/Makefile3
-rw-r--r--devel/sparc-rtems-gdb/Makefile3
8 files changed, 42 insertions, 7 deletions
diff --git a/devel/arm-rtems-gdb/Makefile b/devel/arm-rtems-gdb/Makefile
index c0451ab8d150..834bfa2f55fd 100644
--- a/devel/arm-rtems-gdb/Makefile
+++ b/devel/arm-rtems-gdb/Makefile
@@ -10,4 +10,7 @@ PORTNAME= gdb
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= arm-rtems
+
+MAN1= ${LCLTARGET}-run.1
+
.include "${.CURDIR}/../i386-rtems-gdb/Makefile"
diff --git a/devel/i386-rtems-gdb/Makefile b/devel/i386-rtems-gdb/Makefile
index beda79c913f7..cad976a5c4da 100644
--- a/devel/i386-rtems-gdb/Makefile
+++ b/devel/i386-rtems-gdb/Makefile
@@ -6,21 +6,23 @@
#
PORTNAME= gdb
-PORTVERSION= 5.0
-PORTREVISION= 3
+PORTVERSION= 5.2
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gdb
MAINTAINER= jeh@FreeBSD.org
-PATCHFILES= ${GDBNAME}-rtems-20010314.diff
+PATCHFILES= ${GDBNAME}-rtems-base-20020612.diff \
+ ${GDBNAME}-rtems-cg-20020612.diff \
+ ${GDBNAME}-rtems-rdbg-20020612.diff
PATCH_SITES= ftp://ftp.oarcorp.com/pub/rtems/snapshots/c_tools/source/ \
http://rtems.thehousleys.net/
LCLTARGET?= i386-rtems
-GDBNAME= gdb-5.0
+GDBNAME= gdb-5.2
MASTERDIR= ${.CURDIR}/../i386-rtems-gdb
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
@@ -41,7 +43,7 @@ CONFIGURE_SCRIPT?= ../${GDBNAME}/configure
PATCH_DIST_STRIP?= -p1
-MAN1= ${LCLTARGET}-gdb.1
+MAN1+= ${LCLTARGET}-gdb.1
pre-configure:
@(cd ${WRKDIR} ; ${MKDIR} build-${LCLTARGET})
diff --git a/devel/i386-rtems-gdb/distinfo b/devel/i386-rtems-gdb/distinfo
index ceb9abd78c35..61f508de6f78 100644
--- a/devel/i386-rtems-gdb/distinfo
+++ b/devel/i386-rtems-gdb/distinfo
@@ -1,2 +1,4 @@
-MD5 (gdb-5.0.tar.gz) = 9511b69b6b5a3b38c62ad207b3c94673
-MD5 (gdb-5.0-rtems-20010314.diff) = 97941a78d16763bf401e537062f90dec
+MD5 (gdb-5.2.tar.gz) = afb7d18f72be812ef405f6b271a36e03
+MD5 (gdb-5.2-rtems-base-20020612.diff) = d328e2959b8c83add5e2a3ca60582b03
+MD5 (gdb-5.2-rtems-cg-20020612.diff) = 44f82adae65e657458fde1280a6ac2c9
+MD5 (gdb-5.2-rtems-rdbg-20020612.diff) = 1fffe3010d9e33186497238efa9c3060
diff --git a/devel/i960-rtems-gdb/Makefile b/devel/i960-rtems-gdb/Makefile
index f73a49f89cf7..ae0c2db336d2 100644
--- a/devel/i960-rtems-gdb/Makefile
+++ b/devel/i960-rtems-gdb/Makefile
@@ -10,4 +10,7 @@ PORTNAME= gdb
MAINTAINER= jeh@FreeBSD.org
LCLTARGET= i960-rtems
+
+MAN1= ${LCLTARGET}-run.1
+
.include "${.CURDIR}/../i386-rtems-gdb/Makefile"
diff --git a/devel/mips-rtems-gdb/Makefile b/devel/mips-rtems-gdb/Makefile
new file mode 100644
index 000000000000..c3f6362a05e8
--- /dev/null
+++ b/devel/mips-rtems-gdb/Makefile
@@ -0,0 +1,16 @@
+# New ports collection makefile for: mips-rtems-gdb
+# Date created: 31 October 2002
+# Whom: James Housley <jeh@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdb
+
+MAINTAINER= jeh@FreeBSD.org
+
+LCLTARGET= mips-rtems
+
+MAN1= ${LCLTARGET}-run.1
+
+.include "${.CURDIR}/../i386-rtems-gdb/Makefile"
diff --git a/devel/powerpc-rtems-gdb/Makefile b/devel/powerpc-rtems-gdb/Makefile
index 387dd5cadb37..f50883f50287 100644
--- a/devel/powerpc-rtems-gdb/Makefile
+++ b/devel/powerpc-rtems-gdb/Makefile
@@ -12,4 +12,7 @@ MAINTAINER= jeh@FreeBSD.org
LCLTARGET= powerpc-rtems
CONFIGURE_ARGS= --verbose --enable-sim --enable-sim-powerpc \
--enable-sim-timebase --enable-sim-hardware
+
+BROKEN= "Errors on compile"
+
.include "${.CURDIR}/../i386-rtems-gdb/Makefile"
diff --git a/devel/sh-rtems-gdb/Makefile b/devel/sh-rtems-gdb/Makefile
index f4796a25375f..abbffa0ccc67 100644
--- a/devel/sh-rtems-gdb/Makefile
+++ b/devel/sh-rtems-gdb/Makefile
@@ -11,4 +11,7 @@ MAINTAINER= jeh@FreeBSD.org
LCLTARGET= sh-rtems
CONFIGURE_ARGS= --verbose --enable-sim
+
+MAN1= ${LCLTARGET}-run.1
+
.include "${.CURDIR}/../i386-rtems-gdb/Makefile"
diff --git a/devel/sparc-rtems-gdb/Makefile b/devel/sparc-rtems-gdb/Makefile
index 4752cad17dfd..b719c6f1b662 100644
--- a/devel/sparc-rtems-gdb/Makefile
+++ b/devel/sparc-rtems-gdb/Makefile
@@ -11,4 +11,7 @@ MAINTAINER= jeh@FreeBSD.org
LCLTARGET= sparc-rtems
CONFIGURE_ARGS+= --verbose --enable-sim
+
+MAN1= ${LCLTARGET}-run.1
+
.include "${.CURDIR}/../i386-rtems-gdb/Makefile"