aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-20 09:37:21 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-20 09:37:21 +0000
commit026e7e59d0ed7d0547f4bbfeb78ec2d7314e4b7e (patch)
treee15da3a9d272dc778a61c4284411b8e8825bce6d
parentdad0d0873a3d4f82a21a868dc5cb50e86c14565b (diff)
downloadports-026e7e59d0ed7d0547f4bbfeb78ec2d7314e4b7e.tar.gz
ports-026e7e59d0ed7d0547f4bbfeb78ec2d7314e4b7e.zip
- Remove USE_GETOPT_LONG which is a no-op since March 200
Notes
Notes: svn path=/head/; revision=209418
-rw-r--r--databases/dbview/Makefile2
-rw-r--r--databases/mysqlard/Makefile1
-rw-r--r--databases/postgresql73-server/Makefile8
-rw-r--r--databases/postgresql74-server/Makefile8
-rw-r--r--databases/postgresql80-server/Makefile8
-rw-r--r--databases/postgresql81-server/Makefile8
-rw-r--r--databases/postgresql82-server/Makefile8
-rw-r--r--databases/postgresql83-server/Makefile8
-rw-r--r--databases/postgresql84-server/Makefile8
-rw-r--r--databases/postgresql90-server/Makefile8
-rw-r--r--databases/postgresql91-server/Makefile8
-rw-r--r--databases/postgresql92-server/Makefile8
-rw-r--r--databases/pxtools/Makefile1
-rw-r--r--databases/wmjsql/Makefile1
-rw-r--r--deskutils/ljclive/Makefile1
-rw-r--r--deskutils/mdh/Makefile1
-rw-r--r--deskutils/wmpinboard/Makefile1
-rw-r--r--devel/cvsd/Makefile1
-rw-r--r--devel/cvsnt/Makefile1
-rw-r--r--devel/eboxy/Makefile1
-rw-r--r--devel/ecore-file/Makefile1
-rw-r--r--devel/ecore-ipc/Makefile1
-rw-r--r--devel/ecore-job/Makefile1
-rw-r--r--devel/ecore-main/Makefile1
-rw-r--r--devel/fastdep/Makefile1
-rw-r--r--devel/gcvs/Makefile1
-rw-r--r--devel/glademm/Makefile1
-rw-r--r--devel/hcs12mem/Makefile1
-rw-r--r--devel/id-utils/Makefile1
-rw-r--r--devel/idutils/Makefile1
-rw-r--r--devel/jclassinfo/Makefile1
-rw-r--r--devel/kimwitu++/Makefile1
-rw-r--r--devel/libytnef/Makefile1
-rw-r--r--devel/pcsc-lite/Makefile1
-rw-r--r--devel/picprog/Makefile1
-rw-r--r--devel/rlwrap/Makefile1
-rw-r--r--dns/dnsflood/Makefile2
-rw-r--r--dns/dnsmasq/Makefile1
-rw-r--r--dns/drill/Makefile1
-rw-r--r--dns/libidn/Makefile1
40 files changed, 0 insertions, 112 deletions
diff --git a/databases/dbview/Makefile b/databases/dbview/Makefile
index aff34ccb9e18..cc61d6c82b6a 100644
--- a/databases/dbview/Makefile
+++ b/databases/dbview/Makefile
@@ -15,8 +15,6 @@ MASTER_SITE_SUBDIR= apps/database/proprietary
MAINTAINER= ports@FreeBSD.org
COMMENT= View dBase III files
-USE_GETOPT_LONG= yes
-
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= dbview.1
diff --git a/databases/mysqlard/Makefile b/databases/mysqlard/Makefile
index 14131a51b8ae..0fd3cec43a64 100644
--- a/databases/mysqlard/Makefile
+++ b/databases/mysqlard/Makefile
@@ -17,7 +17,6 @@ BUILD_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool
RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_APACHE= 1.3+
-USE_GETOPT_LONG=yes
USE_MYSQL= yes
MYSQLARD_DIR?= ${PREFIX}/www/mysqlard
diff --git a/databases/postgresql73-server/Makefile b/databases/postgresql73-server/Makefile
index 222d6a4a6df0..c93dfdb61267 100644
--- a/databases/postgresql73-server/Makefile
+++ b/databases/postgresql73-server/Makefile
@@ -76,10 +76,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
# Note: server only options are no-ops for the client
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -94,10 +90,6 @@ OPTIONS+= DEBUG "Builds with debugging symbols" off
CONFIGURE_ARGS+=--with-pam
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls --with-includes=${LOCALBASE}/include
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql74-server/Makefile b/databases/postgresql74-server/Makefile
index 43a6fdb71ebd..fa6f04f42387 100644
--- a/databases/postgresql74-server/Makefile
+++ b/databases/postgresql74-server/Makefile
@@ -76,10 +76,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
# Note: server only options are no-ops for the client
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -103,10 +99,6 @@ USE_BISON= build
CONFIGURE_ARGS+=--with-pam
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls --with-includes=${LOCALBASE}/include
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql80-server/Makefile b/databases/postgresql80-server/Makefile
index 2ade864a8007..9415b37fc421 100644
--- a/databases/postgresql80-server/Makefile
+++ b/databases/postgresql80-server/Makefile
@@ -76,10 +76,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
OPTIONS+= HEIMDAL_KRB5 "Builds with Heimdal kerberos support" off
@@ -124,10 +120,6 @@ CONFIGURE_ARGS+=--with-pam
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql81-server/Makefile b/databases/postgresql81-server/Makefile
index 0fca314ade12..070417d80ced 100644
--- a/databases/postgresql81-server/Makefile
+++ b/databases/postgresql81-server/Makefile
@@ -77,10 +77,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
OPTIONS+= HEIMDAL_KRB5 "Builds with Heimdal kerberos support" off
@@ -125,10 +121,6 @@ CONFIGURE_ARGS+=--with-pam
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql82-server/Makefile b/databases/postgresql82-server/Makefile
index 5b4fc72a06f3..0e03fa24bd94 100644
--- a/databases/postgresql82-server/Makefile
+++ b/databases/postgresql82-server/Makefile
@@ -81,10 +81,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -124,10 +120,6 @@ USE_OPENLDAP= YES
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql83-server/Makefile b/databases/postgresql83-server/Makefile
index bea34fea6ef4..99c7cdab477b 100644
--- a/databases/postgresql83-server/Makefile
+++ b/databases/postgresql83-server/Makefile
@@ -87,10 +87,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -142,10 +138,6 @@ PLIST_SUB+= TZDATA="@comment "
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql84-server/Makefile b/databases/postgresql84-server/Makefile
index bea34fea6ef4..99c7cdab477b 100644
--- a/databases/postgresql84-server/Makefile
+++ b/databases/postgresql84-server/Makefile
@@ -87,10 +87,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -142,10 +138,6 @@ PLIST_SUB+= TZDATA="@comment "
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql90-server/Makefile b/databases/postgresql90-server/Makefile
index bea34fea6ef4..99c7cdab477b 100644
--- a/databases/postgresql90-server/Makefile
+++ b/databases/postgresql90-server/Makefile
@@ -87,10 +87,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -142,10 +138,6 @@ PLIST_SUB+= TZDATA="@comment "
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql91-server/Makefile b/databases/postgresql91-server/Makefile
index bea34fea6ef4..99c7cdab477b 100644
--- a/databases/postgresql91-server/Makefile
+++ b/databases/postgresql91-server/Makefile
@@ -87,10 +87,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -142,10 +138,6 @@ PLIST_SUB+= TZDATA="@comment "
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
diff --git a/databases/postgresql92-server/Makefile b/databases/postgresql92-server/Makefile
index bea34fea6ef4..99c7cdab477b 100644
--- a/databases/postgresql92-server/Makefile
+++ b/databases/postgresql92-server/Makefile
@@ -87,10 +87,6 @@ CONFIGURE_ARGS+=--with-openssl
.include <bsd.port.pre.mk>
.if !defined(SLAVE_ONLY)
-# gnugetopt will always be used if already installed
-. if ( ${OSVERSION} < 500041 ) && !exists(${LOCALBASE}/include/getopt.h)
-OPTIONS+= GNUGETOPT "Use GNU getopt" on
-. endif
OPTIONS+= PAM "Build with PAM support (server only)" off
OPTIONS+= LDAP "Build with LDAP authentication support" off
OPTIONS+= MIT_KRB5 "Build with MIT's kerberos support" off
@@ -142,10 +138,6 @@ PLIST_SUB+= TZDATA="@comment "
CONFIGURE_ARGS+=--enable-integer-datetimes
. endif
-. if !defined(WITHOUT_GNUGETOPT) || exists(${LOCALBASE}/include/getopt.h)
-USE_GETOPT_LONG=yes
-. endif
-
. if !(defined(WITHOUT_GETTEXT) || defined(WITHOUT_NLS))
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= GETTEXT=""
diff --git a/databases/pxtools/Makefile b/databases/pxtools/Makefile
index 44df7f3ab8de..50b1e650f296 100644
--- a/databases/pxtools/Makefile
+++ b/databases/pxtools/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= http://jan.kneschke.de/assets/2007/2/16/
MAINTAINER= ports@FreeBSD.org
COMMENT= Collection of tools to work with Paradox databases
-USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
USE_GETTEXT= yes
CPPFLAGS= -I${LOCALBASE}/include
diff --git a/databases/wmjsql/Makefile b/databases/wmjsql/Makefile
index a9526fcb4aaa..90d052542118 100644
--- a/databases/wmjsql/Makefile
+++ b/databases/wmjsql/Makefile
@@ -18,7 +18,6 @@ COMMENT= MySQL server status displaying dockapp
USE_MYSQL= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GETOPT_LONG= yes
USE_XPM= yes
ALL_TARGET= clean all
diff --git a/deskutils/ljclive/Makefile b/deskutils/ljclive/Makefile
index 78535dbaee57..ba0145e4e320 100644
--- a/deskutils/ljclive/Makefile
+++ b/deskutils/ljclive/Makefile
@@ -17,7 +17,6 @@ COMMENT= A command line client for posting LiveJournal entries
MAN1= clive.1
GNU_CONFIGURE= yes
-USE_GETOPT_LONG=yes
CONFLICTS= py*-clive-[0-9]*
diff --git a/deskutils/mdh/Makefile b/deskutils/mdh/Makefile
index 5649b1a0da4e..232a7aae59d3 100644
--- a/deskutils/mdh/Makefile
+++ b/deskutils/mdh/Makefile
@@ -17,7 +17,6 @@ COMMENT= GTK2-based toolbar, like a smaller GNOME panel
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnometarget gtk20
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/deskutils/wmpinboard/Makefile b/deskutils/wmpinboard/Makefile
index 3beb6d68a8d5..2cea7a3e2115 100644
--- a/deskutils/wmpinboard/Makefile
+++ b/deskutils/wmpinboard/Makefile
@@ -18,7 +18,6 @@ COMMENT= Post-it notes for the WindowMaker dock or AfterStep Wharf
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
USE_XPM= yes
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/devel/cvsd/Makefile b/devel/cvsd/Makefile
index 1687343ddd1a..15205e45e6a7 100644
--- a/devel/cvsd/Makefile
+++ b/devel/cvsd/Makefile
@@ -17,7 +17,6 @@ COMMENT= CVS pserver daemon
EXTRA_PATCHES= ${FILESDIR}/extra-cvsd-buildroot.in
USE_PERL5= yes
-USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/devel/cvsnt/Makefile b/devel/cvsnt/Makefile
index b568790597b6..6c20652617ca 100644
--- a/devel/cvsnt/Makefile
+++ b/devel/cvsnt/Makefile
@@ -24,7 +24,6 @@ CONFIGURE_ARGS= --enable-fork --enable-rcs \
--disable-odbc --disable-postgres\
--disable-mysql --disable-sqlite
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-USE_GETOPT_LONG=yes
USE_ICONV= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include"\
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"\
diff --git a/devel/eboxy/Makefile b/devel/eboxy/Makefile
index 5a4ad4487a49..ca4fad6a991d 100644
--- a/devel/eboxy/Makefile
+++ b/devel/eboxy/Makefile
@@ -20,7 +20,6 @@ USE_BISON= build
USE_BZIP2= yes
USE_SDL= sdl gui mixer
USE_GNOME= gnometarget libxml2 lthack
-USE_GETOPT_LONG= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-lirc
diff --git a/devel/ecore-file/Makefile b/devel/ecore-file/Makefile
index 49dbff8abac7..b3ca1cbe2204 100644
--- a/devel/ecore-file/Makefile
+++ b/devel/ecore-file/Makefile
@@ -21,7 +21,6 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_GETOPT_LONG=yes
USE_EFL= ecore
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_file
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/devel/ecore-ipc/Makefile b/devel/ecore-ipc/Makefile
index 02af88c5ff1e..7d14d0932480 100644
--- a/devel/ecore-ipc/Makefile
+++ b/devel/ecore-ipc/Makefile
@@ -21,7 +21,6 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_GETOPT_LONG=yes
USE_EFL= ecore
USE_EFL_ECORE= con
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_ipc
diff --git a/devel/ecore-job/Makefile b/devel/ecore-job/Makefile
index 90ab1c6e667a..19ea9a2d43ed 100644
--- a/devel/ecore-job/Makefile
+++ b/devel/ecore-job/Makefile
@@ -21,7 +21,6 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_GETOPT_LONG=yes
USE_EFL= ecore
BUILD_WRKSRC= ${WRKSRC}/src/lib/ecore_job
INSTALL_WRKSRC= ${BUILD_WRKSRC}
diff --git a/devel/ecore-main/Makefile b/devel/ecore-main/Makefile
index 97cfb70b112a..38c26cb32926 100644
--- a/devel/ecore-main/Makefile
+++ b/devel/ecore-main/Makefile
@@ -21,7 +21,6 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack pkgconfig gnometarget
USE_LDCONFIG= yes
-USE_GETOPT_LONG=yes
CONFIGURE_ARGS= --disable-ecore-con \
--disable-ecore-config \
diff --git a/devel/fastdep/Makefile b/devel/fastdep/Makefile
index 86b60cd948d6..10ebd7725dfe 100644
--- a/devel/fastdep/Makefile
+++ b/devel/fastdep/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= sergei@FreeBSD.org
COMMENT= Fast dependency generator for C/C++ files
USE_GMAKE= yes
-USE_GETOPT_LONG= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --disable-local-gnugetopt
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index 539a07e48121..eecec0ab0e9e 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -19,7 +19,6 @@ COMMENT= High-end interface client for CVS
BUILD_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
-USE_GETOPT_LONG=yes
USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/devel/glademm/Makefile b/devel/glademm/Makefile
index 4647b4933ccd..c3df826d124a 100644
--- a/devel/glademm/Makefile
+++ b/devel/glademm/Makefile
@@ -19,7 +19,6 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnometarget
GNU_CONFIGURE= yes
-USE_GETOPT_LONG= yes
PLIST_FILES= bin/glade-- bin/glademm-embed
diff --git a/devel/hcs12mem/Makefile b/devel/hcs12mem/Makefile
index cdd951045803..6aac0789a1fa 100644
--- a/devel/hcs12mem/Makefile
+++ b/devel/hcs12mem/Makefile
@@ -15,7 +15,6 @@ COMMENT= Software to manipulate EEPROM/FLASH memory
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETOPT_LONG= yes
MANCOMPRESSED= no
MAN1= hcs12mem.1
diff --git a/devel/id-utils/Makefile b/devel/id-utils/Makefile
index 832647979d50..650609f1d796 100644
--- a/devel/id-utils/Makefile
+++ b/devel/id-utils/Makefile
@@ -17,7 +17,6 @@ COMMENT= The classic Berkeley gid/lid tools for looking up variables in code
CONFLICTS= coreutils-[0-9]* linux-gid-[0-9]* sh-utils-[0-9]*
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/devel/idutils/Makefile b/devel/idutils/Makefile
index 832647979d50..650609f1d796 100644
--- a/devel/idutils/Makefile
+++ b/devel/idutils/Makefile
@@ -17,7 +17,6 @@ COMMENT= The classic Berkeley gid/lid tools for looking up variables in code
CONFLICTS= coreutils-[0-9]* linux-gid-[0-9]* sh-utils-[0-9]*
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/devel/jclassinfo/Makefile b/devel/jclassinfo/Makefile
index 81d7a9200a45..9378dea97d21 100644
--- a/devel/jclassinfo/Makefile
+++ b/devel/jclassinfo/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Shows information about Java class, dependencies and more
USE_AUTOTOOLS= libtool:15
-USE_GETOPT_LONG= yes
USE_GNOME= pkgconfig gnomehack
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/devel/kimwitu++/Makefile b/devel/kimwitu++/Makefile
index 5f996782f3cc..6a29f87995db 100644
--- a/devel/kimwitu++/Makefile
+++ b/devel/kimwitu++/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A tool for processing trees (i.e. terms)
USE_BISON= build
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/devel/libytnef/Makefile b/devel/libytnef/Makefile
index 05e1af9f41c6..ea98cb43578d 100644
--- a/devel/libytnef/Makefile
+++ b/devel/libytnef/Makefile
@@ -18,7 +18,6 @@ COMMENT= Unpack data in MS Outlook TNEF format
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
-USE_GETOPT_LONG=yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/devel/pcsc-lite/Makefile b/devel/pcsc-lite/Makefile
index cd34125afb8c..4044ffc45f08 100644
--- a/devel/pcsc-lite/Makefile
+++ b/devel/pcsc-lite/Makefile
@@ -31,7 +31,6 @@ CONFIGURE_ARGS+=--enable-debug \
--enable-usbdropdir=${PREFIX}/lib/pcsc/drivers/ \
--enable-muscledropdir=${PREFIX}/lib/pcsc/services/ \
--enable-threadsafe
-USE_GETOPT_LONG=yes
PKGMESSAGE= ${WRKDIR}/pkg-message
MAN5= reader.conf.5
diff --git a/devel/picprog/Makefile b/devel/picprog/Makefile
index 3427b68280e8..5cf77a9ea0b6 100644
--- a/devel/picprog/Makefile
+++ b/devel/picprog/Makefile
@@ -13,7 +13,6 @@ MASTER_SITES= http://hyvatti.iki.fi/~jaakko/pic/
MAINTAINER= erik@smluc.org
COMMENT= Serial port pic16c84 programmer
-USE_GETOPT_LONG= yes
USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/devel/rlwrap/Makefile b/devel/rlwrap/Makefile
index 58a033b1777c..f2f4d4152809 100644
--- a/devel/rlwrap/Makefile
+++ b/devel/rlwrap/Makefile
@@ -17,7 +17,6 @@ MASTER_SITE_SUBDIR= dryice
MAINTAINER= dryice@FreeBSD.org
COMMENT= Readline wrapper
-USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= ptyttylib_cv_ptys=BSD LDFLAGS=-lutil
diff --git a/dns/dnsflood/Makefile b/dns/dnsflood/Makefile
index 687a0196e8af..b4427aeac935 100644
--- a/dns/dnsflood/Makefile
+++ b/dns/dnsflood/Makefile
@@ -15,8 +15,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= az@FreeBSD.org
COMMENT= DNS flood detector
-USE_GETOPT_LONG= yes
-
WRKSRC= ${WRKDIR}/dns_flood_detector
PLIST_FILES= sbin/dns_flood_detector
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index fef8599cda35..60289d75b09c 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -22,7 +22,6 @@ PORTDOCS= ${docs:T}
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
-USE_GETOPT_LONG=yes
USE_GMAKE= yes
USE_GNOME= pkgconfig
MAKE_ENV= LIBS="${LDFLAGS}" RPM_OPT_FLAGS="${CPPFLAGS}" COPTS="${CFLAGS}"
diff --git a/dns/drill/Makefile b/dns/drill/Makefile
index 8521a9408f78..7f09c4996617 100644
--- a/dns/drill/Makefile
+++ b/dns/drill/Makefile
@@ -20,7 +20,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
USE_OPENSSL= yes
HAS_CONFIGURE= yes
-USE_GETOPT_LONG=yes
LDFLAGS+= -L${OPENSSLLIB}
CFLAGS+= ${CPPFLAGS} -I${OPENSSLINC}
CONFIGURE_ARGS= --prefix=${PREFIX}
diff --git a/dns/libidn/Makefile b/dns/libidn/Makefile
index a4d78d76760d..81bb1a97af24 100644
--- a/dns/libidn/Makefile
+++ b/dns/libidn/Makefile
@@ -15,7 +15,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= krion@FreeBSD.org
COMMENT= Internationalized Domain Names command line tool
-USE_GETOPT_LONG= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_ICONV= yes
USE_LDCONFIG= yes