aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 03:54:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-06-26 03:54:09 +0000
commit0825d343b67d333a5eb074ffc162e99e36afd05b (patch)
treefa9e30457336a2f3f64d4b8aec724296f7285e0a
parent527b94968318c37ba67fae67811b60ad2500b11c (diff)
downloadports-0825d343b67d333a5eb074ffc162e99e36afd05b.tar.gz
ports-0825d343b67d333a5eb074ffc162e99e36afd05b.zip
${PERL} -> ${REINPLACE_CMD}
PR: 39856 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=61971
-rw-r--r--deskutils/horde-kronolith/Makefile18
-rw-r--r--deskutils/horde-nag/Makefile12
-rw-r--r--deskutils/horde4-kronolith/Makefile18
-rw-r--r--deskutils/horde4-nag/Makefile12
-rw-r--r--deskutils/kronolith/Makefile18
-rw-r--r--deskutils/nag/Makefile12
-rw-r--r--devel/chora/Makefile16
-rw-r--r--devel/horde-chora/Makefile16
-rw-r--r--mail/horde-turba/Makefile10
-rw-r--r--mail/horde4-turba/Makefile10
-rw-r--r--mail/imp3/Makefile53
-rw-r--r--mail/turba/Makefile10
-rw-r--r--www/horde2/Makefile40
-rw-r--r--www/horde2/files/patch-ab27
-rw-r--r--www/horde2/pkg-deinstall3
15 files changed, 151 insertions, 124 deletions
diff --git a/deskutils/horde-kronolith/Makefile b/deskutils/horde-kronolith/Makefile
index ac563fd6f682..15cbd738af4f 100644
--- a/deskutils/horde-kronolith/Makefile
+++ b/deskutils/horde-kronolith/Makefile
@@ -18,9 +18,11 @@ RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-IS_INTERACTIVE= 'need to build mod_php4 with mcrypt option set.'
+IS_INTERACTIVE= 'need to build mod_php4 with MCAL option set.'
NO_BUILD= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i.beforeKronolith
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL docs/TODO
CONFFILE= conf.php html.php keywords.php menu.php prefs.php
SUB_DIRS= config graphics lib locale po scripts templates
@@ -60,11 +62,10 @@ do-install:
@${CHOWN} -R www:www ${KRONOLITHDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.kronolith ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/kronolith:${KRONOLITHDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/kronolith:${KRONOLITHDIR}:g" \
${HORDE_INC}/httpd.conf.kronolith
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeKronolith
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTKRONOLITH::" \
+ @${RM} ${HORDE_INC}/httpd.conf.kronolith.beforeKronolith
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTKRONOLITH::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterKronolith
@@ -88,16 +89,17 @@ post-install:
${ECHO} -n "Please enter a password for www's calendar: " ; \
(read PASSCAL; \
${LOCALBASE}/bin/htpasswd -bc ${LOCALBASE}/etc/mpasswd www $${PASSCAL}; \
- ${PERL} -pi -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
elif ! ${GREP} -q -e "^www" ${LOCALBASE}/etc/mpasswd ; then \
${ECHO_MSG} "===> Adding www into ${LOCALBASE}/etc/mpasswd" ; \
${ECHO} -n "Please enter a password for www's calendar: " ; \
(read PASSCAL; \
${LOCALBASE}/bin/htpasswd -b ${LOCALBASE}/etc/mpasswd www $${PASSCAL} ; \
- ${PERL} -pi -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
else \
- ${PERL} -pi -e "s:%%PASSCAL%%:www_cal_password:" ${CONFDIR}/conf.php ; \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:www_cal_password:" ${CONFDIR}/conf.php ; \
fi
+ @${RM} ${CONFDIR}/conf.php.beforeKronolith
.endif
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE} | \
diff --git a/deskutils/horde-nag/Makefile b/deskutils/horde-nag/Makefile
index 2f997563f112..cbbd623abdff 100644
--- a/deskutils/horde-nag/Makefile
+++ b/deskutils/horde-nag/Makefile
@@ -16,8 +16,11 @@ MAINTAINER= thierry@pompo.net
RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeNag
+
PLIST_SUB= HORDEDIR=${LHORDEDIR} NAGDIR=${LNAGDIR}
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -48,11 +51,10 @@ do-install:
@${CHOWN} -R www:www ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.nag ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
${HORDE_INC}/httpd.conf.nag
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeNag
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
+ @${RM} ${HORDE_INC}/httpd.conf.nag.beforeNag
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterNag
.if !defined(NOPORTDOCS)
diff --git a/deskutils/horde4-kronolith/Makefile b/deskutils/horde4-kronolith/Makefile
index ac563fd6f682..15cbd738af4f 100644
--- a/deskutils/horde4-kronolith/Makefile
+++ b/deskutils/horde4-kronolith/Makefile
@@ -18,9 +18,11 @@ RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-IS_INTERACTIVE= 'need to build mod_php4 with mcrypt option set.'
+IS_INTERACTIVE= 'need to build mod_php4 with MCAL option set.'
NO_BUILD= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i.beforeKronolith
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL docs/TODO
CONFFILE= conf.php html.php keywords.php menu.php prefs.php
SUB_DIRS= config graphics lib locale po scripts templates
@@ -60,11 +62,10 @@ do-install:
@${CHOWN} -R www:www ${KRONOLITHDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.kronolith ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/kronolith:${KRONOLITHDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/kronolith:${KRONOLITHDIR}:g" \
${HORDE_INC}/httpd.conf.kronolith
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeKronolith
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTKRONOLITH::" \
+ @${RM} ${HORDE_INC}/httpd.conf.kronolith.beforeKronolith
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTKRONOLITH::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterKronolith
@@ -88,16 +89,17 @@ post-install:
${ECHO} -n "Please enter a password for www's calendar: " ; \
(read PASSCAL; \
${LOCALBASE}/bin/htpasswd -bc ${LOCALBASE}/etc/mpasswd www $${PASSCAL}; \
- ${PERL} -pi -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
elif ! ${GREP} -q -e "^www" ${LOCALBASE}/etc/mpasswd ; then \
${ECHO_MSG} "===> Adding www into ${LOCALBASE}/etc/mpasswd" ; \
${ECHO} -n "Please enter a password for www's calendar: " ; \
(read PASSCAL; \
${LOCALBASE}/bin/htpasswd -b ${LOCALBASE}/etc/mpasswd www $${PASSCAL} ; \
- ${PERL} -pi -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
else \
- ${PERL} -pi -e "s:%%PASSCAL%%:www_cal_password:" ${CONFDIR}/conf.php ; \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:www_cal_password:" ${CONFDIR}/conf.php ; \
fi
+ @${RM} ${CONFDIR}/conf.php.beforeKronolith
.endif
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE} | \
diff --git a/deskutils/horde4-nag/Makefile b/deskutils/horde4-nag/Makefile
index 2f997563f112..cbbd623abdff 100644
--- a/deskutils/horde4-nag/Makefile
+++ b/deskutils/horde4-nag/Makefile
@@ -16,8 +16,11 @@ MAINTAINER= thierry@pompo.net
RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeNag
+
PLIST_SUB= HORDEDIR=${LHORDEDIR} NAGDIR=${LNAGDIR}
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -48,11 +51,10 @@ do-install:
@${CHOWN} -R www:www ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.nag ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
${HORDE_INC}/httpd.conf.nag
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeNag
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
+ @${RM} ${HORDE_INC}/httpd.conf.nag.beforeNag
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterNag
.if !defined(NOPORTDOCS)
diff --git a/deskutils/kronolith/Makefile b/deskutils/kronolith/Makefile
index ac563fd6f682..15cbd738af4f 100644
--- a/deskutils/kronolith/Makefile
+++ b/deskutils/kronolith/Makefile
@@ -18,9 +18,11 @@ RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-IS_INTERACTIVE= 'need to build mod_php4 with mcrypt option set.'
+IS_INTERACTIVE= 'need to build mod_php4 with MCAL option set.'
NO_BUILD= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i.beforeKronolith
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL docs/TODO
CONFFILE= conf.php html.php keywords.php menu.php prefs.php
SUB_DIRS= config graphics lib locale po scripts templates
@@ -60,11 +62,10 @@ do-install:
@${CHOWN} -R www:www ${KRONOLITHDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.kronolith ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/kronolith:${KRONOLITHDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/kronolith:${KRONOLITHDIR}:g" \
${HORDE_INC}/httpd.conf.kronolith
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeKronolith
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTKRONOLITH::" \
+ @${RM} ${HORDE_INC}/httpd.conf.kronolith.beforeKronolith
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTKRONOLITH::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterKronolith
@@ -88,16 +89,17 @@ post-install:
${ECHO} -n "Please enter a password for www's calendar: " ; \
(read PASSCAL; \
${LOCALBASE}/bin/htpasswd -bc ${LOCALBASE}/etc/mpasswd www $${PASSCAL}; \
- ${PERL} -pi -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
elif ! ${GREP} -q -e "^www" ${LOCALBASE}/etc/mpasswd ; then \
${ECHO_MSG} "===> Adding www into ${LOCALBASE}/etc/mpasswd" ; \
${ECHO} -n "Please enter a password for www's calendar: " ; \
(read PASSCAL; \
${LOCALBASE}/bin/htpasswd -b ${LOCALBASE}/etc/mpasswd www $${PASSCAL} ; \
- ${PERL} -pi -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:$${PASSCAL}:" ${CONFDIR}/conf.php) \
else \
- ${PERL} -pi -e "s:%%PASSCAL%%:www_cal_password:" ${CONFDIR}/conf.php ; \
+ ${REINPLACE_CMD} -e "s:%%PASSCAL%%:www_cal_password:" ${CONFDIR}/conf.php ; \
fi
+ @${RM} ${CONFDIR}/conf.php.beforeKronolith
.endif
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE} | \
diff --git a/deskutils/nag/Makefile b/deskutils/nag/Makefile
index 2f997563f112..cbbd623abdff 100644
--- a/deskutils/nag/Makefile
+++ b/deskutils/nag/Makefile
@@ -16,8 +16,11 @@ MAINTAINER= thierry@pompo.net
RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeNag
+
PLIST_SUB= HORDEDIR=${LHORDEDIR} NAGDIR=${LNAGDIR}
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -48,11 +51,10 @@ do-install:
@${CHOWN} -R www:www ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.nag ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
${HORDE_INC}/httpd.conf.nag
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeNag
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
+ @${RM} ${HORDE_INC}/httpd.conf.nag.beforeNag
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterNag
.if !defined(NOPORTDOCS)
diff --git a/devel/chora/Makefile b/devel/chora/Makefile
index c8230b1b3066..0329a050b774 100644
--- a/devel/chora/Makefile
+++ b/devel/chora/Makefile
@@ -35,6 +35,8 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letter
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i.beforeChora
# Specify where your repository belongs.
# (You can reconfigure it after installation anyway)
@@ -70,21 +72,19 @@ do-install:
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${PERL} -pi -e "s:%%CVSROOT%%:${CVSROOT}:;s:%%CONFDIR%%:${CONFDIR}:" \
+ @${REINPLACE_CMD} -e "s:%%CVSROOT%%:${CVSROOT}:;s:%%CONFDIR%%:${CONFDIR}:" \
${CONFDIR}/cvsroots.php
+ @${RM} ${CONFDIR}/cvsroots.php.beforeChora
@${CHOWN} -R www:www ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.chora ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/chora:${CHORADIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/chora:${CHORADIR}:g" \
${HORDE_INC}/httpd.conf.chora
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeChora
- @${CP} -p ${HORDEDIR}/config/mime_drivers.php \
- ${HORDEDIR}/config/mime_drivers.php.beforeChora
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
+ @${RM} ${HORDE_INC}/httpd.conf.chora.beforeChora
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTCHORA::" \
${HORDEDIR}/config/registry.php
.if !defined(WITHOUT_ENSCRIPT)
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTCHORA::" \
${HORDEDIR}/config/mime_drivers.php
.endif
@${CP} -p ${HORDEDIR}/config/registry.php \
diff --git a/devel/horde-chora/Makefile b/devel/horde-chora/Makefile
index c8230b1b3066..0329a050b774 100644
--- a/devel/horde-chora/Makefile
+++ b/devel/horde-chora/Makefile
@@ -35,6 +35,8 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/enscript:${PORTSDIR}/print/enscript-letter
.endif
NO_BUILD= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i.beforeChora
# Specify where your repository belongs.
# (You can reconfigure it after installation anyway)
@@ -70,21 +72,19 @@ do-install:
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${PERL} -pi -e "s:%%CVSROOT%%:${CVSROOT}:;s:%%CONFDIR%%:${CONFDIR}:" \
+ @${REINPLACE_CMD} -e "s:%%CVSROOT%%:${CVSROOT}:;s:%%CONFDIR%%:${CONFDIR}:" \
${CONFDIR}/cvsroots.php
+ @${RM} ${CONFDIR}/cvsroots.php.beforeChora
@${CHOWN} -R www:www ${CHORADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.chora ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/chora:${CHORADIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/chora:${CHORADIR}:g" \
${HORDE_INC}/httpd.conf.chora
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeChora
- @${CP} -p ${HORDEDIR}/config/mime_drivers.php \
- ${HORDEDIR}/config/mime_drivers.php.beforeChora
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
+ @${RM} ${HORDE_INC}/httpd.conf.chora.beforeChora
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTCHORA::" \
${HORDEDIR}/config/registry.php
.if !defined(WITHOUT_ENSCRIPT)
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTCHORA::" \
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTCHORA::" \
${HORDEDIR}/config/mime_drivers.php
.endif
@${CP} -p ${HORDEDIR}/config/registry.php \
diff --git a/mail/horde-turba/Makefile b/mail/horde-turba/Makefile
index de7e2932ba40..850e007e9ae5 100644
--- a/mail/horde-turba/Makefile
+++ b/mail/horde-turba/Makefile
@@ -39,6 +39,9 @@ LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2 \
RUN_DEPENDS+= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeTurba
DOCS= COPYING README docs/CHANGES docs/CREDITS \
docs/INSTALL docs/turba.dia docs/turba.pdf
CONFFILE= attributes.php conf.php html.php menu.php \
@@ -109,11 +112,10 @@ do-install:
@${CHOWN} -R www:www ${TURBADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.turba ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
${HORDE_INC}/httpd.conf.turba
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeTurba
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTTURBA::" \
+ @${RM} ${HORDE_INC}/httpd.conf.turba.beforeTurba
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTTURBA::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterTurba
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index de7e2932ba40..850e007e9ae5 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -39,6 +39,9 @@ LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2 \
RUN_DEPENDS+= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeTurba
DOCS= COPYING README docs/CHANGES docs/CREDITS \
docs/INSTALL docs/turba.dia docs/turba.pdf
CONFFILE= attributes.php conf.php html.php menu.php \
@@ -109,11 +112,10 @@ do-install:
@${CHOWN} -R www:www ${TURBADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.turba ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
${HORDE_INC}/httpd.conf.turba
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeTurba
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTTURBA::" \
+ @${RM} ${HORDE_INC}/httpd.conf.turba.beforeTurba
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTTURBA::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterTurba
diff --git a/mail/imp3/Makefile b/mail/imp3/Makefile
index d6255aceba79..3fa1d15d7cc7 100644
--- a/mail/imp3/Makefile
+++ b/mail/imp3/Makefile
@@ -121,6 +121,9 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/aspell:${PORTSDIR}/textproc/aspell
IS_INTERACTIVE= 'need to build mod_php4 with mcrypt, cclient with SSL.'
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeIMP
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL
CONFFILE= conf.php filter.txt header.txt html.php menu.php \
mime_drivers.php motd.php prefs.php servers.php \
@@ -238,62 +241,66 @@ do-install:
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${CP} -p ${HCONFDIR}/mime_drivers.php ${HCONFDIR}/mime_drivers.php.beforeIMP
- @${CP} -p ${HCONFDIR}/registry.php ${HCONFDIR}/registry.php.beforeIMP
- @${CP} -p ${TURBADIR}/config/conf.php ${TURBADIR}/config/conf.php.beforeIMP
- @${PERL} -pi -e "s:example.com:${HOSTNAME}:g" ${CONFDIR}/servers.php
- @${PERL} -pi -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${CONFDIR}/mime_drivers.php
- @${PERL} -pi -e "s:IMP_VERSION:IMP_VERSION . ' / ${SERVOS}':" \
+ @${CP} -p ${HCONFDIR}/mime_drivers.php ${HCONFDIR}/mime_drivers.php.beforeIMP3
+ @${CP} -p ${HCONFDIR}/registry.php ${HCONFDIR}/registry.php.beforeIMP3
+ @${CP} -p ${TURBADIR}/config/conf.php ${TURBADIR}/config/conf.php.beforeIMP3
+ @${REINPLACE_CMD} -e "s:example.com:${HOSTNAME}:g" ${CONFDIR}/servers.php
+ @${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${CONFDIR}/mime_drivers.php
+ @${RM} ${CONFDIR}/mime_drivers.php.beforeIMP
+ @${REINPLACE_CMD} -e "s:IMP_VERSION:IMP_VERSION . ' / ${SERVOS}':" \
${IMPDIR}/compose.php
+ @${RM} ${IMPDIR}/compose.php.beforeIMP
.if defined(WITHOUT_SSL)
- @${PERL} -pi -e "s:%%PROTOCOL%%:imap/notls:;s:%%IMAPPORT%%:143:" \
+ @${REINPLACE_CMD} -e "s:%%PROTOCOL%%:imap/notls:;s:%%IMAPPORT%%:143:" \
${CONFDIR}/servers.php
.else
- @${PERL} -pi -e "s:%%IMAPPORT%%:993:" ${CONFDIR}/servers.php
+ @${REINPLACE_CMD} -e "s:%%IMAPPORT%%:993:" ${CONFDIR}/servers.php
.if defined(WITH_VALID_CERT)
- @${PERL} -pi -e "s:%%PROTOCOL%%:imap/ssl:" ${CONFDIR}/servers.php
+ @${REINPLACE_CMD} -e "s:%%PROTOCOL%%:imap/ssl:" ${CONFDIR}/servers.php
.else
- @${PERL} -pi -e "s:%%PROTOCOL%%:imap/ssl/novalidate-cert:" \
+ @${REINPLACE_CMD} -e "s:%%PROTOCOL%%:imap/ssl/novalidate-cert:" \
${CONFDIR}/servers.php
.endif
+ @${RM} ${CONFDIR}/servers.php.beforeIMP
.endif
.if !defined(WITHOUT_ASPELL)
- @${PERL} -pi -e "s:spellchecker'] = '':spellchecker'] = '${LOCALBASE}/bin/aspell':" \
+ @${REINPLACE_CMD} -e "s:spellchecker'] = '':spellchecker'] = '${LOCALBASE}/bin/aspell':" \
${CONFDIR}/conf.php
.endif
.if !defined(WITHOUT_X11)
.if !defined(WITHOUT_WV)
- @${PERL} -pi -e "s://UNCOMMENTIFWV ::" ${HCONFDIR}/mime_drivers.php
+ @${REINPLACE_CMD} -e "s://UNCOMMENTIFWV ::" ${HCONFDIR}/mime_drivers.php
.endif
.if !defined(WITHOUT_XL)
- @${PERL} -pi -e "s://UNCOMMENTIFXL ::" ${HCONFDIR}/mime_drivers.php
+ @${REINPLACE_CMD} -e "s://UNCOMMENTIFXL ::" ${HCONFDIR}/mime_drivers.php
.endif
.endif
#.if !defined(NOCRYPT)
# @(if [ ! -d ${GNUPG_CNFDIR} ] ; then \
# ${MKDIR} ${GNUPG_CNFDIR} ; \
# fi)
-# @${PERL} -pi -e "s:pgp']['enabled'] = false:pgp']['enabled'] = true:g" \
+# @${REINPLACE_CMD} -e "s:pgp']['enabled'] = false:pgp']['enabled'] = true:g" \
# ${CONFDIR}/conf.php
-# @${PERL} -pi -e "s:%%GNUPG_CNFDIR%%:${GNUPG_CNFDIR}:" \
+# @${REINPLACE_CMD} -e "s:%%GNUPG_CNFDIR%%:${GNUPG_CNFDIR}:" \
# ${CONFDIR}/conf.php
#.endif
.if !defined(WITHOUT_ZIP)
- @${PERL} -pi -e "s://UNCOMMENTIFZIP ::" ${HCONFDIR}/mime_drivers.php
+ @${REINPLACE_CMD} -e "s://UNCOMMENTIFZIP ::" ${HCONFDIR}/mime_drivers.php
.endif
.if defined(WITH_RAR)
- @${PERL} -pi -e "s://UNCOMMENTIFRAR ::" ${HCONFDIR}/mime_drivers.php
+ @${REINPLACE_CMD} -e "s://UNCOMMENTIFRAR ::" ${HCONFDIR}/mime_drivers.php
.endif
@${CHOWN} -R www:www ${IMPDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.imp ${HORDE_INC}/httpd.conf.imp
- @${PERL} -pi -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" ${HORDE_INC}/httpd.conf.imp
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/imp:${IMPDIR}:g" ${HORDE_INC}/httpd.conf.imp
+ @${RM} ${HORDE_INC}/httpd.conf.imp.beforeIMP
# Let's Horde use IMP for auth
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTIMP::" ${HCONFDIR}/registry.php
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTIMP::" ${HCONFDIR}/registry.php
# Provide a link to IMP from Turba
.if !defined(WITHOUT_TURBA)
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTIMP::" ${TURBADIR}/config/conf.php
- @${PERL} -pi -e "s:apps'] = array\(\):apps'] = array('turba'):" \
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTIMP::" ${TURBADIR}/config/conf.php
+ @${REINPLACE_CMD} -e "s:apps'] = array():apps'] = array('turba'):" \
${CONFDIR}/conf.php
.endif
.if !defined(NOPORTDOCS)
@@ -304,6 +311,10 @@ do-install:
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
# Prepare deinstallation
+ @${RM} ${CONFDIR}/conf.php.beforeIMP
+ @${MV} ${HCONFDIR}/mime_drivers.php.beforeIMP3 ${HCONFDIR}/mime_drivers.php.beforeIMP
+ @${MV} ${HCONFDIR}/registry.php.beforeIMP3 ${HCONFDIR}/registry.php.beforeIMP
+ @${MV} ${TURBADIR}/config/conf.php.beforeIMP3 ${TURBADIR}/config/conf.php.beforeIMP
@${CP} -p ${HCONFDIR}/mime_drivers.php ${HCONFDIR}/mime_drivers.php.afterIMP
@${CP} -p ${HCONFDIR}/registry.php ${HCONFDIR}/registry.php.afterIMP
@${CP} -p ${TURBADIR}/config/conf.php ${TURBADIR}/config/conf.php.afterIMP
diff --git a/mail/turba/Makefile b/mail/turba/Makefile
index de7e2932ba40..850e007e9ae5 100644
--- a/mail/turba/Makefile
+++ b/mail/turba/Makefile
@@ -39,6 +39,9 @@ LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2 \
RUN_DEPENDS+= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeTurba
DOCS= COPYING README docs/CHANGES docs/CREDITS \
docs/INSTALL docs/turba.dia docs/turba.pdf
CONFFILE= attributes.php conf.php html.php menu.php \
@@ -109,11 +112,10 @@ do-install:
@${CHOWN} -R www:www ${TURBADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.turba ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
${HORDE_INC}/httpd.conf.turba
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeTurba
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTTURBA::" \
+ @${RM} ${HORDE_INC}/httpd.conf.turba.beforeTurba
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTTURBA::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterTurba
diff --git a/www/horde2/Makefile b/www/horde2/Makefile
index 81189991849c..08db76bb5435 100644
--- a/www/horde2/Makefile
+++ b/www/horde2/Makefile
@@ -34,6 +34,9 @@ RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libssl.so:${PORTSDIR}/www/apache13-mod
RUN_DEPENDS+= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeHorde
DOCS= COPYING README docs/CHANGES docs/CODING_STANDARDS \
docs/CONTRIBUTING docs/CREDITS docs/HACKING docs/INSTALL
CONFFILE= html.php lang.php mime_drivers.php mime_mapping.php \
@@ -92,33 +95,35 @@ do-install:
@${CP} -p ${WRKSRC}/*.php ${HORDEDIR}
@if [ ! -f ${CONFDIR}/horde.php ]; then \
${CP} ${CONFDIR}/horde.php.dist ${CONFDIR}/horde.php ; \
- ${PERL} -pi -e "s:/var/www/htdocs/horde/templates:${HORDEDIR}/templates:g" \
- ${CONFDIR}/horde.php ; \
- ${PERL} -pi -e "s:/tmp/horde.log:${LOG_FILE}:g" ${CONFDIR}/horde.php ; \
+ ${REINPLACE_CMD} -e "s:/tmp/horde.log:${LOG_FILE}:g" ${CONFDIR}/horde.php ; \
+ ${RM} ${CONFDIR}/horde.php.beforeHorde ; \
fi
- @${PERL} -pi -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:g" \
+ @${REINPLACE_CMD} -e "s:/etc/mpasswd:${LOCALBASE}/etc/mpasswd:g" \
${HORDEDIR}/lib/Auth/mcal.php
+ @${RM} ${HORDEDIR}/lib/Auth/mcal.php.beforeHorde
.for FILE in ${CONFFILE}
@if [ ! -f ${CONFDIR}/${FILE} ]; then \
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${PERL} -pi -e "s:%%LOCALBASE%%:${LOCALBASE}:" ${CONFDIR}/mime_drivers.php
+ @${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:" ${CONFDIR}/mime_drivers.php
+ @${RM} ${CONFDIR}/mime_drivers.php.beforeHorde
@${CP} ${WRKSRC}/scripts/set_perms.sh ${HORDESBIN}/horde_set_perms.sh
- @${PERL} -pi -e "s:UPDATED_BY_THE_PORT:${HORDEDIR}/:g" \
+ @${REINPLACE_CMD} -e "s:UPDATED_BY_THE_PORT:${HORDEDIR}/:g" \
${HORDESBIN}/horde_set_perms.sh
+ @${RM} ${HORDESBIN}/horde_set_perms.sh.beforeHorde
@${CHMOD} u+x ${HORDESBIN}/horde_set_perms.sh
@(if [ -f ${APACHE_CONF} ] ; then \
- ${MKDIR} ${HORDE_INC} ; \
- ${CP} -p ${FILESDIR}/httpd.conf.horde ${HORDE_INC} ; \
- ${PERL} -pi -e "s:/home/httpd/html/horde:${HORDEDIR}:g" ${HORDE_INC}/httpd.conf.horde ; \
- ${PERL} -pi -e "s:/home/httpd/phplib:${PHP_LIB}:g" ${HORDE_INC}/httpd.conf.horde ; \
- ${ECHO_MSG} "===> Updating ${APACHE_CONF}..." ; \
- ${CP} -p ${APACHE_CONF} ${APACHE_CONF}.beforeHorde ; \
- ${PERL} -pi -e "s:php_value auto_prepend_file:# php_value auto_prepend_file:g" ${APACHE_CONF} ; \
- ${PERL} -pi -e "s:${HORDEDIR}/phplib:${PHP_LIB}:g" ${APACHE_CONF} ; \
- ${ECHO_CMD} "# Horde's include directory" >> ${APACHE_CONF} ; \
- ${ECHO_CMD} "Include ${HORDE_INC}" >> ${APACHE_CONF} ; \
+ ${MKDIR} ${HORDE_INC} ; \
+ ${CP} -p ${FILESDIR}/httpd.conf.horde ${HORDE_INC} ; \
+ ${REINPLACE_CMD} -e "s:/home/httpd/html/horde:${HORDEDIR}:g ; \
+ s:/home/httpd/phplib:${PHP_LIB}:g" ${HORDE_INC}/httpd.conf.horde ; \
+ ${RM} ${HORDE_INC}/httpd.conf.horde.beforeHorde ; \
+ ${ECHO_MSG} "===> Updating ${APACHE_CONF}..." ; \
+ ${REINPLACE_CMD} -e "s:php_value auto_prepend_file:# php_value auto_prepend_file:g ; \
+ s:${HORDEDIR}/phplib:${PHP_LIB}:g" ${APACHE_CONF} ; \
+ ${ECHO_CMD} "# Horde's include directory" >> ${APACHE_CONF} ; \
+ ${ECHO_CMD} "Include ${HORDE_INC}" >> ${APACHE_CONF} ; \
fi)
@${CHOWN} -R www:www ${HORDEDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@@ -129,7 +134,8 @@ do-install:
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
- @${PERL} -pi -e "s:/usr/local/apache/htdocs/horde:${DOCSDIR}:g" ${DOCSDIR}/INSTALL
+ @${REINPLACE_CMD} -e "s:/usr/local/apache/htdocs:${PREFIX}/www:g" ${DOCSDIR}/INSTALL
+ @${RM} ${DOCSDIR}/INSTALL.beforeHorde
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
diff --git a/www/horde2/files/patch-ab b/www/horde2/files/patch-ab
index 16553bca732a..fbbef346a07f 100644
--- a/www/horde2/files/patch-ab
+++ b/www/horde2/files/patch-ab
@@ -1,5 +1,5 @@
---- config/horde.php.dist.orig Sat Mar 9 19:43:35 2002
-+++ config/horde.php.dist Wed Mar 13 01:21:30 2002
+--- config/horde.php.dist.orig Sat Jun 1 01:57:03 2002
++++ config/horde.php.dist Mon Jun 24 21:59:21 2002
@@ -75,7 +75,7 @@
// What backend should we use for authenticating users to Horde? Valid
@@ -9,18 +9,9 @@
// An array holding any parameters that the Auth object will need to
// function correctly.
-@@ -106,7 +106,7 @@
- // and for sql it would be the table name to use. For the 'syslog'
- // driver it is the facility as a _constant_ (with no quotes), e.g.:
- // ... = LOG_LOCAL0;
--$conf['log']['name'] = '/tmp/horde.log';
-+$conf['log']['name'] = '/var/log/horde.log';
-
- // What level of messages should we log? The values are LOG_EMERG,
- // LOG_ALERT, LOG_CRIT, LOG_ERR, LOG_WARNING, LOG_NOTICE, LOG_INFO,
@@ -131,7 +131,7 @@
// (meaning use system defaults and don't save any user preferences),
- // 'session' (preferences only persist during the login), 'ldap',
+ // 'session' (preferences only persist during the login), 'ldap',
// and 'sql'.
-$conf['prefs']['driver'] = 'none';
+$conf['prefs']['driver'] = 'sql';
@@ -44,18 +35,18 @@
+$conf['prefs']['params']['database'] = 'horde';
+$conf['prefs']['params']['table'] = 'horde_prefs';
-
- /**
-@@ -177,7 +177,7 @@
- // function correctly. For sendmail, this is mainly the sendmail_path
- // option; SMTP requires at least a server and a port (if nonstandard).
+ // This is an example configuration for an LDAP preference backend.
+ // The schemas needed for ldap are in horde/scripts/ldap. For more
+@@ -195,7 +195,7 @@
+ // If you want to use SMTP authentication, set the 'auth' parameter
+ // to 'true' (without quotes).
$conf['mailer']['params'] = array();
-// $conf['mailer']['params'] = array('sendmail_path' => '/usr/lib/sendmail');
+// $conf['mailer']['params'] = array('sendmail_path' => '/usr/sbin/sendmail');
// $conf['mailer']['params'] = array('host' => 'smtp.example.com');
-@@ -223,3 +223,9 @@
+@@ -241,3 +241,9 @@
// Should we use DHTML to display a floating menu of Horde appliation
// links, instead of a frame?
$conf['menu']['floating_bar'] = false;
diff --git a/www/horde2/pkg-deinstall b/www/horde2/pkg-deinstall
index 6a75b26f7a23..8352504f3599 100644
--- a/www/horde2/pkg-deinstall
+++ b/www/horde2/pkg-deinstall
@@ -8,6 +8,7 @@ fi
if [ -f ${PKG_PREFIX}/etc/apache/httpd.conf.beforeHorde ] ; then
echo "Restoring httpd.conf..."
cp ${PKG_PREFIX}/etc/apache/httpd.conf ${PKG_PREFIX}/etc/apache/httpd.conf.deinstHorde
- perl -pi -e "s:Include ${PKG_PREFIX}/etc/horde:# Include ${PKG_PREFIX}/etc/horde:g" \
+ sed_inplace -i.tmp -e "s:Include ${PKG_PREFIX}/etc/horde:# Include ${PKG_PREFIX}/etc/horde:g" \
${PKG_PREFIX}/etc/apache/httpd.conf
+ rm ${PKG_PREFIX}/etc/apache/httpd.conf.tmp
fi