aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2001-12-19 20:53:39 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2001-12-19 20:53:39 +0000
commit3c53076356000179a91438038745f2ceba2e11d6 (patch)
tree542e1add18b6b02da575420152d7c537a9525428
parent40118ebaa1bd541d5a3a1c64150d9f9690cc47f2 (diff)
downloadports-3c53076356000179a91438038745f2ceba2e11d6.tar.gz
ports-3c53076356000179a91438038745f2ceba2e11d6.zip
* Take maintainership. The original maintainer has disappeared.
* Update to 1.0.7: lots of bugfixes, some new and updated translations. * Remove questionable LITE flavor.
Notes
Notes: svn path=/head/; revision=51868
-rw-r--r--editors/nano/Makefile17
-rw-r--r--editors/nano/distinfo2
-rw-r--r--editors/nano/files/patch-config.h.in15
-rw-r--r--editors/nano/files/patch-configure14
-rw-r--r--editors/nano/files/patch-proto.h15
-rw-r--r--editors/nano/files/patch-utils.c22
-rw-r--r--editors/nano/pkg-descr14
-rw-r--r--editors/nano/pkg-plist9
-rw-r--r--editors/nano/pkg-plist.nonls4
9 files changed, 83 insertions, 29 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 0ce6add6622e..c01b79cf9a41 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -6,27 +6,20 @@
#
PORTNAME= nano
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.7
CATEGORIES= editors
-MASTER_SITES= http://www.nano-editor.org/dist/v1.0/ \
- http://www.asty.org/nano/dist/ \
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
${MASTER_SITE_GNU} \
- ${MASTER_SITE_SOURCEFORGE}
+ http://www.nano-editor.org/dist/v1.0/
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= nemesis@balistik.net
+MAINTAINER= naddy@FreeBSD.org
LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl"
-
-.if defined(LITE)
-CONFIGURE_ARGS+= --disable-tabcomp --enable-tiny --disable-speller \
- --disable-justify --disable-nls --disable-browser --disable-help
-PLIST= ${PKGDIR}/pkg-plist.nonls
-.endif
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= nano.1
diff --git a/editors/nano/distinfo b/editors/nano/distinfo
index b635fb04c83e..91ef7df07c0e 100644
--- a/editors/nano/distinfo
+++ b/editors/nano/distinfo
@@ -1 +1 @@
-MD5 (nano-1.0.4.tar.gz) = e48f0c030f30ef279cb37c7e046a9b14
+MD5 (nano-1.0.7.tar.gz) = dce4cb0721f6d5533a4bf6b471664d20
diff --git a/editors/nano/files/patch-config.h.in b/editors/nano/files/patch-config.h.in
new file mode 100644
index 000000000000..b7b4a796c888
--- /dev/null
+++ b/editors/nano/files/patch-config.h.in
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- config.h.in.orig Fri Dec 7 06:51:38 2001
++++ config.h.in Tue Dec 18 19:58:04 2001
+@@ -136,6 +136,9 @@
+ /* Define if you have the strcasecmp function. */
+ #undef HAVE_STRCASECMP
+
++/* Define if you have the strcasestr function. */
++#undef HAVE_STRCASESTR
++
+ /* Define if you have the strchr function. */
+ #undef HAVE_STRCHR
+
diff --git a/editors/nano/files/patch-configure b/editors/nano/files/patch-configure
new file mode 100644
index 000000000000..a95e365aea9e
--- /dev/null
+++ b/editors/nano/files/patch-configure
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- configure.orig Wed Dec 19 21:36:45 2001
++++ configure Wed Dec 19 21:37:16 2001
+@@ -2106,7 +2106,7 @@
+
+ fi
+
+-for ac_func in getopt_long
++for ac_func in getopt_long strcasestr
+ do
+ echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
+ echo "configure:2113: checking for $ac_func" >&5
diff --git a/editors/nano/files/patch-proto.h b/editors/nano/files/patch-proto.h
new file mode 100644
index 000000000000..264828d74252
--- /dev/null
+++ b/editors/nano/files/patch-proto.h
@@ -0,0 +1,15 @@
+
+$FreeBSD$
+
+--- proto.h.orig Fri Dec 14 06:57:10 2001
++++ proto.h Tue Dec 18 19:58:04 2001
+@@ -65,7 +65,9 @@
+
+ /* Programs we want available */
+
++#ifndef HAVE_STRCASESTR
+ char *strcasestr(char *haystack, char *needle);
++#endif
+ char *strstrwrapper(char *haystack, char *needle);
+ int search_init(int replacing);
+ int renumber(filestruct * fileptr);
diff --git a/editors/nano/files/patch-utils.c b/editors/nano/files/patch-utils.c
new file mode 100644
index 000000000000..49cdbf43192a
--- /dev/null
+++ b/editors/nano/files/patch-utils.c
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- utils.c.orig Mon Nov 19 03:46:54 2001
++++ utils.c Tue Dec 18 19:58:04 2001
+@@ -47,7 +47,7 @@
+ }
+ }
+
+-
++#ifndef HAVE_STRCASESTR
+ /* This is now mutt's version (called mutt_stristr) because it doesn't
+ use memory allocation to do a simple search (yuck). */
+ char *strcasestr(char *haystack, char *needle)
+@@ -69,6 +69,7 @@
+ }
+ return NULL;
+ }
++#endif
+
+ char *strstrwrapper(char *haystack, char *needle)
+ {
diff --git a/editors/nano/pkg-descr b/editors/nano/pkg-descr
index 20bbe4bcef00..8c856cf82212 100644
--- a/editors/nano/pkg-descr
+++ b/editors/nano/pkg-descr
@@ -1,11 +1,7 @@
-nano was originally known as TIP (TIP Isn't Pico). It is a small, free
-and friendly editor which aims to replace Pico, the default editor
-included in the non-free Pine package. Rather than just copying Pico's
-look and feel, nano also implements some missing (or disabled by
-default) features in Pico, such as "search and replace" and "goto line
-number".
+nano is a small, free and friendly editor which aims to replace
+Pico, the default editor included in the non-free Pine package.
+Rather than just copying Pico's look and feel, nano also implements
+some missing (or disabled by default) features in Pico, such as
+"search and replace" and "goto line number".
WWW: http://www.nano-editor.org/
-
-- Philippe
-nemesis@balistik.net
diff --git a/editors/nano/pkg-plist b/editors/nano/pkg-plist
index 1658fa9e3ac7..0f1538deb95a 100644
--- a/editors/nano/pkg-plist
+++ b/editors/nano/pkg-plist
@@ -1,6 +1,11 @@
+@comment $FreeBSD$
bin/nano
+@unexec install-info --delete %D/info/nano.info %D/info/dir
+info/nano.info
+@exec install-info %D/info/nano.info %D/info/dir
share/locale/ca/LC_MESSAGES/nano.mo
share/locale/cs/LC_MESSAGES/nano.mo
+share/locale/da/LC_MESSAGES/nano.mo
share/locale/de/LC_MESSAGES/nano.mo
share/locale/es/LC_MESSAGES/nano.mo
share/locale/fi/LC_MESSAGES/nano.mo
@@ -9,10 +14,8 @@ share/locale/gl/LC_MESSAGES/nano.mo
share/locale/hu/LC_MESSAGES/nano.mo
share/locale/id/LC_MESSAGES/nano.mo
share/locale/it/LC_MESSAGES/nano.mo
+share/locale/nl/LC_MESSAGES/nano.mo
share/locale/no/LC_MESSAGES/nano.mo
share/locale/ru/LC_MESSAGES/nano.mo
share/locale/sv/LC_MESSAGES/nano.mo
share/locale/uk/LC_MESSAGES/nano.mo
-@unexec install-info --delete %D/info/nano.info %D/info/dir
-info/nano.info
-@exec install-info %D/info/nano.info %D/info/dir
diff --git a/editors/nano/pkg-plist.nonls b/editors/nano/pkg-plist.nonls
deleted file mode 100644
index 71fbe2dad295..000000000000
--- a/editors/nano/pkg-plist.nonls
+++ /dev/null
@@ -1,4 +0,0 @@
-bin/nano
-@unexec install-info --delete %D/info/nano.info %D/info/dir
-info/nano.info
-@exec install-info %D/info/nano.info %D/info/dir