aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2011-08-14 11:45:37 +0000
committerGabor Pali <pgj@FreeBSD.org>2011-08-14 11:45:37 +0000
commit55c7cc395e8229f098949a15b51ac7987d2bbad1 (patch)
treefb9eb0bed572304741270226cc5c3b4117e7cad3
parentf1f3359643d3f337434cf56a35ce41e82dda7127 (diff)
downloadports-55c7cc395e8229f098949a15b51ac7987d2bbad1.tar.gz
ports-55c7cc395e8229f098949a15b51ac7987d2bbad1.zip
Haskell 98 pointed and copointed data.
WWW: http://github.com/ekmett/copointed/ Obtained from: FreeBSD Haskell
Notes
Notes: svn path=/head/; revision=279695
-rw-r--r--lang/ghc/bsd.hackage.mk1
-rw-r--r--math/Makefile1
-rw-r--r--math/hs-pointed/Makefile22
-rw-r--r--math/hs-pointed/distinfo2
-rw-r--r--math/hs-pointed/files/patch-pointed.cabal11
-rw-r--r--math/hs-pointed/pkg-descr3
6 files changed, 40 insertions, 0 deletions
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 770f2fe88eeb..6aa69b5c4b39 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -137,6 +137,7 @@ parsec_port= textproc/hs-parsec
pcap_port= net/hs-pcap
pcre-light_port= devel/hs-pcre-light # lib_depends
polyparse_port= textproc/hs-polyparse
+pointed_port= math/hs-pointed
porte_port= ports-mgmt/hs-porte # executable
primitive_port= devel/hs-primitive
probability_port= math/hs-probability
diff --git a/math/Makefile b/math/Makefile
index 60dee10f4851..268738ba80e3 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -131,6 +131,7 @@
SUBDIR += hs-distributive
SUBDIR += hs-erf
SUBDIR += hs-mwc-random
+ SUBDIR += hs-pointed
SUBDIR += hs-probability
SUBDIR += hs-semigroupoids
SUBDIR += hs-semigroups
diff --git a/math/hs-pointed/Makefile b/math/hs-pointed/Makefile
new file mode 100644
index 000000000000..daa16441ab9a
--- /dev/null
+++ b/math/hs-pointed/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: hs-pointed
+# Date created: July 16, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pointed
+PORTVERSION= 2.0
+CATEGORIES= math haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Haskell 98 pointed and copointed data
+
+LICENSE= BSD
+
+USE_CABAL= comonad>=1.1.1 comonad-transformers>=2.0 data-default>=0.2.0.1 \
+ semigroupoids>=1.2.4 semigroups>=0.7.1 stm>=2.1.2.1 \
+ transformers>=0.2.0
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/math/hs-pointed/distinfo b/math/hs-pointed/distinfo
new file mode 100644
index 000000000000..7752518127ea
--- /dev/null
+++ b/math/hs-pointed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/pointed-2.0.tar.gz) = 446f9096185e9b110caf9bdcfae738a2c43b28ee1cfc872c363a9ef67b36382e
+SIZE (cabal/pointed-2.0.tar.gz) = 2953
diff --git a/math/hs-pointed/files/patch-pointed.cabal b/math/hs-pointed/files/patch-pointed.cabal
new file mode 100644
index 000000000000..fbd9ad4d0d72
--- /dev/null
+++ b/math/hs-pointed/files/patch-pointed.cabal
@@ -0,0 +1,11 @@
+--- ./pointed.cabal.orig 2011-08-04 22:03:15.000000000 +0200
++++ ./pointed.cabal 2011-08-13 12:29:45.000000000 +0200
+@@ -22,7 +22,7 @@
+ base >= 4 && < 5,
+ transformers >= 0.2.0 && < 0.3,
+ containers >= 0.4.0.0 && < 0.5,
+- data-default >= 0.2.0.1 && < 0.3,
++ data-default >= 0.2.0.1,
+ comonad >= 1.1.1 && < 1.2,
+ semigroups >= 0.7.1 && < 0.8,
+ semigroupoids >= 1.2.4 && < 1.3,
diff --git a/math/hs-pointed/pkg-descr b/math/hs-pointed/pkg-descr
new file mode 100644
index 000000000000..0cba93e0d507
--- /dev/null
+++ b/math/hs-pointed/pkg-descr
@@ -0,0 +1,3 @@
+Haskell 98 pointed and copointed data.
+
+WWW: http://github.com/ekmett/copointed/