aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-07-05 12:21:06 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-07-05 12:21:06 +0000
commit640070333d03dbd4f2f5e3b2ba0e8f2bc5451c85 (patch)
treef3eb9f88100ad5cd3afc29446e3c83dc9c81ff0a
parente79389466a52f5cefbdd19a6c832096120e486c5 (diff)
downloadports-640070333d03dbd4f2f5e3b2ba0e8f2bc5451c85.tar.gz
ports-640070333d03dbd4f2f5e3b2ba0e8f2bc5451c85.zip
Force -O2 in CFLAGS to fix runtime in -CURRENT
Notes
Notes: svn path=/head/; revision=195009
-rw-r--r--audio/gstreamer-plugins-fluendo-mp3/Makefile1
-rw-r--r--audio/gstreamer-plugins-moodbar/Makefile1
-rw-r--r--multimedia/gstreamer-plugins-fluendo-mpegdemux/Makefile1
-rw-r--r--multimedia/gstreamer-plugins-gnonlin/Makefile1
4 files changed, 4 insertions, 0 deletions
diff --git a/audio/gstreamer-plugins-fluendo-mp3/Makefile b/audio/gstreamer-plugins-fluendo-mp3/Makefile
index 5fa1ca97bc39..28dc7121df84 100644
--- a/audio/gstreamer-plugins-fluendo-mp3/Makefile
+++ b/audio/gstreamer-plugins-fluendo-mp3/Makefile
@@ -14,6 +14,7 @@ DISTNAME= gst-fluendo-mp3-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Mp3 gstreamer plugin from fluendo
+CFLAGS:= ${CFLAGS} -O2
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
PLIST_FILES= lib/gstreamer-0.10/libgstflump3dec.a \
diff --git a/audio/gstreamer-plugins-moodbar/Makefile b/audio/gstreamer-plugins-moodbar/Makefile
index 19266b7d3bb8..65e4eb1f4d1f 100644
--- a/audio/gstreamer-plugins-moodbar/Makefile
+++ b/audio/gstreamer-plugins-moodbar/Makefile
@@ -19,6 +19,7 @@ COMMENT= Shows the "moods" of audio tracks in Amarok
LIB_DEPENDS= fftw3f:${PORTSDIR}/math/fftw3-float \
fftw3:${PORTSDIR}/math/fftw3
+CFLAGS:= ${CFLAGS} -O2
USE_GSTREAMER= yes good
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
diff --git a/multimedia/gstreamer-plugins-fluendo-mpegdemux/Makefile b/multimedia/gstreamer-plugins-fluendo-mpegdemux/Makefile
index 0208d8a5a022..df2be38d65fe 100644
--- a/multimedia/gstreamer-plugins-fluendo-mpegdemux/Makefile
+++ b/multimedia/gstreamer-plugins-fluendo-mpegdemux/Makefile
@@ -14,6 +14,7 @@ DISTNAME= gst-fluendo-mpegdemux-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= MPEG2 demuxing gstreamer plugin from fluendo
+CFLAGS:= ${CFLAGS} -O2
USE_GSTREAMER= yes
GNU_CONFIGURE= yes
PLIST_FILES= lib/gstreamer-0.10/libgstflumpegdemux.a \
diff --git a/multimedia/gstreamer-plugins-gnonlin/Makefile b/multimedia/gstreamer-plugins-gnonlin/Makefile
index ca1b7ede8642..f0bbd0e174e2 100644
--- a/multimedia/gstreamer-plugins-gnonlin/Makefile
+++ b/multimedia/gstreamer-plugins-gnonlin/Makefile
@@ -15,6 +15,7 @@ DISTNAME= gnonlin-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Gstreamer lib for writing non-linear audio and video
+CFLAGS:= ${CFLAGS} -O2
USE_BZIP2= yes
USE_GNOME= gnometarget
GNU_CONFIGURE= yes