aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-07-26 21:20:37 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-07-26 21:20:37 +0000
commit690acbda3d3b9fc24fe3c367e980ce829f86daee (patch)
tree19b654b48e5e1afe283f71d5aedcc226ec7890ab
parent9b478cbcd6dd76c545ab52486162de804607359b (diff)
downloadports-690acbda3d3b9fc24fe3c367e980ce829f86daee.tar.gz
ports-690acbda3d3b9fc24fe3c367e980ce829f86daee.zip
Add postgresql-plproxy 2.0.2, PL/Proxy is database partitioning system.
Notes
Notes: svn path=/head/; revision=196341
-rw-r--r--databases/Makefile1
-rw-r--r--databases/postgresql-plproxy/Makefile26
-rw-r--r--databases/postgresql-plproxy/distinfo3
-rw-r--r--databases/postgresql-plproxy/pkg-descr8
-rw-r--r--databases/postgresql-plproxy/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 3e8599c44c25..8861a9533af1 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -390,6 +390,7 @@
SUBDIR += postgresql-libpq++
SUBDIR += postgresql-libpqxx
SUBDIR += postgresql-odbc
+ SUBDIR += postgresql-plproxy
SUBDIR += postgresql-plpython
SUBDIR += postgresql-plruby
SUBDIR += postgresql-pltcl
diff --git a/databases/postgresql-plproxy/Makefile b/databases/postgresql-plproxy/Makefile
new file mode 100644
index 000000000000..742000543b02
--- /dev/null
+++ b/databases/postgresql-plproxy/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: postgresql-plproxy
+# Date created: 27 July 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plproxy
+PORTVERSION= 2.0.2
+CATEGORIES= databases
+MASTER_SITES= http://pgfoundry.org/frs/download.php/1355/
+PKGNAMEPREFIX= postgresql-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= PL/Proxy is database partitioning system
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+
+USE_PGSQL= yes
+USE_GMAKE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's= flex= ${LOCALBASE}/bin/flex=g' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/databases/postgresql-plproxy/distinfo b/databases/postgresql-plproxy/distinfo
new file mode 100644
index 000000000000..b1d64489ad53
--- /dev/null
+++ b/databases/postgresql-plproxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (plproxy-2.0.2.tar.gz) = 44fe7112d9a41befdb601691e00df661
+SHA256 (plproxy-2.0.2.tar.gz) = 3dc89d21093580607da033b877e5dc524a9b1cb7a93fb2c457b3cb4dea906a25
+SIZE (plproxy-2.0.2.tar.gz) = 30068
diff --git a/databases/postgresql-plproxy/pkg-descr b/databases/postgresql-plproxy/pkg-descr
new file mode 100644
index 000000000000..3989f4f394e3
--- /dev/null
+++ b/databases/postgresql-plproxy/pkg-descr
@@ -0,0 +1,8 @@
+PL/Proxy is a proxy language used for remote database procedure calls
+and data partitioning between databases based on hashing field values.
+
+Main idea is that proxy function will be created with same signature as
+remote function to be called, so only destination info needs to be
+specified inside proxy function body.
+
+WWW: https://developer.skype.com/SkypeGarage/DbProjects/PlProxy
diff --git a/databases/postgresql-plproxy/pkg-plist b/databases/postgresql-plproxy/pkg-plist
new file mode 100644
index 000000000000..959167123322
--- /dev/null
+++ b/databases/postgresql-plproxy/pkg-plist
@@ -0,0 +1,5 @@
+lib/postgresql/plproxy.so
+share/postgresql/contrib/plproxy.sql
+@dirrmtry lib/postgresql
+@dirrmtry share/postgresql/contrib
+@dirrmtry share/postgresql