aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-09-08 12:24:00 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-09-08 12:24:00 +0000
commit78bbc51a8841b41205392bbb2614b424f4c0c31b (patch)
tree90563279b6bc43e0f927347ff28a6a9866a3c634
parent6cf52798edb4b5a143043663582f0658d45437da (diff)
downloadports-78bbc51a8841b41205392bbb2614b424f4c0c31b.tar.gz
ports-78bbc51a8841b41205392bbb2614b424f4c0c31b.zip
Don't break package building on Satoshi's cluster. Explicitly depend
on python1.5:lang/python15.
Notes
Notes: svn path=/head/; revision=32438
-rw-r--r--audio/pysol-sound-server/Makefile4
-rw-r--r--biology/py-biopython/Makefile2
-rw-r--r--databases/gadfly/Makefile4
-rw-r--r--databases/metakit/Makefile4
-rw-r--r--databases/py-MySQL/Makefile4
-rw-r--r--databases/py-MySQLdb-devel/Makefile4
-rw-r--r--databases/py-MySQLdb/Makefile4
-rw-r--r--databases/py-PyGreSQL/Makefile4
-rw-r--r--devel/newt/Makefile2
-rw-r--r--devel/py-coro/Makefile4
-rw-r--r--devel/py-htmlkit/Makefile2
-rw-r--r--devel/py-kjbuckets/Makefile4
-rw-r--r--devel/py-kqueue/Makefile4
-rw-r--r--devel/py-mxDateTime/Makefile4
-rw-r--r--devel/py-mxStack/Makefile4
-rw-r--r--devel/py-mxTools/Makefile4
-rw-r--r--devel/veepee/Makefile4
-rw-r--r--graphics/piddle/Makefile2
-rw-r--r--graphics/py-opengl/Makefile4
-rw-r--r--lang/py-mx-base/Makefile4
-rw-r--r--math/py-gnuplot/Makefile4
-rw-r--r--net/ldapmodule/Makefile4
-rw-r--r--net/py-ldap1/Makefile4
-rw-r--r--net/py-ldap2/Makefile4
-rw-r--r--textproc/py-mxTextTools/Makefile4
-rw-r--r--textproc/py-xml/Makefile2
-rw-r--r--www/evg/Makefile2
-rw-r--r--x11-toolkits/py-gnome/Makefile4
-rw-r--r--x11-toolkits/py-gnome2/Makefile4
-rw-r--r--x11-toolkits/py-gtk/Makefile4
-rw-r--r--x11-toolkits/py-gtk2/Makefile4
-rw-r--r--x11-toolkits/py-wxPython/Makefile4
-rw-r--r--x11-toolkits/py-wxPython24/Makefile4
-rw-r--r--x11-toolkits/py-wxPython26/Makefile4
-rw-r--r--x11-toolkits/py-wxPython28/Makefile4
35 files changed, 64 insertions, 64 deletions
diff --git a/audio/pysol-sound-server/Makefile b/audio/pysol-sound-server/Makefile
index 6f005d59e912..46c8a42a5c9f 100644
--- a/audio/pysol-sound-server/Makefile
+++ b/audio/pysol-sound-server/Makefile
@@ -12,11 +12,11 @@ MASTER_SITES= http://wildsau.idv.uni-linz.ac.at/mfx/download/pysol/pysol-sound-s
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel \
smpeg.0:${PORTSDIR}/graphics/smpeg \
SDL_mixer.2:${PORTSDIR}/audio/sdl_mixer
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
WRKSRC= ${WRKDIR}/${DISTNAME}/src
HAS_CONFIGURE= yes
diff --git a/biology/py-biopython/Makefile b/biology/py-biopython/Makefile
index 2234286127be..9f7e08642cba 100644
--- a/biology/py-biopython/Makefile
+++ b/biology/py-biopython/Makefile
@@ -14,7 +14,7 @@ DISTNAME= biopython-0.90-d02
MAINTAINER= johann@egenetics.com
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15 \
${LOCALBASE}/lib/python1.5/site-packages/Numeric/Numeric.py:${PORTSDIR}/math/numpy \
${LOCALBASE}/lib/python1.5/site-packages/distutils/core.py:${PORTSDIR}/misc/py-distutils
diff --git a/databases/gadfly/Makefile b/databases/gadfly/Makefile
index d6b607396ab4..2733d2bf6b59 100644
--- a/databases/gadfly/Makefile
+++ b/databases/gadfly/Makefile
@@ -13,8 +13,8 @@ DISTNAME= kwP
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
NO_WRKSUBDIR= yes
diff --git a/databases/metakit/Makefile b/databases/metakit/Makefile
index 90e5569c4822..840ac21ae228 100644
--- a/databases/metakit/Makefile
+++ b/databases/metakit/Makefile
@@ -13,8 +13,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= rcarter@pinyon.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
WRKSRC= ${WRKDIR}/${DISTNAME}/builds
diff --git a/databases/py-MySQL/Makefile b/databases/py-MySQL/Makefile
index 8d40deca15e4..92090c2c3719 100644
--- a/databases/py-MySQL/Makefile
+++ b/databases/py-MySQL/Makefile
@@ -13,9 +13,9 @@ DISTNAME= MySQLmodule-${PORTVERSION}
MAINTAINER= dr@domix.de
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
ALL_TARGET= MySQLmodule.so
diff --git a/databases/py-MySQLdb-devel/Makefile b/databases/py-MySQLdb-devel/Makefile
index b3d983747f6b..068a1abd69dd 100644
--- a/databases/py-MySQLdb-devel/Makefile
+++ b/databases/py-MySQLdb-devel/Makefile
@@ -13,9 +13,9 @@ DISTNAME= MySQLdb-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
FETCH_BEFORE_ARGS= -b
ALL_TARGET= _mysqlmodule.o
diff --git a/databases/py-MySQLdb/Makefile b/databases/py-MySQLdb/Makefile
index b3d983747f6b..068a1abd69dd 100644
--- a/databases/py-MySQLdb/Makefile
+++ b/databases/py-MySQLdb/Makefile
@@ -13,9 +13,9 @@ DISTNAME= MySQLdb-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= mysqlclient.6:${PORTSDIR}/databases/mysql322-client
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
FETCH_BEFORE_ARGS= -b
ALL_TARGET= _mysqlmodule.o
diff --git a/databases/py-PyGreSQL/Makefile b/databases/py-PyGreSQL/Makefile
index 6dc0f6aecada..f2babb0faebc 100644
--- a/databases/py-PyGreSQL/Makefile
+++ b/databases/py-PyGreSQL/Makefile
@@ -14,8 +14,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= nectar@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= pq.2:${PORTSDIR}/databases/postgresql7
MAKE_ENV= PYTHON=${PREFIX}/bin/python \
diff --git a/devel/newt/Makefile b/devel/newt/Makefile
index 629de27a61ba..0e8037f0f9b5 100644
--- a/devel/newt/Makefile
+++ b/devel/newt/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang \
tcl82.1:${PORTSDIR}/lang/tcl82 \
popt.0:${PORTSDIR}/devel/popt
BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/misc/rpm \
- python:${PORTSDIR}/lang/python
+ python1.5:${PORTSDIR}/lang/python15
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/devel/py-coro/Makefile b/devel/py-coro/Makefile
index d229e39ca70e..c5d4fc385aa2 100644
--- a/devel/py-coro/Makefile
+++ b/devel/py-coro/Makefile
@@ -15,8 +15,8 @@ DISTNAME= egp-coro-20000424
MAINTAINER= kbyanc@posi.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libcoro.a:${PORTSDIR}/devel/libcoro \
- python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+ python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
CORO_MODULES= coroutinemodule.so sendfilemodule.so
CORO_PACKAGE= coro corodns coromysql corourl \
diff --git a/devel/py-htmlkit/Makefile b/devel/py-htmlkit/Makefile
index eb1e5a4b16de..5719156bfc10 100644
--- a/devel/py-htmlkit/Makefile
+++ b/devel/py-htmlkit/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tar
MAINTAINER= kbyanc@posi.net
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
NO_BUILD= yes
diff --git a/devel/py-kjbuckets/Makefile b/devel/py-kjbuckets/Makefile
index 7faccf1767a1..d69e12232331 100644
--- a/devel/py-kjbuckets/Makefile
+++ b/devel/py-kjbuckets/Makefile
@@ -14,8 +14,8 @@ DISTNAME= kjb
MAINTAINER= nectar@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
NO_WRKSUBDIR= yes
MAKEFILE= makefile
diff --git a/devel/py-kqueue/Makefile b/devel/py-kqueue/Makefile
index 36a7dad703db..05d1b306a5bb 100644
--- a/devel/py-kqueue/Makefile
+++ b/devel/py-kqueue/Makefile
@@ -15,8 +15,8 @@ DISTNAME= PyKQueue-${PORTVERSION}
MAINTAINER= dwhite@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
.include <bsd.port.pre.mk>
diff --git a/devel/py-mxDateTime/Makefile b/devel/py-mxDateTime/Makefile
index ea777d5c5ea6..c85ca79f26e7 100644
--- a/devel/py-mxDateTime/Makefile
+++ b/devel/py-mxDateTime/Makefile
@@ -13,8 +13,8 @@ PKGNAMEPREFIX= py-
MAINTAINER= tg@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
diff --git a/devel/py-mxStack/Makefile b/devel/py-mxStack/Makefile
index cc921dcd9472..ddb18f79f136 100644
--- a/devel/py-mxStack/Makefile
+++ b/devel/py-mxStack/Makefile
@@ -13,8 +13,8 @@ PKGNAMEPREFIX= py-
MAINTAINER= tg@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
diff --git a/devel/py-mxTools/Makefile b/devel/py-mxTools/Makefile
index 47e636a82d5b..3509a8824ba5 100644
--- a/devel/py-mxTools/Makefile
+++ b/devel/py-mxTools/Makefile
@@ -13,8 +13,8 @@ PKGNAMEPREFIX= py-
MAINTAINER= tg@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
diff --git a/devel/veepee/Makefile b/devel/veepee/Makefile
index d794cf4f1a03..6be428bfb5e9 100644
--- a/devel/veepee/Makefile
+++ b/devel/veepee/Makefile
@@ -13,10 +13,10 @@ DISTNAME= VeePee-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
gd.1:${PORTSDIR}/graphics/gd
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
USE_XLIB= yes
USE_LIBTOOL= yes
diff --git a/graphics/piddle/Makefile b/graphics/piddle/Makefile
index 73e82b689496..6804f65506ea 100644
--- a/graphics/piddle/Makefile
+++ b/graphics/piddle/Makefile
@@ -15,7 +15,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dom@myrddin.demon.co.uk
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
WRKSRC= ${WRKDIR}/${PKGNAME}
NO_BUILD= yes
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index 28210e38e692..f6f8536a2592 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -15,9 +15,9 @@ DISTNAME= PyOpenGL-${PORTVERSION}
MAINTAINER= aa8vb@ipass.net
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python \
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15 \
${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy
-RUN_DEPENDS= python:${PORTSDIR}/lang/python \
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15 \
${NUMPYDIR}/Numeric.py:${PORTSDIR}/math/numpy
USE_MESA= yes
diff --git a/lang/py-mx-base/Makefile b/lang/py-mx-base/Makefile
index 9b573bbd2e3d..ed19b4ed4077 100644
--- a/lang/py-mx-base/Makefile
+++ b/lang/py-mx-base/Makefile
@@ -13,8 +13,8 @@ DISTNAME= mxTextTools-1.1.1
MAINTAINER= tg@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
diff --git a/math/py-gnuplot/Makefile b/math/py-gnuplot/Makefile
index 94bd8b6257c5..bdfae5e376a6 100644
--- a/math/py-gnuplot/Makefile
+++ b/math/py-gnuplot/Makefile
@@ -13,8 +13,8 @@ DISTNAME= Gnuplot-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python \
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15 \
gnuplot:${PORTSDIR}/math/gnuplot \
${LOCALBASE}/lib/python1.5/site-packages/Numeric/_numpy.so:${PORTSDIR}/math/numpy
diff --git a/net/ldapmodule/Makefile b/net/ldapmodule/Makefile
index c68f756ae62e..a019d4ab7b19 100644
--- a/net/ldapmodule/Makefile
+++ b/net/ldapmodule/Makefile
@@ -13,8 +13,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha
MAINTAINER= dirk.meyer@dinoex.sub.org
LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
diff --git a/net/py-ldap1/Makefile b/net/py-ldap1/Makefile
index c68f756ae62e..a019d4ab7b19 100644
--- a/net/py-ldap1/Makefile
+++ b/net/py-ldap1/Makefile
@@ -13,8 +13,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha
MAINTAINER= dirk.meyer@dinoex.sub.org
LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
diff --git a/net/py-ldap2/Makefile b/net/py-ldap2/Makefile
index c68f756ae62e..a019d4ab7b19 100644
--- a/net/py-ldap2/Makefile
+++ b/net/py-ldap2/Makefile
@@ -13,8 +13,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha
MAINTAINER= dirk.meyer@dinoex.sub.org
LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
diff --git a/textproc/py-mxTextTools/Makefile b/textproc/py-mxTextTools/Makefile
index 9b573bbd2e3d..ed19b4ed4077 100644
--- a/textproc/py-mxTextTools/Makefile
+++ b/textproc/py-mxTextTools/Makefile
@@ -13,8 +13,8 @@ DISTNAME= mxTextTools-1.1.1
MAINTAINER= tg@FreeBSD.org
-BUILD_DEPENDS= python:${PORTSDIR}/lang/python
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
diff --git a/textproc/py-xml/Makefile b/textproc/py-xml/Makefile
index d397b8f54347..c927980dc2b3 100644
--- a/textproc/py-xml/Makefile
+++ b/textproc/py-xml/Makefile
@@ -17,7 +17,7 @@ DISTNAME= PyXML-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/python1.5/site-packages/distutils/core.py:${PORTSDIR}/misc/py-distutils
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
PLIST= ${WRKDIR}/PLIST
diff --git a/www/evg/Makefile b/www/evg/Makefile
index 7915e2de8d19..315fdf399026 100644
--- a/www/evg/Makefile
+++ b/www/evg/Makefile
@@ -14,7 +14,7 @@ DISTNAME= evg-1.01
MAINTAINER= dima@Chg.RU
-RUN_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS+= xv:${PORTSDIR}/graphics/xv
diff --git a/x11-toolkits/py-gnome/Makefile b/x11-toolkits/py-gnome/Makefile
index 9ab7fdd095a7..57a1cb6146ce 100644
--- a/x11-toolkits/py-gnome/Makefile
+++ b/x11-toolkits/py-gnome/Makefile
@@ -14,11 +14,11 @@ DISTNAME= gnome-python-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.org
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python ${PYGTK_DEP}
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15 ${PYGTK_DEP}
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
capplet.4:${PORTSDIR}/sysutils/gnomecontrolcenter \
panel_applet.4:${PORTSDIR}/x11/gnomecore
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python ${PYGTK_DEP}
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15 ${PYGTK_DEP}
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
diff --git a/x11-toolkits/py-gnome2/Makefile b/x11-toolkits/py-gnome2/Makefile
index 9ab7fdd095a7..57a1cb6146ce 100644
--- a/x11-toolkits/py-gnome2/Makefile
+++ b/x11-toolkits/py-gnome2/Makefile
@@ -14,11 +14,11 @@ DISTNAME= gnome-python-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.org
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python ${PYGTK_DEP}
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15 ${PYGTK_DEP}
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
capplet.4:${PORTSDIR}/sysutils/gnomecontrolcenter \
panel_applet.4:${PORTSDIR}/x11/gnomecore
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python ${PYGTK_DEP}
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15 ${PYGTK_DEP}
GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
diff --git a/x11-toolkits/py-gtk/Makefile b/x11-toolkits/py-gtk/Makefile
index d00e043ba430..4aa8b76312c2 100644
--- a/x11-toolkits/py-gtk/Makefile
+++ b/x11-toolkits/py-gtk/Makefile
@@ -14,10 +14,10 @@ DISTNAME= gnome-python-1.0.53
MAINTAINER= nectar@FreeBSD.org
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.5:${PORTSDIR}/graphics/imlib
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
GTK_CONFIG= ${X11BASE}/bin/gtk12-config
USE_GMAKE= yes
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index d00e043ba430..4aa8b76312c2 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -14,10 +14,10 @@ DISTNAME= gnome-python-1.0.53
MAINTAINER= nectar@FreeBSD.org
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
Imlib.5:${PORTSDIR}/graphics/imlib
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
GTK_CONFIG= ${X11BASE}/bin/gtk12-config
USE_GMAKE= yes
diff --git a/x11-toolkits/py-wxPython/Makefile b/x11-toolkits/py-wxPython/Makefile
index f38924852e10..25a07c166758 100644
--- a/x11-toolkits/py-wxPython/Makefile
+++ b/x11-toolkits/py-wxPython/Makefile
@@ -13,9 +13,9 @@ DISTNAME= wxPython-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.ORG
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
WRKSRC= ${WRKDIR}/${DISTNAME}/src
diff --git a/x11-toolkits/py-wxPython24/Makefile b/x11-toolkits/py-wxPython24/Makefile
index f38924852e10..25a07c166758 100644
--- a/x11-toolkits/py-wxPython24/Makefile
+++ b/x11-toolkits/py-wxPython24/Makefile
@@ -13,9 +13,9 @@ DISTNAME= wxPython-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.ORG
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
WRKSRC= ${WRKDIR}/${DISTNAME}/src
diff --git a/x11-toolkits/py-wxPython26/Makefile b/x11-toolkits/py-wxPython26/Makefile
index f38924852e10..25a07c166758 100644
--- a/x11-toolkits/py-wxPython26/Makefile
+++ b/x11-toolkits/py-wxPython26/Makefile
@@ -13,9 +13,9 @@ DISTNAME= wxPython-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.ORG
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
WRKSRC= ${WRKDIR}/${DISTNAME}/src
diff --git a/x11-toolkits/py-wxPython28/Makefile b/x11-toolkits/py-wxPython28/Makefile
index f38924852e10..25a07c166758 100644
--- a/x11-toolkits/py-wxPython28/Makefile
+++ b/x11-toolkits/py-wxPython28/Makefile
@@ -13,9 +13,9 @@ DISTNAME= wxPython-${PORTVERSION}
MAINTAINER= nectar@FreeBSD.ORG
-BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python1.5:${PORTSDIR}/lang/python15
LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
-RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python
+RUN_DEPENDS= python1.5:${PORTSDIR}/lang/python15
WRKSRC= ${WRKDIR}/${DISTNAME}/src