aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrank J. Laszlo <laszlof@FreeBSD.org>2006-11-10 14:15:44 +0000
committerFrank J. Laszlo <laszlof@FreeBSD.org>2006-11-10 14:15:44 +0000
commit93db167ac1280a9c77f7ef31dadea4ade00c45a0 (patch)
treea9e692482aedd6e5582aa6b3a3eadefc6be7e838
parent7eccf49bc2f74dac89d2d4a5c357f64c044ddad3 (diff)
downloadports-93db167ac1280a9c77f7ef31dadea4ade00c45a0.tar.gz
ports-93db167ac1280a9c77f7ef31dadea4ade00c45a0.zip
New Port: www/mod_security2
ModSecurity is an embeddable web application firewall. It provides protection from a range of attacks against web applications and allows for HTTP traffic monitoring and real-time analysis with no changes to existing infrastructure. It is also an open source project that aims to make the web application firewall technology available to everyone. WWW: http://www.modsecurity.org/ This port will only work with Apache 2.x, this is why it is a new port, and not an upgrade of the existing www/mod_security. PR: ports/105339 Submitted By: Dominic Mitchell <dom@happygiraffe.net> Approved By: flz (mentor)
Notes
Notes: svn path=/head/; revision=176998
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_security2/Makefile39
-rw-r--r--www/mod_security2/distinfo3
-rw-r--r--www/mod_security2/pkg-descr9
-rw-r--r--www/mod_security21/Makefile39
-rw-r--r--www/mod_security21/distinfo3
-rw-r--r--www/mod_security21/pkg-descr9
7 files changed, 103 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b20040d32cff..0b5a73bfa909 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -380,6 +380,7 @@
SUBDIR += mod_ruby
SUBDIR += mod_scgi
SUBDIR += mod_security
+ SUBDIR += mod_security2
SUBDIR += mod_sed
SUBDIR += mod_sequester
SUBDIR += mod_shapvh
diff --git a/www/mod_security2/Makefile b/www/mod_security2/Makefile
new file mode 100644
index 000000000000..a94d3c8cf9a6
--- /dev/null
+++ b/www/mod_security2/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_security2
+# Date created: 9 November 2006
+# Whom: Dominic Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_security
+PORTVERSION= 2.0.3
+CATEGORIES= www security
+MASTER_SITES= http://www.modsecurity.org/download/
+DISTNAME= ${PORTNAME:S/_//}-apache_${PORTVERSION}
+
+MAINTAINER= dom@happygiraffe.net
+COMMENT= An intrusion detection and prevention engine
+
+USE_APACHE= 2.0+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+WRKSRCTOP= ${WRKDIR}/${DISTNAME}
+WRKSRC= ${WRKSRCTOP}/apache2
+SRC_FILE= *.c
+PORTDOCS= *
+DOCS= CHANGES LICENSE README.TXT modsecurity.conf-minimal doc
+
+.if defined(WITH_LIBXML2)
+AP_EXTRAS+= -DWITH_LIBXML2
+AP_INC= ${LOCALBASE}/include/libxml2
+AP_LIB= ${LOCALBASE}/lib
+USE_GNOME= libxml2
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRCTOP} && ${TAR} cf - ${DOCS}) | (cd ${DOCSDIR} && ${TAR} xpof -)
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_security2/distinfo b/www/mod_security2/distinfo
new file mode 100644
index 000000000000..23504709f521
--- /dev/null
+++ b/www/mod_security2/distinfo
@@ -0,0 +1,3 @@
+MD5 (modsecurity-apache_2.0.3.tar.gz) = 7993fd01121c6562cc4e3829ba343f94
+SHA256 (modsecurity-apache_2.0.3.tar.gz) = dcf0c70ab6fc0326e03666acb006f92b59434787881f7c220e30e7519dbb417f
+SIZE (modsecurity-apache_2.0.3.tar.gz) = 302451
diff --git a/www/mod_security2/pkg-descr b/www/mod_security2/pkg-descr
new file mode 100644
index 000000000000..91757c63af8d
--- /dev/null
+++ b/www/mod_security2/pkg-descr
@@ -0,0 +1,9 @@
+ModSecurity is an embeddable web application firewall. It provides
+protection from a range of attacks against web applications and allows
+for HTTP traffic monitoring and real-time analysis with no changes to
+existing infrastructure.
+
+It is also an open source project that aims to make the web application
+firewall technology available to everyone.
+
+WWW: http://www.modsecurity.org/
diff --git a/www/mod_security21/Makefile b/www/mod_security21/Makefile
new file mode 100644
index 000000000000..a94d3c8cf9a6
--- /dev/null
+++ b/www/mod_security21/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_security2
+# Date created: 9 November 2006
+# Whom: Dominic Mitchell <dom@happygiraffe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_security
+PORTVERSION= 2.0.3
+CATEGORIES= www security
+MASTER_SITES= http://www.modsecurity.org/download/
+DISTNAME= ${PORTNAME:S/_//}-apache_${PORTVERSION}
+
+MAINTAINER= dom@happygiraffe.net
+COMMENT= An intrusion detection and prevention engine
+
+USE_APACHE= 2.0+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+WRKSRCTOP= ${WRKDIR}/${DISTNAME}
+WRKSRC= ${WRKSRCTOP}/apache2
+SRC_FILE= *.c
+PORTDOCS= *
+DOCS= CHANGES LICENSE README.TXT modsecurity.conf-minimal doc
+
+.if defined(WITH_LIBXML2)
+AP_EXTRAS+= -DWITH_LIBXML2
+AP_INC= ${LOCALBASE}/include/libxml2
+AP_LIB= ${LOCALBASE}/lib
+USE_GNOME= libxml2
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRCTOP} && ${TAR} cf - ${DOCS}) | (cd ${DOCSDIR} && ${TAR} xpof -)
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_security21/distinfo b/www/mod_security21/distinfo
new file mode 100644
index 000000000000..23504709f521
--- /dev/null
+++ b/www/mod_security21/distinfo
@@ -0,0 +1,3 @@
+MD5 (modsecurity-apache_2.0.3.tar.gz) = 7993fd01121c6562cc4e3829ba343f94
+SHA256 (modsecurity-apache_2.0.3.tar.gz) = dcf0c70ab6fc0326e03666acb006f92b59434787881f7c220e30e7519dbb417f
+SIZE (modsecurity-apache_2.0.3.tar.gz) = 302451
diff --git a/www/mod_security21/pkg-descr b/www/mod_security21/pkg-descr
new file mode 100644
index 000000000000..91757c63af8d
--- /dev/null
+++ b/www/mod_security21/pkg-descr
@@ -0,0 +1,9 @@
+ModSecurity is an embeddable web application firewall. It provides
+protection from a range of attacks against web applications and allows
+for HTTP traffic monitoring and real-time analysis with no changes to
+existing infrastructure.
+
+It is also an open source project that aims to make the web application
+firewall technology available to everyone.
+
+WWW: http://www.modsecurity.org/