aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-31 16:59:59 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-31 16:59:59 +0000
commit946b4e58b59d8526d32f1fc0586d038989678f85 (patch)
tree4ab7558916b0779bce1c6f8fa99852bf71cc4431
parenta7ac3782c90ef0af6b205dd2edec41e70ca0eecf (diff)
downloadports-946b4e58b59d8526d32f1fc0586d038989678f85.tar.gz
ports-946b4e58b59d8526d32f1fc0586d038989678f85.zip
POE::Component::IRC::Plugin::Bollocks is a POE::Component::IRC plugin
generates management bullshit whenever you need it. WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-Bollocks/ PR: ports/-u Submitted by: Martin Wilke <miwi at FreeBSD.org
Notes
Notes: svn path=/head/; revision=214034
-rw-r--r--irc/Makefile1
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile33
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Bollocks/distinfo3
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Bollocks/pkg-descr4
-rw-r--r--irc/p5-POE-Component-IRC-Plugin-Bollocks/pkg-plist13
5 files changed, 54 insertions, 0 deletions
diff --git a/irc/Makefile b/irc/Makefile
index 18c23b5430d3..e73a63dfb61b 100644
--- a/irc/Makefile
+++ b/irc/Makefile
@@ -82,6 +82,7 @@
SUBDIR += p5-IRC-Bot-Hangman
SUBDIR += p5-POE-Component-IRC
SUBDIR += p5-POE-Component-IRC-Object
+ SUBDIR += p5-POE-Component-IRC-Plugin-Bollocks
SUBDIR += p5-POE-Component-Server-IRC
SUBDIR += p5-POE-Filter-IRCD
SUBDIR += party
diff --git a/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile b/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile
new file mode 100644
index 000000000000..d5f951dad9ac
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Bollocks/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: POE-Component-IRC-Plugin-Bollocks
+# Date created: 31 may 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-IRC-Plugin-Bollocks
+PORTVERSION= 0.06
+CATEGORIES= irc perl5 devel
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= A POE::Component::IRC plugin that talks bollocks.
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC
+RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Component/IRC.pm:${PORTSDIR}/irc/p5-POE-Component-IRC
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::IRC::Plugin::Bollocks.3
+
+post-install:
+.ifndef(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/irc/p5-POE-Component-IRC-Plugin-Bollocks/distinfo b/irc/p5-POE-Component-IRC-Plugin-Bollocks/distinfo
new file mode 100644
index 000000000000..0fae1749bf2d
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Bollocks/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-IRC-Plugin-Bollocks-0.06.tar.gz) = 282de67bfbc46e42554977485a2a7841
+SHA256 (POE-Component-IRC-Plugin-Bollocks-0.06.tar.gz) = 97ab82e2e407b2368f4d51cbab469eb8350bd5129e4ea9f5c50c403fd8149476
+SIZE (POE-Component-IRC-Plugin-Bollocks-0.06.tar.gz) = 20533
diff --git a/irc/p5-POE-Component-IRC-Plugin-Bollocks/pkg-descr b/irc/p5-POE-Component-IRC-Plugin-Bollocks/pkg-descr
new file mode 100644
index 000000000000..f9d39635eadd
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Bollocks/pkg-descr
@@ -0,0 +1,4 @@
+POE::Component::IRC::Plugin::Bollocks is a POE::Component::IRC plugin
+generates management bullshit whenever you need it.
+
+WWW: http://search.cpan.org/dist/POE-Component-IRC-Plugin-Bollocks/
diff --git a/irc/p5-POE-Component-IRC-Plugin-Bollocks/pkg-plist b/irc/p5-POE-Component-IRC-Plugin-Bollocks/pkg-plist
new file mode 100644
index 000000000000..dddf1b6d1f2a
--- /dev/null
+++ b/irc/p5-POE-Component-IRC-Plugin-Bollocks/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/POE/Component/IRC/Plugin/Bollocks.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/Bollocks/.packlist
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/synopsis.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin/Bollocks
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC/Plugin
+@dirrmtry %%SITE_PERL%%/POE/Component/IRC
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE