aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-12-11 14:50:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-12-11 14:50:25 +0000
commita4cb92abacde96bd2bb6a190b820aa06cda9ae69 (patch)
tree3208ecc97ff107b85f4fd97be895e6e7807486e6
parentd3bfc2b36499da46ace4b789ba512dcd0327cba3 (diff)
downloadports-a4cb92abacde96bd2bb6a190b820aa06cda9ae69.tar.gz
ports-a4cb92abacde96bd2bb6a190b820aa06cda9ae69.zip
Add RenRot, Perl utility for various processing tasks on the image files, and
give maintainership to the author per his kind agreement. WWW: http://puszcza.gnu.org.ua/projects/renrot/ Feature safe: yes
Notes
Notes: svn path=/head/; revision=287183
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/renrot/Makefile45
-rw-r--r--graphics/renrot/distinfo2
-rw-r--r--graphics/renrot/pkg-descr16
-rw-r--r--graphics/renrot/pkg-plist8
5 files changed, 72 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 74551fcb7f70..5eaba7711dd7 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -844,6 +844,7 @@
SUBDIR += rayshade
SUBDIR += reallyslick
SUBDIR += recoverjpeg
+ SUBDIR += renrot
SUBDIR += repng2jpeg
SUBDIR += rgbpaint
SUBDIR += ristretto
diff --git a/graphics/renrot/Makefile b/graphics/renrot/Makefile
new file mode 100644
index 000000000000..c465e1b33b7e
--- /dev/null
+++ b/graphics/renrot/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: RenRot
+# Date created: 11 Dec 2011
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= renrot
+PORTVERSION= 1.1
+CATEGORIES= graphics perl5
+MASTER_SITES= ftp://download.gnu.org.ua/pub/release/${PORTNAME}/
+
+MAINTAINER= zeus@ibs.dn.ua
+COMMENT= Perl utility for various processing tasks on the image files
+
+LICENSE= ART20
+
+BUILD_DEPENDS= ${SITE_PERL}/Image/ExifTool.pm:${PORTSDIR}/graphics/p5-Image-ExifTool
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+OPTIONS= IMAGEMAGICK "Enable Image::Magick module support" off
+
+MAN1= ${PORTNAME}.1
+PORTDOCS= AUTHORS README ChangeLog NEWS TODO
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_IMAGEMAGICK)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+post-install:
+ @${MKDIR} ${PREFIX}/etc/${PORTNAME}
+.for conf in colors.conf copyright.tag renrot.conf tags.conf
+ ${INSTALL_DATA} ${WRKSRC}/etc/${conf} \
+ ${PREFIX}/etc/${PORTNAME}/${conf}.sample
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/renrot/distinfo b/graphics/renrot/distinfo
new file mode 100644
index 000000000000..2fb727b1d90d
--- /dev/null
+++ b/graphics/renrot/distinfo
@@ -0,0 +1,2 @@
+SHA256 (renrot-1.1.tar.gz) = 40b084bc7ff615fef62e560010b60299d3c7a3a19e576ef7c64962fdffdd79a4
+SIZE (renrot-1.1.tar.gz) = 50446
diff --git a/graphics/renrot/pkg-descr b/graphics/renrot/pkg-descr
new file mode 100644
index 000000000000..e1dffcdc8af9
--- /dev/null
+++ b/graphics/renrot/pkg-descr
@@ -0,0 +1,16 @@
+RenRot is utility written in Perl, aiming to carry out different processing
+tasks upon the image files (especially those containing EXIF data).
+
+RenRot renames files according to the flexible name template (allowing
+DateTimeOriginal and FileModifyDate EXIF tags, if they exist, otherwise, the
+name will be set according to the current time stamp). Furthermore, RenRot
+can aggregate files according to the shooting time period.
+
+Additionally, it can losslessly rotate JPEGs and their thumbnails, based on
+Orientation EXIF tag, or given angle.
+
+The script can also put commentary into the Commentary and UserComment tags.
+Personal details can be specified via XMP tags defined in a configuration
+file.
+
+WWW: http://puszcza.gnu.org.ua/projects/renrot/
diff --git a/graphics/renrot/pkg-plist b/graphics/renrot/pkg-plist
new file mode 100644
index 000000000000..a48cc8462624
--- /dev/null
+++ b/graphics/renrot/pkg-plist
@@ -0,0 +1,8 @@
+bin/renrot
+etc/renrot/colors.conf.sample
+etc/renrot/copyright.tag.sample
+etc/renrot/renrot.conf.sample
+etc/renrot/tags.conf.sample
+@dirrm etc/renrot
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/renrot/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/renrot