aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2011-12-11 05:44:53 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2011-12-11 05:44:53 +0000
commitbe538897b815719ee0835ec13ca0195ffb58d269 (patch)
tree7a2f5a31f1ecd7cd4a463809b7e89983af7a2154
parent43f9536371f7f95a017113c7927f044b0ad4e95f (diff)
downloadports-be538897b815719ee0835ec13ca0195ffb58d269.tar.gz
ports-be538897b815719ee0835ec13ca0195ffb58d269.zip
update to 1.52; don't build or install the manpage if
NOPORTDOCS is defined Feature safe: yes
Notes
Notes: svn path=/head/; revision=287169
-rw-r--r--devel/cppcheck/Makefile6
-rw-r--r--devel/cppcheck/distinfo4
-rw-r--r--devel/cppcheck/files/patch-Makefile18
-rw-r--r--devel/cppcheck/files/patch-cli__cmdlineparser.cpp16
4 files changed, 28 insertions, 16 deletions
diff --git a/devel/cppcheck/Makefile b/devel/cppcheck/Makefile
index f31084f5fae4..6b639752992c 100644
--- a/devel/cppcheck/Makefile
+++ b/devel/cppcheck/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cppcheck
-PORTVERSION= 1.51
+PORTVERSION= 1.52
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
@@ -22,7 +22,7 @@ USE_GMAKE= yes
USE_BZIP2= yes
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include
-MAKE_ENV+= TINYXML=-ltinyxml
+MAKE_ENV+= HAVE_RULES=yes TINYXML=-ltinyxml
PLIST_FILES= bin/cppcheck
@@ -30,7 +30,7 @@ ALL_TARGET= cppcheck
.include <bsd.port.pre.mk>
-.if !defined(NO_INSTALL_MANPAGES)
+.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
diff --git a/devel/cppcheck/distinfo b/devel/cppcheck/distinfo
index 1cf09e73fd4c..aecc2fbf57df 100644
--- a/devel/cppcheck/distinfo
+++ b/devel/cppcheck/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cppcheck-1.51.tar.bz2) = 856b24f96e7c784936371457e429dd5bb7436e5fed502315e49a2cba0bebc05c
-SIZE (cppcheck-1.51.tar.bz2) = 920230
+SHA256 (cppcheck-1.52.tar.bz2) = 655e4ba4452148342089a83df09c8d2ebceb528e0811bdf83f3a1e3c830e7796
+SIZE (cppcheck-1.52.tar.bz2) = 965225
diff --git a/devel/cppcheck/files/patch-Makefile b/devel/cppcheck/files/patch-Makefile
index ae545b9bf0b5..c752b5b142e8 100644
--- a/devel/cppcheck/files/patch-Makefile
+++ b/devel/cppcheck/files/patch-Makefile
@@ -1,6 +1,18 @@
---- Makefile.orig 2011-02-06 06:14:09.000000000 -0500
-+++ Makefile 2011-02-07 15:35:58.000000000 -0500
-@@ -15,7 +15,7 @@
+--- Makefile.orig 2011-12-10 07:00:45.000000000 -0500
++++ Makefile 2011-12-10 23:10:57.000000000 -0500
+@@ -31,17 +31,17 @@
+ endif
+
+ ifndef INCLUDE_FOR_CLI
+- INCLUDE_FOR_CLI=-Ilib -Iexternals -Iexternals/tinyxml
++ INCLUDE_FOR_CLI=-Ilib -Iexternals
+ endif
+
+ ifndef INCLUDE_FOR_TEST
+- INCLUDE_FOR_TEST=-Ilib -Icli -Iexternals -Iexternals/tinyxml
++ INCLUDE_FOR_TEST=-Ilib -Icli -Iexternals
+ endif
+
BIN=$(DESTDIR)$(PREFIX)/bin
# For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux
diff --git a/devel/cppcheck/files/patch-cli__cmdlineparser.cpp b/devel/cppcheck/files/patch-cli__cmdlineparser.cpp
index a643ec09b8ee..ed0d048090ea 100644
--- a/devel/cppcheck/files/patch-cli__cmdlineparser.cpp
+++ b/devel/cppcheck/files/patch-cli__cmdlineparser.cpp
@@ -1,11 +1,11 @@
---- ./cli/cmdlineparser.cpp.orig 2011-08-14 03:45:53.000000000 -0400
-+++ ./cli/cmdlineparser.cpp 2011-09-17 03:13:23.000000000 -0400
-@@ -535,7 +535,7 @@
- if (doc.LoadFile(12+argv[i]))
- {
+--- cli/cmdlineparser.cpp.orig 2011-12-10 07:00:45.000000000 -0500
++++ cli/cmdlineparser.cpp 2011-12-10 22:32:04.000000000 -0500
+@@ -557,7 +557,7 @@
+ TiXmlDocument doc;
+ if (doc.LoadFile(12+argv[i])) {
TiXmlElement *node = doc.FirstChildElement();
-- for (; node && node->ValueStr() == "rule"; node = node->NextSiblingElement())
-+ for (; node && node->Value() == "rule"; node = node->NextSiblingElement())
- {
+- for (; node && node->ValueStr() == "rule"; node = node->NextSiblingElement()) {
++ for (; node && node->Value() == "rule"; node = node->NextSiblingElement()) {
Settings::Rule rule;
+ TiXmlElement *pattern = node->FirstChildElement("pattern");