aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-12 19:50:59 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-12 19:50:59 +0000
commitf0f8f19eec88fccc1a1879ca7b00670b7d051a35 (patch)
treef089a507f81997fde239d3767cf306db080f7e7b
parentb2e40a1cf84727ec9f276ee7e9db501f84b4bd39 (diff)
downloadports-f0f8f19eec88fccc1a1879ca7b00670b7d051a35.tar.gz
ports-f0f8f19eec88fccc1a1879ca7b00670b7d051a35.zip
Ipsumdump program summarizes TCP/IP dump files into a
self-describing ASCII format easily readable by humans and programs. Ipsumdump can read packets from network interfaces, from tcpdump files, and from existing ipsumdump files. It will transparently uncompress tcpdump or ipsumdump files when necessary. It can randomly sample traffic, filter traffic based on its contents, anonymize IP addresses, and sort packets from multiple dumps by timestamp. Also, it can optionally create a tcpdump file containing actual packet data.
Notes
Notes: svn path=/head/; revision=98008
-rw-r--r--net/Makefile1
-rw-r--r--net/ipsumdump/Makefile31
-rw-r--r--net/ipsumdump/distinfo1
-rw-r--r--net/ipsumdump/pkg-descr11
-rw-r--r--net/ipsumdump/pkg-plist1
5 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 097e8928bbb5..25662255250d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -247,6 +247,7 @@
SUBDIR += ipfw-graph
SUBDIR += iplog
SUBDIR += ipsorc
+ SUBDIR += ipsumdump
SUBDIR += ipsvd
SUBDIR += ipv6calc
SUBDIR += ipv6socket_scrub
diff --git a/net/ipsumdump/Makefile b/net/ipsumdump/Makefile
new file mode 100644
index 000000000000..acbead07aaf0
--- /dev/null
+++ b/net/ipsumdump/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ipsumdump
+# Date created: 12.01.2004
+# Whom: krion@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipsumdump
+PORTVERSION= 1.33
+CATEGORIES= net
+MASTER_SITES= http://www.icir.org/kohler/ipsumdump/
+
+MAINTAINER= krion@FreeBSD.org
+COMMENT= Produce ASCII summary of network traffic or tcpdump(1) file
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_PERL5_BUILD=yes
+USE_GMAKE= yes
+
+MAN1= ${PORTNAME}.1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/ipsumdump/distinfo b/net/ipsumdump/distinfo
new file mode 100644
index 000000000000..a2e86da08604
--- /dev/null
+++ b/net/ipsumdump/distinfo
@@ -0,0 +1 @@
+MD5 (ipsumdump-1.33.tar.gz) = 237cbe89861cb7e6a676438350860b70
diff --git a/net/ipsumdump/pkg-descr b/net/ipsumdump/pkg-descr
new file mode 100644
index 000000000000..08018e0f8479
--- /dev/null
+++ b/net/ipsumdump/pkg-descr
@@ -0,0 +1,11 @@
+Ipsumdump program summarizes TCP/IP dump files into a
+self-describing ASCII format easily readable by humans and
+programs. Ipsumdump can read packets from network interfaces,
+from tcpdump files, and from existing ipsumdump files. It will
+transparently uncompress tcpdump or ipsumdump files when
+necessary. It can randomly sample traffic, filter traffic based
+on its contents, anonymize IP addresses, and sort packets from
+multiple dumps by timestamp. Also, it can optionally create a
+tcpdump file containing actual packet data.
+
+WWW: http://www.icir.org/kohler/ipsumdump/
diff --git a/net/ipsumdump/pkg-plist b/net/ipsumdump/pkg-plist
new file mode 100644
index 000000000000..adc709caa914
--- /dev/null
+++ b/net/ipsumdump/pkg-plist
@@ -0,0 +1 @@
+bin/ipsumdump