aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-24 12:24:51 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-24 12:24:51 +0000
commit13038080060b6b10706595a36fcd149c22087782 (patch)
treeeadf79b380e452c423a37f0305e95113980e5e8f
parentc53060edcd71570ae8f3b059ca98d792042a2c77 (diff)
downloadports-13038080060b6b10706595a36fcd149c22087782.tar.gz
ports-13038080060b6b10706595a36fcd149c22087782.zip
add p5-Shout
Perl glue for libshout MP3 streaming source library PR: 26677 Submitted by: Leo Kim <leo@florida.sarang.net>
Notes
Notes: svn path=/head/; revision=43008
-rw-r--r--audio/p5-Shout/Makefile26
-rw-r--r--audio/p5-Shout/distinfo1
-rw-r--r--audio/p5-Shout/files/patch-aa13
-rw-r--r--audio/p5-Shout/files/patch-ab10
-rw-r--r--audio/p5-Shout/pkg-comment1
-rw-r--r--audio/p5-Shout/pkg-descr10
-rw-r--r--audio/p5-Shout/pkg-plist6
7 files changed, 67 insertions, 0 deletions
diff --git a/audio/p5-Shout/Makefile b/audio/p5-Shout/Makefile
new file mode 100644
index 000000000000..b4c57f598722
--- /dev/null
+++ b/audio/p5-Shout/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Shout
+# Date created: 18 April 2001
+# Whom: leo
+#
+# $FreeBSD$
+#
+
+PORTNAME= Shout
+PORTVERSION= 0.99
+CATEGORIES= audio perl5
+MASTER_SITES= http://developer.icecast.org/libshout/releases/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= leo@florida.sarang.net
+
+LIB_DEPENDS= shout.1:${PORTSDIR}/audio/libshout
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Shout.3
+
+pre-configure:
+ @(cd ${WRKSRC} && ${RM} example.pl example2.pl)
+
+.include <bsd.port.mk>
diff --git a/audio/p5-Shout/distinfo b/audio/p5-Shout/distinfo
new file mode 100644
index 000000000000..ad04a4b2fa47
--- /dev/null
+++ b/audio/p5-Shout/distinfo
@@ -0,0 +1 @@
+MD5 (Shout-0.99.tar.gz) = a4cbf46d1107a54fff61d457ac46dd35
diff --git a/audio/p5-Shout/files/patch-aa b/audio/p5-Shout/files/patch-aa
new file mode 100644
index 000000000000..8dcc1278f7f5
--- /dev/null
+++ b/audio/p5-Shout/files/patch-aa
@@ -0,0 +1,13 @@
+--- Makefile.PL.orig Wed Apr 18 13:29:39 2001
++++ Makefile.PL Wed Apr 18 13:31:05 2001
+@@ -4,8 +4,8 @@
+ WriteMakefile(
+ 'NAME' => 'Shout',
+ 'VERSION_FROM' => 'Shout.pm', # finds $VERSION
+- 'LIBS' => ['-lshout'], # e.g., '-lm'
++ 'LIBS' => ['-L/usr/local/lib -lshout'], # e.g., '-lm'
+ 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
+- 'INC' => '', # e.g., '-I/usr/include/other'
++ 'INC' => '-I/usr/local/include', # e.g., '-I/usr/include/other'
+ 'MYEXTLIB' => ''
+ );
diff --git a/audio/p5-Shout/files/patch-ab b/audio/p5-Shout/files/patch-ab
new file mode 100644
index 000000000000..7ce76e1a4805
--- /dev/null
+++ b/audio/p5-Shout/files/patch-ab
@@ -0,0 +1,10 @@
+--- MANIFEST.orig Wed Apr 18 13:58:36 2001
++++ MANIFEST Wed Apr 18 13:58:43 2001
+@@ -3,7 +3,5 @@
+ Makefile.PL
+ Shout.pm
+ Shout.xs
+-example.pl
+-example2.pl
+ test.pl
+ typemap
diff --git a/audio/p5-Shout/pkg-comment b/audio/p5-Shout/pkg-comment
new file mode 100644
index 000000000000..1160aa098393
--- /dev/null
+++ b/audio/p5-Shout/pkg-comment
@@ -0,0 +1 @@
+Perl glue for libshout MP3 streaming source library
diff --git a/audio/p5-Shout/pkg-descr b/audio/p5-Shout/pkg-descr
new file mode 100644
index 000000000000..c865a1a81d5a
--- /dev/null
+++ b/audio/p5-Shout/pkg-descr
@@ -0,0 +1,10 @@
+This module is an object-oriented interface to libshout, an MP3 streaming
+library that allows applications to easily communicate and broadcast to an
+Icecast streaming media server. It handles the socket connections, metadata
+communication, and data streaming for the calling application, and lets
+developers focus on feature sets instead of implementation details.
+
+WWW: http://developer.icecast.org/libshout/
+
+- Leo
+leo@florida.sarang.net
diff --git a/audio/p5-Shout/pkg-plist b/audio/p5-Shout/pkg-plist
new file mode 100644
index 000000000000..30f9f8a27b08
--- /dev/null
+++ b/audio/p5-Shout/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Shout.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout/Shout.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout/Shout.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Shout